Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 31st October 2009, 15:22
mooseman mooseman is offline
Junior Member
 
Join Date: Dec 2006
Posts: 22
Thanks: 1
Thanked 2 Times in 1 Post
Default ispconfig 3 mydns master to ispconfig 2 bind slave

Hi,

I attempted to create a "master" dns server in ISPconfig 3 using mydns and have it replicate to my ispconfig 2 bind dns. Both servers are being NATed behind respective firewalls.

I updated the mydns.conf with the following options:

allow-axfr = yes
allow-update = yes
notify-enabled = yes
notify-source = (public NATed IP of mydns master)

I created the zone on the master ispconfig 3 server (mydns) and created a slave zone on the ispconfig 2 (bind 9) server pointing to the master.

The initial axfr goes through but any updates to the zone are not transferred with the following error in the log:

I receive the following in the syslog of the ispconfig 2 bind server:

Oct 31 10:03:30 (server) named[(PID)]: client (public.IP.of.mydns)#47075: received notify for zone '(domain).com'
Oct 31 10:03:30 (server) named[(PID)]: zone .com/IN: Transfer started.
Oct 31 10:03:30 (server) named[(PID)]: transfer of '(domain).com/IN' from (public.IP.of.mydns)#53: connected using (private.IP.of.mydns)#35684
Oct 31 10:03:30 (server) named[(PID)]: transfer of '(domain).com/IN' from (public.IP.of.mydns)#53: failed while receiving responses: end of file
Oct 31 10:03:30 (server) named[(PID)]: transfer of '(domain).com/IN' from (public.IP.of.mydns)#53: end of transfer


Is the "failed while receiving responses: end of file" occurring because of the private ip being sent?? is "notify-source = " config option of mydns supposed to fix that?

Any help would be appreciated.

Thanks,
Reply With Quote
Sponsored Links
  #2  
Old 1st November 2009, 11:12
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,420 Times in 4,262 Posts
Default

Please try to disable ixfr in bind on the slave:

http://www.howtoforge.com/forums/showthread.php?t=37727
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 2nd November 2009, 01:11
mooseman mooseman is offline
Junior Member
 
Join Date: Dec 2006
Posts: 22
Thanks: 1
Thanked 2 Times in 1 Post
Default

That Worked!...

I also should be leaving out the "notify-source = xxx" statement in the mydns.conf

Great, Thanks!

--
MoOSeMaN
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Permission Denied Bind Slave Server Problems wxman Server Operation 17 22nd March 2014 12:30
problem with master slave nephish HOWTO-Related Questions 2 2nd May 2007 15:23
MyDNS and ISPConfig CoDonCo General 3 27th July 2006 08:25
Pri & Slave DNS HOWTO (FC4) ppettigrew Suggest HOWTO 0 1st April 2006 15:35
Bind-Chroot-Howto (Debian) spaz HOWTO-Related Questions 5 9th March 2006 14:50


All times are GMT +2. The time now is 13:19.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.