#1  
Old 19th October 2009, 12:02
marcgeldon marcgeldon is offline
Junior Member
 
Join Date: Oct 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default Problem with Jailkit

I installed our new server like described in this How-To:
http://www.howtoforge.com/perfect-se...10-ispconfig-3

Everything works fine.

But no I've created a new shell user with "Chroot Shell" = Jailkit.

If I try to login with the correct shell username and password via SSH the server just disconnects.

I have no problem login if I set the "Chroot Shell" to "none".

Can somebody help?

Best wishes,

Marc
Reply With Quote
Sponsored Links
  #2  
Old 19th October 2009, 13:22
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

Take a lok at your syslog, auth.log and messages log to get more details on this problem.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 19th October 2009, 13:26
marcgeldon marcgeldon is offline
Junior Member
 
Join Date: Oct 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

SYSLOG
Code:
Oct 19 12:25:15 server301 console-kit-daemon[13803]: CRITICAL: cannot initialize libpolkit
AUTH.LOG
Code:
Oct 19 12:23:24 server301 sshd[13495]: Accepted password for XXX from 95.116.241.178 port 63005 ssh2
Oct 19 12:23:24 server301 sshd[13495]: pam_unix(sshd:session): session opened for user XXX by (uid=0)
Oct 19 12:23:24 server301 jk_chrootsh[13563]: abort, the group ID from /etc/passwd (5004) does not match the group ID we run with (5005)
Oct 19 12:23:24 server301 sshd[13495]: pam_unix(sshd:session): session closed for user XXX
Reply With Quote
  #4  
Old 19th October 2009, 13:28
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

Please try to delete the shell user and recreate it. Also make sure that you dont have selinux enabled.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 19th October 2009, 13:35
marcgeldon marcgeldon is offline
Junior Member
 
Join Date: Oct 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I've deleted the user and recreated it. Still does not work. Same problems in logfiles.

SELinux is NOT enabled on my system.
Reply With Quote
  #6  
Old 20th October 2009, 15:02
marcgeldon marcgeldon is offline
Junior Member
 
Join Date: Oct 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I deleted the site and recreated it (also the shell users). Now it works.
Reply With Quote
Reply

Bookmarks

Tags
jailkit chroot shell

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange email problem for one of my domains... any help appreciated paulrobert_a Installation/Configuration 5 9th August 2010 15:15
BIG Problem Postfix issue admins Installation/Configuration 11 13th November 2009 11:05
Bug? Jailkit / chroot crashed server grigra General 19 15th October 2009 10:48
postfix mysql on fedora core5 igongora Installation/Configuration 7 17th April 2007 05:40
SMTP TLS Problem with Mail Client dschmid Installation/Configuration 1 9th December 2005 02:56


All times are GMT +2. The time now is 03:51.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.