#1  
Old 17th October 2009, 05:51
Kas Kas is offline
Junior Member
 
Join Date: Oct 2009
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Default Problem with 2 domains and DNS

I have 2 domains. This domains resolved correctly the server ip.

I add first domain and create zone dns.

The domain its works

I add second domain and create zone dns.

Now, when you access to second domain, automatic redirect to fisrts domain.

what is the problem?

Sorry for my english and thanks for all
Reply With Quote
Sponsored Links
  #2  
Old 17th October 2009, 10:51
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

I dont think that this is dns related. I guess you tried to access the websites? Then make sure that you selected the correct IP address in the website dettings for each website and not *.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
Kas (17th October 2009)
  #3  
Old 17th October 2009, 13:31
Kas Kas is offline
Junior Member
 
Join Date: Oct 2009
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Default

First Domain:



Quote:
<Directory /var/www/bibliotecahentai.net>
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

<VirtualHost 213.186.57.137:80>
DocumentRoot /var/www/bibliotecahentai.net/web

ServerName bibliotecahentai.net
ServerAlias www.bibliotecahentai.net
ServerAdmin webmaster@bibliotecahentai.net

ErrorLog /var/log/ispconfig/httpd/bibliotecahentai.net/error.log

ErrorDocument 400 /error/400.html
ErrorDocument 401 /error/401.html
ErrorDocument 403 /error/403.html
ErrorDocument 404 /error/404.html
ErrorDocument 405 /error/405.html
ErrorDocument 500 /error/500.html
ErrorDocument 503 /error/503.html

<Directory /var/www/bibliotecahentai.net/web>
Options FollowSymLinks
AllowOverride Indexes AuthConfig Limit FileInfo
Order allow,deny
Allow from all
</Directory>
<Directory /var/www/clients/client0/web4/web>
Options FollowSymLinks
AllowOverride Indexes AuthConfig Limit FileInfo
Order allow,deny
Allow from all
</Directory>

# suexec enabled
SuexecUserGroup web4 client3
# php as fast-cgi enabled
<Directory /var/www/bibliotecahentai.net/web>
AddHandler fcgid-script .php .php3 .php4 .php5
FCGIWrapper /var/www/php-fcgi-scripts/web4/.php-fcgi-starter .php
Options +ExecCGI
AllowOverride all
Order allow,deny
Allow from all
</Directory>


</VirtualHost>
Quote:
ks30935:~# dig bibliotecahentai.net

; <<>> DiG 9.5.1-P3 <<>> bibliotecahentai.net
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 51350
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;bibliotecahentai.net. IN A

;; ANSWER SECTION:
bibliotecahentai.net. 86400 IN A 213.186.57.137

;; AUTHORITY SECTION:
bibliotecahentai.net. 86400 IN NS ks30935.kimsufi.com.
bibliotecahentai.net. 86400 IN NS ns.kimsufi.com.

;; Query time: 3 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Sat Oct 17 12:27:38 2009
;; MSG SIZE rcvd: 104
Second Domain:



Quote:
<Directory /var/www/imageshentai.com>
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

<VirtualHost 213.186.57.137:80>
DocumentRoot /var/www/imageshentai.com/web

ServerName imageshentai.com
ServerAdmin webmaster@imageshentai.com

ErrorLog /var/log/ispconfig/httpd/imageshentai.com/error.log

ErrorDocument 400 /error/400.html
ErrorDocument 401 /error/401.html
ErrorDocument 403 /error/403.html
ErrorDocument 404 /error/404.html
ErrorDocument 405 /error/405.html
ErrorDocument 500 /error/500.html
ErrorDocument 503 /error/503.html

<Directory /var/www/imageshentai.com/web>
Options FollowSymLinks
AllowOverride Indexes AuthConfig Limit FileInfo
Order allow,deny
Allow from all
</Directory>
<Directory /var/www/clients/client0/web5/web>
Options FollowSymLinks
AllowOverride Indexes AuthConfig Limit FileInfo
Order allow,deny
Allow from all
</Directory>

# php as fast-cgi enabled
<Directory /var/www/imageshentai.com/web>
AddHandler fcgid-script .php .php3 .php4 .php5
FCGIWrapper /var/www/php-fcgi-scripts/web5/.php-fcgi-starter .php
Options +ExecCGI
AllowOverride all
Order allow,deny
Allow from all
</Directory>


</VirtualHost>
Quote:
ks30935:~# dig imageshentai.com

; <<>> DiG 9.5.1-P3 <<>> imageshentai.com
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 52071
;; flags: qr aa; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 0

;; QUESTION SECTION:
;imageshentai.com. IN A

;; ANSWER SECTION:
imageshentai.com. 86400 IN A 213.186.57.137

;; AUTHORITY SECTION:
imageshentai.com. 86400 IN NS ks30935.kimsufi.com.
imageshentai.com. 86400 IN NS ns.kimsufi.com.

;; Query time: 2 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Sat Oct 17 12:28:34 2009
;; MSG SIZE rcvd: 97
If you access to www.bibliotecahentai.net dont have problem, but you access to www.imageshentai.com, redirect to www.bibliotecahentai.net
Reply With Quote
  #4  
Old 17th October 2009, 13:35
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

I dont get redirected when I access www.imageshentai.com. I get two different sites which both seem to be working. You should check the hosts file on your workstation, maybe you defined some kind of dns override there.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 17th October 2009, 13:44
Kas Kas is offline
Junior Member
 
Join Date: Oct 2009
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Appears this message in imageshentai.com?

Quote:
Por labores de mantenimiento en el servidor, la subida de imagenes estara desactivada temporalmente


For maintenance in the server, the upload of images will be deactivated temporarily
If it appears, is for you still see the old server
Reply With Quote
  #6  
Old 17th October 2009, 13:48
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

Yes, thats the message that I get. Be aware that changes in DNS take up to 48 hours until they get active in all dns caches.

Also make sure that your dns server is really the authoritive dns server for this domain. You can check your domain e.g. with www.intodns.com
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange email problem for one of my domains... any help appreciated paulrobert_a Installation/Configuration 5 9th August 2010 15:15
Exim Gateway with mailwatch (Unable to receive emails) siul0_0 HOWTO-Related Questions 10 9th May 2009 00:00
Getting an ISPConfig server to resolve domains for the DNS Newbie! dpicella Installation/Configuration 4 2nd May 2009 16:40
DNS Configuration Problems VMartins Installation/Configuration 10 24th July 2007 15:40
Unable send receive emails vassilis3 Installation/Configuration 15 19th May 2007 15:34


All times are GMT +2. The time now is 12:46.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.