#1  
Old 2nd October 2009, 17:19
ninjao ninjao is offline
Junior Member
 
Join Date: Oct 2009
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default Ispconfig 3 mail not working

Hi,

I have a fresh install of ISPconfig 3. I have created mail accounts and set it up like I think it should be... mxtoolbox.com says that im ok..

however nothing works. No internal mail, no external mail.

But heres the kicker, when i rebooted the server the mail was sent... wtf?

My DNS records are:

A epibrate.com. 87.98.171.221 0
A mail 87.98.171.221 0
A www 87.98.171.221 0
MX epibrate.com. epibrate.com. 10
NS epibrate.com. r28466.ovh.net. 0
NS epibrate.com. snds1.ovh.net. 0

Are those correct?

Please feel free to ask questions i will be monitoring this thread and will reply very quickly!

Thanks!
Reply With Quote
Sponsored Links
  #2  
Old 3rd October 2009, 17:39
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

Any errors in your mail log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 3rd October 2009, 18:32
ninjao ninjao is offline
Junior Member
 
Join Date: Oct 2009
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Code:
Oct  3 04:50:01 stock pop3d: Connection, ip=[::ffff:127.0.0.1]
Oct  3 04:50:01 stock pop3d: Disconnected, ip=[::ffff:127.0.0.1]
Oct  3 04:50:02 stock imapd: Connection, ip=[::ffff:127.0.0.1]
Oct  3 04:50:02 stock imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0
Oct  3 04:50:02 stock postfix/smtpd[23017]: connect from localhost.localdomain[127.0.0.1]
Oct  3 04:50:02 stock postfix/smtpd[23017]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
Oct  3 04:50:02 stock postfix/smtpd[23017]: disconnect from localhost.localdomain[127.0.0.1]
Oct  3 04:50:48 stock postfix/qmgr[4407]: 85BE6CECF3: from=<www-data@r28466.ovh.net>, size=993, nrcpt=1 (queue active)
Oct  3 04:50:48 stock postfix/qmgr[4407]: 12A93CECF2: from=<www-data@r28466.ovh.net>, size=794, nrcpt=1 (queue active)
Oct  3 04:50:48 stock amavis[22388]: (22388-01) (!)connect_to_sql: unable to connect to DSN 'DBI:mysql:database=dbispconfig;host=127.0.0.1;port=3306':Access denied for user 'ispconfig'@'localhost' (using password: YES)
Oct  3 04:50:48 stock amavis[22388]: (22388-01) (!!)TROUBLE in process_request: connect_to_sql: unable to connect to any dataset at (eval 86) line 241,<GEN26> line 3.
Oct  3 04:50:48 stock amavis[22388]: (22388-01) (!)Requesting process rundown after fatal error
Oct  3 04:50:48 stock amavis[22389]: (22389-01) (!)connect_to_sql: unable to connect to DSN 'DBI:mysql:database=dbispconfig;host=127.0.0.1;port=3306':Access denied for user 'ispconfig'@'localhost' (using password: YES)
Oct  3 04:50:48 stock amavis[22389]: (22389-01) (!!)TROUBLE in process_request: connect_to_sql: unable to connect to any dataset at (eval 86) line 241,<GEN26> line 3.
Oct  3 04:50:48 stock amavis[22389]: (22389-01) (!)Requesting process rundown after fatal error
Oct  3 04:50:48 stock postfix/smtp[23066]: 85BE6CECF3: to=<email>, relay=127.0.0.1[127.0.0.1]:10024, delay=54995, delays=54994/0.01/0.01/0.49, dsn=4.3.2, status=deferred (host 127.0.0.1[127.0.0.1] said: 421 4.3.2 Service shutting down, closing channel (in reply to RCPT TO command))
Oct  3 04:50:48 stock postfix/smtp[23067]: 12A93CECF2: to=<epibrate@gmail.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=54993, delays=54992/0.02/0.01/0.75, dsn=4.3.2, status=deferred (host 127.0.0.1[127.0.0.1] said: 421 4.3.2 Service shutting down, closing channel (in reply to RCPT TO command))
Oct  3 04:55:02 stock imapd: Connection, ip=[::ffff:127.0.0.1]
Oct  3 04:55:02 stock imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0
Oct  3 04:55:02 stock pop3d: Connection, ip=[::ffff:127.0.0.1]
Oct  3 04:55:02 stock pop3d: Disconnected, ip=[::ffff:127.0.0.1]
Oct  3 04:55:02 stock postfix/smtpd[599]: connect from localhost.localdomain[127.0.0.1]
Oct  3 04:55:02 stock postfix/smtpd[599]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
Oct  3 04:55:02 stock postfix/smtpd[599]: disconnect from localhost.localdomain[127.0.0.1]
Oct  3 04:55:48 stock postfix/qmgr[4407]: 831D1CED02: from=<support@epibrate.com>, size=737, nrcpt=1 (queue active)
Oct  3 04:55:48 stock postfix/qmgr[4407]: D9BE8CECFB: from=<www-data@r28466.ovh.net>, size=1000, nrcpt=1 (queue active)
Oct  3 04:55:48 stock postfix/qmgr[4407]: 6CBF5CECFA: from=<www-data@r28466.ovh.net>, size=801, nrcpt=1 (queue active)
Oct  3 04:55:48 stock amavis[23070]: (23070-01) (!)connect_to_sql: unable to connect to DSN 'DBI:mysql:database=dbispconfig;host=127.0.0.1;port=3306':Access denied for user 'ispconfig'@'localhost' (using password: YES)
p.s. du kannst auch in deutsch antworten wenn das leichter für dich ist! danke nochmal!

Last edited by ninjao; 9th May 2010 at 22:03.
Reply With Quote
  #4  
Old 4th October 2009, 13:32
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

Quote:
Oct 3 04:50:48 stock amavis[22388]: (22388-01) (!)connect_to_sql: unable to connect to DSN 'DBI:mysql:database=dbispconfig;host=127.0.0.1;por t=3306':Access denied for user 'ispconfig'@'localhost' (using password: YES)
Oct 3 04:50:48 stock amavis[22388]: (22388-01) (!!)TROUBLE in process_request: connect_to_sql: unable to connect to any dataset at (eval 86) line 241,<GEN26> line 3.
Oct 3 04:50:48 stock amavis[22388]: (22388-01) (!)Requesting process rundown after fatal error
Oct 3 04:50:48 stock amavis[22389]: (22389-01) (!)connect_to_sql: unable to connect to DSN 'DBI:mysql:database=dbispconfig;host=127.0.0.1;por t=3306':Access denied for user 'ispconfig'@'localhost' (using password: YES)
Oct 3 04:50:48 stock amavis[22389]: (22389-01) (!!)TROUBLE in process_request: connect_to_sql: unable to connect to any dataset at (eval 86) line 241,<GEN26> line 3.
Oct 3 04:50:48 stock amavis[22389]: (22389-01) (!)Requesting process rundown after fatal error
Please check if the MySQL user and password are correct in your amavisd configuration.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 4th October 2009, 23:03
ninjao ninjao is offline
Junior Member
 
Join Date: Oct 2009
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi thanks for the reply,

I tried to find the config file but was unsuccessful.

:/# locate amavisd.conf
/usr/share/doc/amavisd-new/examples/amavisd.conf-default.gz
/usr/share/doc/amavisd-new/examples/amavisd.conf-sample.gz

Locate also only seems to find that? Maybe that is the problem.

Also I never actually defined or setup amavisd... was this done automatically by ISPconfig?

I don't know if you are familiar with the hosting provider OVH.co.uk but I am using an RPS server of theirs which comes with a pre-installed ISPconfig 3 distribution. So I didnt install any of this stuff myself.

Any Idea how I might proceed?
Reply With Quote
  #6  
Old 5th October 2009, 12:38
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,495
Thanks: 835
Thanked 5,534 Times in 4,352 Posts
Default

Which Linux distribution do you use?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help get mail to work (can't recieve and apperently can't send) omega13a Installation/Configuration 19 20th August 2009 22:06
Loads of mysql connections to dbispconfig StrikerNL General 2 5th March 2009 15:31
ispconfig postconf sasl smtpd mail not working vinodadhikary Installation/Configuration 8 6th April 2008 17:09
Postfix problem: lost connection after CONNECT from unknown fernando_torrez Server Operation 5 30th November 2007 15:17
ISP-Ubuntu breezy ispconfig dns email e-mail working finally yellowjelly HOWTO-Related Questions 0 19th November 2005 21:30


All times are GMT +2. The time now is 22:19.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.