Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 8th September 2009, 02:19
FadeOUT FadeOUT is offline
Member
 
Join Date: Apr 2007
Posts: 30
Thanks: 3
Thanked 2 Times in 1 Post
Unhappy Webmail not working - ISPConfig 3

Hi,

Although it originally worked, after running some updates, Squirrelmail no longer works (giving a 500 error). Since then, I have downloaded and installed the latest version of ISPConfig, but this has not affected the situation.

The Apache log shows the following when I attempt to access the webmail directory:
  • SoftException in Application.cpp:202: Script "/var/www/webmail/index.php" resolving to "/usr/share/squirrelmail//index.php" not within configured docroot

The installation is of ISPConfig 3 on Ubuntu 64bit using the Perfect Setup instructions. Webmail was originally working. It is installed within a VPS, but was working.

If I copy the Squirrelmail to /var/www instead of using a symlink, I get these errors in the Apache logs, instead:
  • SecurityException in Application.cpp:440: Handler not found in configuration
  • Caused by KeyNotFoundException in Configuration.cpp:234: Handler "application/x-httpd-php" not found

Any ideas... please..?
Reply With Quote
Sponsored Links
  #2  
Old 8th September 2009, 20:12
ivomendonca ivomendonca is offline
Banned
 
Join Date: Sep 2009
Posts: 132
Thanks: 10
Thanked 14 Times in 8 Posts
Default Try to reinstall.

apt-get remove --purge squirrelmail
apt-get install squirrelmail
cd /usr/share/squirrelmail
./configure

and add a link pointing to /var/www/webmail/
Reply With Quote
  #3  
Old 9th September 2009, 17:44
FadeOUT FadeOUT is offline
Member
 
Join Date: Apr 2007
Posts: 30
Thanks: 3
Thanked 2 Times in 1 Post
Default

Quote:
Originally Posted by ivomendonca View Post
apt-get remove --purge squirrelmail
apt-get install squirrelmail
cd /usr/share/squirrelmail
./configure

and add a link pointing to /var/www/webmail/
Thanks... Worth a try, but I'm still getting the same error.
Reply With Quote
  #4  
Old 9th September 2009, 18:12
ivomendonca ivomendonca is offline
Banned
 
Join Date: Sep 2009
Posts: 132
Thanks: 10
Thanked 14 Times in 8 Posts
Default This is not the normal procedure to do this.

If I copy the Squirrelmail to /var/www instead of using a symlink, I get these errors in the Apache logs, instead:

* SecurityException in Application.cpp:440: Handler not found in configuration
* Caused by KeyNotFoundException in Configuration.cpp:234: Handler "application/x-httpd-php" not found


If you remove and delete Squirrelmail files manualy, and install normaly as you shoud, this will work, dont do crazy stuff and ask help from there.

The better way is allways the clean and normal way.

http://www.howtoforge.org/perfect-se...-ispconfig3-p5 this "way" works even when updating.


Personaly Ubunto is for workstations and normal Debian is for servers maybe is that your first problem.

by.

Last edited by ivomendonca; 9th September 2009 at 18:18. Reason: update
Reply With Quote
  #5  
Old 9th September 2009, 18:31
FadeOUT FadeOUT is offline
Member
 
Join Date: Apr 2007
Posts: 30
Thanks: 3
Thanked 2 Times in 1 Post
Default

Quote:
Originally Posted by ivomendonca View Post
If I copy the Squirrelmail to /var/www instead of using a symlink, I get these errors in the Apache logs, instead:

* SecurityException in Application.cpp:440: Handler not found in configuration
* Caused by KeyNotFoundException in Configuration.cpp:234: Handler "application/x-httpd-php" not found


If you remove and delete Squirrelmail files manualy, and install normaly as you shoud, this will work, dont do crazy stuff and ask help from there.

The better way is allways the clean and normal way.

http://www.howtoforge.org/perfect-se...-ispconfig3-p5 this "way" works even when updating.


Personaly Ubunto is for workstations and normal Debian is for servers maybe is that your first problem.

by.
I didn't think that copying it would actually be useful functionally, but just might be some kind of guide as to the problem (I was wondering if suphp was broken for some reason). It's interesting that you got the same error - that presumably rules suphp out of the equation.

Anyway, yes, I removed / purged everything and reinstalled as in the Perfect Setup and it still didn't work - thanks for the idea, though.
Reply With Quote
  #6  
Old 9th September 2009, 18:40
ivomendonca ivomendonca is offline
Banned
 
Join Date: Sep 2009
Posts: 132
Thanks: 10
Thanked 14 Times in 8 Posts
Default Do you have this line ok?

My last tip

/etc/apache2/conf.d# nano apache2-doc

Alias /webmail /usr/share/squirrelmail/

<Directory "/usr/share/squirrelmail/">
Options Indexes FollowSymlinks
AllowOverride None
Order allow,deny
Allow from all
AddDefaultCharset off
</Directory>

Suphp is the problem, ok good luck resolving

Last edited by ivomendonca; 9th September 2009 at 18:46.
Reply With Quote
Reply

Bookmarks

Tags
squirrelmail, suphp, symlink, webmail

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3.0.0.8 RC1 released till General 92 22nd February 2010 10:52
ISPConfig 3.0.1 released till General 36 29th March 2009 15:30
ISPConfig 3.0.0.7 Beta released till General 78 24th December 2008 12:47
Round Cube webmail with ISPConfig Hagforce General 31 26th March 2007 01:19
Webmail on port 80, ISPConfig on port 81 wonka Installation/Configuration 5 3rd March 2007 16:46


All times are GMT +2. The time now is 19:32.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.