#1  
Old 31st August 2009, 04:41
atjensen11 atjensen11 is offline
Senior Member
 
Join Date: Dec 2007
Posts: 199
Thanks: 9
Thanked 6 Times in 6 Posts
Default Cannot login to phpmyadmin

I had followed the Perfect Server with ISPConfig3 tutorial for Debian Lenny.

Last week, I had an issue with phpmyadmin. Everytime I visited the site, there were strange characters in the username filed. Despite deleting them and typing in the correct credentials, the login always failed.

I double checked that I could login to MySQL on the command line with the same credentials and that worked.

In an attempt to fix the problem, I uninstalled and reinstalled phpmyadmin. It appears that I may have a different problem now. Whenever I browse to the phpmyadmin site, I get an error. The text above the area where the login credentials would appear says the following:

Code:
phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in your configuration and make sure that they correspond to the information given by the administrator of the MySQL server.
In the box below this text, is another more specific error message. It reads:
Code:
Error
MySQL said:  
#1045 - Access denied for user 'root'@'localhost' (using password: NO)
Please note that I get these errors just by browsing to the phpmyadmin page. There are no fields presented to me as the user to even enter the user and/or password. It appears to me at least, that phpmyadmin is trying to automatically login to the site as the root user without a password, which obivously won't work.

Again, I can login to MySQL on the command line. Any suggestions?
Reply With Quote
Sponsored Links
  #2  
Old 31st August 2009, 12:37
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

Please check the authentication settings in phpMyAdmin's config.php file.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 31st August 2009, 15:49
atjensen11 atjensen11 is offline
Senior Member
 
Join Date: Dec 2007
Posts: 199
Thanks: 9
Thanked 6 Times in 6 Posts
Default

A short while after submitting my post, I found information online regarding the phpmyadmin configuration file.

After the reinstallation, the authentication type was set to "config". I changed it to "cookie" and the phpmyadmin login screen began to operate again as I expected.

Thanks.
Reply With Quote
  #4  
Old 31st August 2009, 18:07
longvnit longvnit is offline
Junior Member
 
Join Date: Mar 2009
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Config $cfg['Servers'][$i]['auth_type'] = http after login with your username and password.
$cfg['Servers'][$i]['auth_type'] = 'http'; // Authentication method (config, http or cookie based)?

Last edited by falko; 1st September 2009 at 15:26. Reason: Removed links - looks like spam
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Webmail problems with only one domain? compner Installation/Configuration 14 16th February 2010 16:59
Centos 5.2 + ISPConfig 3 tutorial - Problem with email tanakskool Server Operation 1 3rd June 2009 16:22
phpmyadmin login problem ddouma Installation/Configuration 14 20th January 2009 02:33
PHPmyadmin login and pasword ? specon Installation/Configuration 2 26th April 2008 12:31
Unable to authenticate to SMTP server ashkev Installation/Configuration 15 6th February 2007 17:46


All times are GMT +2. The time now is 06:39.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.