#1  
Old 20th July 2009, 21:02
madmerlin madmerlin is offline
Junior Member
 
Join Date: Jun 2009
Posts: 21
Thanks: 2
Thanked 0 Times in 0 Posts
Default relay denied

I'm trying to use thunderbird to send email from an external location. Receiving email works perfectly via IMAp.
For the SMTP server settings I'm using the server via port:25, and have Security and Authentication, Use name and password checked... using the user's name as his email address. I have TLS, if available enabled as well.

/var/log/mail.info:
Code:
554 5.7.1 <user@hisdomain.com>: Relay access denied; from=<me@mydomain.ca> to=<user@hisdomain.com> proto=SMTP helo=<[192.168.1.133]>
snipet from main.cf
Code:
relayhost =
smtpd_sasl_authenticated_header = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination
smtpd_tls_security_level = may
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
relay_domains = mysql:/etc/postfix/mysql-virtual_relaydomains.cf
maildrop snipet from master.cf:
Code:
maildrop  unix  -       n       n       -       -       pipe
  flags=R user=vmail argv=/usr/bin/maildrop -d vmail ${extension} ${recipient} ${user} ${nexthop} ${sender}
Used the perfect server ubuntu 9.04 + ISPconfig3 as my guide.

Thanks much,
MM
Reply With Quote
Sponsored Links
  #2  
Old 20th July 2009, 23:18
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,259 Times in 4,123 Posts
Default

Your mail client did not authenticate itself with smtp-auth. Please enable smtp authentication in the email client.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 20th July 2009, 23:33
madmerlin madmerlin is offline
Junior Member
 
Join Date: Jun 2009
Posts: 21
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
Your mail client did not authenticate itself with smtp-auth. Please enable smtp authentication in the email client.
Using Thunderbird I've tried all 4 authentication options...

Security and Authentication
Use name and password is enabled. (using email address as user)
Use secure connection has 4 options and I've tried all 4.
No
TLS if available
TLS
SSL

TLS option gives "Unable to connect to SMTP server myserver via STARTTLS since it doesn't support EHLO.

using TLS if available or NO gives the relay error I quoted above.
Reply With Quote
  #4  
Old 21st July 2009, 08:18
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,259 Times in 4,123 Posts
Default

Please post all messages that appear in the mail log when you try to send a meial. There must be more lines then just the line you posted.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 21st July 2009, 17:53
madmerlin madmerlin is offline
Junior Member
 
Join Date: Jun 2009
Posts: 21
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
Please post all messages that appear in the mail log when you try to send a meial. There must be more lines then just the line you posted.
From /var/log/mail.log:
Code:
Jul 21 08:47:42 dbl postfix/smtpd[25947]: NOQUEUE: reject: RCPT from externalserver.domain.com[x.x.x.x]: 554 5.7.1 <user@hisdomain.com>: Relay access denied; from=<me@mydomain.ca> to=<user@hisdomain.com> proto=SMTP helo=<[192.168.1.133]>
Jul 21 08:47:43 dbl postfix/smtpd[25947]: disconnect from externalserver.domain.com[x.x.x.x]
where externalserver.domain.com is the remote location I'm currently at.

I'm using "use name and password" authentication with the secure connection option of "TLS, if available"

Thanks for the help. Really appreciate it.
Reply With Quote
  #6  
Old 22nd July 2009, 18:02
madmerlin madmerlin is offline
Junior Member
 
Join Date: Jun 2009
Posts: 21
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Any other insight into why sending from an external location might be failing? There's really not much more in the log files.

Is there a table in MySQL I could check for the right relay authentication information?... or a config file on my Ubuntu 9.04 server?

A test I could try locally on the machine?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix: 554 5.7.1 Relay access denied Crog Server Operation 4 26th March 2010 14:19
ISP Config hesitation when opening web pages frankb Installation/Configuration 7 15th December 2008 13:06
postfix 554 Relay access denied ratcateme Server Operation 1 29th May 2008 18:52
Apache Ownership cybereatl General 2 26th March 2008 12:25
Questions in regards to ISP-Server Setup - Ubuntu 5.10 "Breezy Badger" rbrantley HOWTO-Related Questions 16 10th April 2006 18:26


All times are GMT +2. The time now is 00:40.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.