Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th April 2006, 09:51
gpf gpf is offline
Junior Member
 
Join Date: Apr 2006
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: sql

thanks for the great docs, very well done and much appreciated.

I'm working with Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAssassin, ClamAV) at http://howtoforge.com/virtual_postfi..._quota_courier

I'm setting it up on a fresh, clean, updated install of Ubuntu 5.10 Breezy Badger.

I've read through about six related threads in various threads on these forums, but i'm no closer to success, hence the post.

I strayed from Howto by omitting everything quota related, but otherwise all remains the same.

I have some repeated errors in the auth log which don't seem to be causing any functional problems that i've noticed. should i worry about them or shall i just press on and know they're there for me to read when i'm bored?

Here is the auth.log snippet which is repeated over and over both when mail is flowing in both directions and when it is not:
Code:
Apr 16 18:54:13 talthybius postfix/smtpd[9815]: sql_select option missing
Apr 16 18:54:13 talthybius postfix/smtpd[9815]: auxpropfunc error no mechanism available
Apr 16 18:54:13 talthybius postfix/smtpd[9815]: _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: sql
Apr 16 18:54:27 talthybius postfix/smtpd[9840]: sql_select option missing
Apr 16 18:54:27 talthybius postfix/smtpd[9840]: auxpropfunc error no mechanism available
Apr 16 18:54:27 talthybius postfix/smtpd[9840]: _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: sql
Apr 16 18:58:46 talthybius postfix/smtpd[9913]: sql_select option missing
Apr 16 18:58:46 talthybius postfix/smtpd[9913]: auxpropfunc error no mechanism available
Apr 16 18:58:46 talthybius postfix/smtpd[9913]: _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: sql


my /etc/default/saslauthd looks like this:
Code:
# This needs to be uncommented before saslauthd will be run automatically
 START=yes

# You must specify the authentication mechanisms you wish to use.
# This defaults to "pam" for PAM support, but may also include
# "shadow" or "sasldb", like this:
# MECHANISMS="pam shadow"

MECHANISMS="pam"
PARAMS="-m /var/spool/postfix/var/run/saslauthd -r"
here's what my /etc/courier/authmysqlrc has going on:
Code:
MYSQL_SERVER localhost
MYSQL_USERNAME mail_admin
MYSQL_PASSWORD MyPasswordHere
MYSQL_PORT 0
MYSQL_DATABASE mail
MYSQL_USER_TABLE users
MYSQL_CRYPT_PWFIELD password
#MYSQL_CLEAR_PWFIELD password
MYSQL_UID_FIELD 5000
MYSQL_GID_FIELD 5000
MYSQL_LOGIN_FIELD email
MYSQL_HOME_FIELD "/home/vmail"
MYSQL_MAILDIR_FIELD CONCAT(SUBSTRING_INDEX(email,'@',-1),'/',SUBSTRING_INDEX(email,'@',1),'/')
#MYSQL_NAME_FIELD
#MYSQL_QUOTA_FIELD quota
my /etc/postfix/main.cf is as follows:
Code:
# See /usr/share/postfix/main.cf.dist for a commented, more complete version

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

myhostname = my.domain.tld
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = my.domain.tld, localhost, localhost.localdomain
relayhost =
mynetworks = 127.0.0.0/8
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, proxy:mysql:/etc/postfix/mysql-virtual_email2email.cf
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_mailbox_base = /home/vmail
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
smtpd_sasl_auth_enable = yes
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
smtpd_use_tls = yes
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
#virtual_create_maildirsize = yes
#virtual_mailbox_extended = yes
#virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_limit_maps.cf
#virtual_mailbox_limit_override = yes
#virtual_maildir_limit_message = "The user you are trying to reach is over quota."
#virtual_overquota_bounce = yes
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
content_filter = amavis:[127.0.0.1]:10024
receive_override_options = no_address_mappings
please let me know of any other configs or log files i should post to help unravel this.
Reply With Quote
Sponsored Links
  #2  
Old 17th April 2006, 17:54
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

Have a look here: http://www.howtoforge.com/forums/sho...version+format
http://www.howtoforge.com/forums/sho...version+format
http://www.howtoforge.com/forums/sho...ostfix+version
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 9th May 2006, 00:39
one one is offline
Junior Member
 
Join Date: May 2006
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default same problem

I have upgraded from workaround.org tutorial and skiped quota patch and quota settings
Reply With Quote
  #4  
Old 9th May 2006, 17:45
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

Did you have a look at the links I posted above?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 10th May 2006, 18:43
one one is offline
Junior Member
 
Join Date: May 2006
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default yes

I read all forum posts, search on google but nothing helps me emails works perfectly except posted errors in auth.log

postconf -d | grep mail_version
mail_version = 2.1.5
Reply With Quote
  #6  
Old 11th May 2006, 00:12
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

Does your /etc/pam.d/smtp look exactly as the one from the tutorial? Maybe you made a typo somewhere.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 20th May 2006, 13:03
falcon5 falcon5 is offline
Junior Member
 
Join Date: May 2006
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Default possible sollution

Hi,

Think I have resolved the problem with postfix/smtpd.conf

pwcheck_method: saslauthd auxprop
mech_list: plain login
allow_plaintext: true
auxprop_plugin: mysql
sql_hostnames: localhost
sql_user: some_dbase
sql_passwd: password
sql_database: some_dbase
sql_select: select password from users where email = '%u'

logcheck gives now:
postfix/smtpd: sql auxprop plugin using mysql engine

I hope falco can confirm...
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to install BFD (Brute Force Detection) domino Tips/Tricks/Mods 9 31st March 2006 22:40
Perfect Xen 3.0 setup for Debian gurneyzap HOWTO-Related Questions 4 26th March 2006 11:30
Problems with postfix-mysql Pelle Installation/Configuration 39 13th November 2005 23:25
Total Frustration-HELP palkat Installation/Configuration 17 3rd September 2005 17:28


All times are GMT +2. The time now is 10:00.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.