Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 4th July 2009, 22:46
kentor kentor is offline
Junior Member
 
Join Date: Jul 2009
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default problem with mail server setup

Hello,

I started following the guide on Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (CentOS 5.3 x86_64) http://www.howtoforge.com/virtual-us...tos-5.3-x86_64. I already had apache setup as well as a few other things but after going through the first page of the guide, I think I overwrote the old installation and now my previous application is not working =/ should I just skip this part "3 Install Apache, MySQL, phpMyAdmin" ? Thank you.
Reply With Quote
Sponsored Links
  #2  
Old 5th July 2009, 12:00
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

If these are already installed, you can skip that chapter.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 7th July 2009, 21:43
kentor kentor is offline
Junior Member
 
Join Date: Jul 2009
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Red face stuck at 2nd page

Ok so now im following this guide -> http://www.howtoforge.com/virtual-us...-5.3-x86_64-p2 but on the 2nd page im stuck when it says to do "/etc/init.d/postfix start" it fails...

I'm pretty sure something is missing cuz I don't see mysql in here:

[root@domU-12-31-39-00-5D-07 postfix]# postconf -m
btree
cidr
environ
hash
ldap
nis
pcre
proxy
regexp
static
unix

any help would be really appreciated. I followed exactly what is said in the tutorial except for this command:

yum install ntp httpd mysql-server php php-mysql php-mbstring rpm-build gcc mysql-devel openssl-devel cyrus-sasl-devel pkgconfig zlib-devel phpmyadmin pcre-devel openldap-devel postgresql-devel expect libtool-ltdl-devel openldap-servers libtool gdbm-devel pam-devel gamin-devel

I didn't install
httpd
php-mbstring
mysql-server

cuz the box already had httpd/mysql and I wasn't sure what php-mbstring was but I didn't need php so I skipped it for now.

Please help Thanks!
Reply With Quote
  #4  
Old 8th July 2009, 09:15
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 100 Times in 96 Posts
Default

"it fails" .. what error(s) do you get in your log files?
Reply With Quote
  #5  
Old 8th July 2009, 14:09
kentor kentor is offline
Junior Member
 
Join Date: Jul 2009
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default error

the errors in /var/log/maillog are

Jul 8 08:06:32 domU-12-31-39-00-5D-07 postfix/master[2128]: warning: process /usr/libexec/postfix/proxymap pid 7658 exit status 1
Jul 8 08:06:32 domU-12-31-39-00-5D-07 postfix/master[2128]: warning: /usr/libexec/postfix/proxymap: bad command startup -- throttling
Jul 8 08:06:32 domU-12-31-39-00-5D-07 postfix/smtpd[24110]: warning: premature end-of-input on private/proxymap socket while reading input attribute name
Jul 8 08:06:32 domU-12-31-39-00-5D-07 postfix/smtpd[24110]: warning: private/proxymap socket: service dict_proxy_open: Success
Jul 8 08:06:32 domU-12-31-39-00-5D-07 postfix/cleanup[13491]: warning: premature end-of-input on private/proxymap socket while reading input attribute name
Jul 8 08:06:32 domU-12-31-39-00-5D-07 postfix/cleanup[13491]: warning: private/proxymap socket: service dict_proxy_open: Connection reset by peer

it fails when I try to start postfix:

[root@domU-12-31-39-00-5D-07 postfix]# /etc/init.d/postfix start
Starting postfix: [FAILED]
Reply With Quote
  #6  
Old 8th July 2009, 14:33
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Did you get any errors when you applied the quota patch to Postfix?
What's in /etc/postfix/main.cf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Statistic not working mzo Installation/Configuration 49 20th April 2011 12:19
Undelivered Mail Returned to Sender Error202 General 5 7th May 2009 11:14
external mail server and sending e-mails from a site problem dimas Server Operation 5 20th November 2008 20:59
What can be wrong martin_rudowicz Installation/Configuration 9 11th May 2008 19:42
Core 4: Error Messages on Fresh Install re CTX/SSL jjw Installation/Configuration 30 6th September 2006 12:16


All times are GMT +2. The time now is 18:34.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.