#1  
Old 15th June 2009, 18:18
BHGR BHGR is offline
Junior Member
 
Join Date: Jun 2009
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default Postfix problems

Hi,

I have problems with Postfix on ISPConfig 3.0.1.3, OS is CentOS 5.3

Postfix won't send or recieve mail for any user.

Logs say this:

/var/log/maillog
Code:
Jun 15 19:12:33 srv1 postfix/master[11611]: warning: process /usr/libexec/postfix/smtpd pid 11628 exit status 1
Jun 15 19:12:33 srv1 postfix/master[11611]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
Jun 15 19:13:33 srv1 postfix/smtpd[11888]: warning: xsasl_cyrus_server_get_mechanism_list: no applicable SASL mechanisms
Jun 15 19:13:33 srv1 postfix/smtpd[11888]: fatal: no SASL authentication mechanisms
Jun 15 19:13:34 srv1 postfix/master[11611]: warning: process /usr/libexec/postfix/smtpd pid 11888 exit status 1
Jun 15 19:13:34 srv1 postfix/master[11611]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
/var/log/messages
Code:
Jun 15 19:13:33 srv1 postfix/smtpd[11888]: sql_select option missing
Jun 15 19:13:33 srv1 postfix/smtpd[11888]: auxpropfunc error no mechanism available
Can anyone tell me what's wrong with this setup?

Thank you.
Reply With Quote
Sponsored Links
  #2  
Old 15th June 2009, 18:43
Croydon Croydon is offline
ISPConfig Developer
 
Join Date: Jul 2007
Location: Koblenz, Germany
Posts: 932
Thanks: 16
Thanked 263 Times in 208 Posts
Default

Did you strictly follow the perfect setup howto for your distribution?
It seems that you didn't setup the sql authentication correctly.
Reply With Quote
  #3  
Old 15th June 2009, 18:57
BHGR BHGR is offline
Junior Member
 
Join Date: Jun 2009
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes I did, and also I tried running update.php to rewrite config files, but nothing has changed...
Reply With Quote
  #4  
Old 16th June 2009, 15:58
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,733
Thanks: 840
Thanked 5,597 Times in 4,407 Posts
Default

Looks as if the mysql bindings for sasl are missing. Maybe you used some packages from another repository. Please seek for a package on your server that has mysql and sasl in its name.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 16th June 2009, 18:04
BHGR BHGR is offline
Junior Member
 
Join Date: Jun 2009
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I guess this is it:


[root@srv1 ~]# rpm -qa | grep sasl
cyrus-sasl-sql-2.1.22-4
cyrus-sasl-devel-2.1.22-4
cyrus-sasl-lib-2.1.22-4
cyrus-sasl-2.1.22-4

[root@srv1 ~]# rpm -qa | grep mysql
perl-DBD-mysql-4.011-1.el5.rf
php-mysql-5.1.6-23.2.el5_3
mysql-server-5.0.45-7.el5
mysql-5.0.45-7.el5
mysql-devel-5.0.45-7.el5
courier-authlib-mysql-0.62.1-1
mydns-mysql-1.1.0-1
Reply With Quote
  #6  
Old 16th June 2009, 18:06
BHGR BHGR is offline
Junior Member
 
Join Date: Jun 2009
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

and:

[root@srv1 ~]# rpm -qa | grep sql
perl-DBD-mysql-4.011-1.el5.rf
php-mysql-5.1.6-23.2.el5_3
php-mssql-5.1.6-15.el5.centos.1
cyrus-sasl-sql-2.1.22-4
python-sqlite-1.1.7-1.2.1
postgresql-libs-8.1.11-1.el5_1.1
mysql-server-5.0.45-7.el5
sqlite-3.3.6-2
mysql-5.0.45-7.el5
mysql-devel-5.0.45-7.el5
courier-authlib-mysql-0.62.1-1
mydns-mysql-1.1.0-1
postgresql-8.1.11-1.el5_1.1
postgresql-devel-8.1.11-1.el5_1.1
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix not responding to telnet CarbonCopy Server Operation 6 8th May 2009 06:39
Undelivered Mail Returned to Sender Error202 General 5 7th May 2009 12:14
localhost postfix/master: fatal: bind 127.0.0.1 port 125: Permission denied g18c Installation/Configuration 4 24th March 2009 18:39
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 16:47
Verify email setup meekish Installation/Configuration 28 27th October 2006 16:36


All times are GMT +2. The time now is 05:14.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.