Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 5th June 2009, 17:59
pyropoptrt pyropoptrt is offline
Member
 
Join Date: Dec 2006
Location: Jackson, MS, USA
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to pyropoptrt Send a message via Yahoo to pyropoptrt
Default New FTP Users can't login

I'm having an issue where new users can't login into sites recently created. This is the error I'm getting, "Could not connect as user (username)". I'm currently using ISPConfig 2.2.30. Any input on what is causing this? I've tried deleting the site and client so that I could recreate it fresh but it doesn't delete from the recycle bin even after clicking Empty Recycle Bin.
Reply With Quote
Sponsored Links
  #2  
Old 6th June 2009, 10:36
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

Which distribution are you using? Are there any errors in the logs? Did you try both active and passive transfers in your FTP client?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 6th June 2009, 16:55
pyropoptrt pyropoptrt is offline
Member
 
Join Date: Dec 2006
Location: Jackson, MS, USA
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to pyropoptrt Send a message via Yahoo to pyropoptrt
Default

Hey Falko, I'm using ISPConfig 2.2.3o and I've tried connected via active and passive and neither has worked. Honestly, I don't remember how to access the ISPConfig logs to find the error.
Reply With Quote
  #4  
Old 6th June 2009, 17:01
pyropoptrt pyropoptrt is offline
Member
 
Join Date: Dec 2006
Location: Jackson, MS, USA
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to pyropoptrt Send a message via Yahoo to pyropoptrt
Default

here is the latest entry from proftpd.log

Jun 05 13:26:30 outpost proftpd[28088] outpost (67.98.241.15[67.98.241.15]): FTP session opened.
Jun 05 13:26:30 outpost proftpd[28088] outpost (67.98.241.15[67.98.241.15]): mod_delay/0.5: delaying for 156 usecs
Jun 05 13:26:30 outpost proftpd[28088] outpost (67.98.241.15[67.98.241.15]): no such user 'ergon.mobi_ergon'
Jun 05 13:26:30 outpost proftpd[28088] outpost (67.98.241.15[67.98.241.15]): USER ergon.mobi_ergon: no such user found from 67.98.241.15 [67.98.241.15] to $
Jun 05 13:26:30 outpost proftpd[28088] outpost (67.98.241.15[67.98.241.15]): mod_delay/0.5: delaying for 1334014 usecs
Jun 05 13:26:32 outpost proftpd[28088] outpost (67.98.241.15[67.98.241.15]): FTP session closed.
Reply With Quote
  #5  
Old 6th June 2009, 17:09
pyropoptrt pyropoptrt is offline
Member
 
Join Date: Dec 2006
Location: Jackson, MS, USA
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to pyropoptrt Send a message via Yahoo to pyropoptrt
Default

and this is info from the isp_isp_user table show that the user does exist

> select doc_id, user_username, user_admin, user_shell from isp_isp_user order by doc_id desc limit 1;

+--------+------------------+------------+------------+
| doc_id | user_username | user_admin | user_shell |
+--------+------------------+------------+------------+
| 86 | ergon.mobi_ergon | 1 | 1 |
+--------+------------------+------------+------------+
Reply With Quote
  #6  
Old 7th June 2009, 14:40
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,421
Thanks: 812
Thanked 5,205 Times in 4,081 Posts
Default

FTP does not authenticate against the mysql database, it authenticates against /etc/password. The problem is that usernames may not contain a dot, change your username or username_prefix so that there is no dot in it.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cacti and ISPConfig: Monitoring Tool VMartins Tips/Tricks/Mods 11 9th August 2008 18:37
proFTPd passive mode problems bisbell Server Operation 8 6th August 2008 21:12
Question about Virtual Hosting With Proftpd And MySQL (Incl. Quota) On Debian Etch ikkem HOWTO-Related Questions 30 26th February 2008 19:38
Junk mail and spamassassin... sthompson Installation/Configuration 4 27th December 2006 16:11
WEB UI FTP not working gimhan90 Installation/Configuration 2 16th March 2006 08:03


All times are GMT +2. The time now is 04:38.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.