Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 9th April 2006, 04:01
malikp malikp is offline
Junior Member
 
Join Date: Apr 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up PHP problem ..Just installed ISP Config

I just installed ISP config on Ubuntu Breezy 5.10
Web server, email and DNS works fine.
I try to install SquirrelMail and get is to this PHP problem
I configure the SquirrelMail
and try to access the log in page and get this error
http://mail.test.com
<?php

/**
* index.php
*
* Redirects to the login page.
*
* @copyright &copy; 1999-2006 The SquirrelMail Project Team
* @license http://opensource.org/licenses/gpl-license.php GNU Public License
* @version $Id: index.php,v 1.14.2.7 2006/02/03 22:27:46 jervfors Exp $
* @package squirrelmail
*/

// Are we configured yet?
if( ! file_exists ( 'config/config.php' ) ) {
echo '<html><body><p><strong>ERROR:</strong> Config file ' .
'&quot;<tt>config/config.php</tt>&quot; not found. You need to ' .
'configure SquirrelMail before you can use it.</p></body></html>';
exit;
}

// If we are, go ahead to the login page.
header('Location: src/login.php');

?>
Then I try to create this a test page with following then I can see same thing in the web browser.
<?php
phpinfo();
php?>
But ISP config works fine. I have no idea what else to look.
May be PHP configure for ISP Config only for apache 1.3 not for apache2. Is that the case how can I configure PHP for Apache2.
Thank you,

Last edited by malikp; 9th April 2006 at 04:11.
Reply With Quote
Sponsored Links
  #2  
Old 9th April 2006, 04:07
awd.pt awd.pt is offline
Member
 
Join Date: Apr 2006
Location: Ericeira/Porugal
Posts: 57
Thanks: 9
Thanked 3 Times in 2 Posts
Send a message via MSN to awd.pt
Default

Quote:
Originally Posted by malikp
I just installed ISP config on Ubuntu Breezy 5.10
Web server, email and DNS works fine.
I try to install SquirrelMail and get is to this PHP problem
I configure the SquirrelMail
and try to access the log in page and get this error
http://mail.test.com
<?php

/**
* index.php
*
* Redirects to the login page.
*
* @copyright &copy; 1999-2006 The SquirrelMail Project Team
* @license http://opensource.org/licenses/gpl-license.php GNU Public License
* @version $Id: index.php,v 1.14.2.7 2006/02/03 22:27:46 jervfors Exp $
* @package squirrelmail
*/

// Are we configured yet?
if( ! file_exists ( 'config/config.php' ) ) {
echo '<html><body><p><strong>ERROR:</strong> Config file ' .
'&quot;<tt>config/config.php</tt>&quot; not found. You need to ' .
'configure SquirrelMail before you can use it.</p></body></html>';
exit;
}

// If we are, go ahead to the login page.
header('Location: src/login.php');

?>
Then I try to create this a test page with following then I can see same thing in the web browser.
<?php
phpinfo();
php?>
But ISP config works fine. I have no idea what else to look.
This is nothing related with ISPConfig since ISPConfig runs a separated HTTP server.
I've recently a problem like yours and it was related with apache configuration and php module (I had a mess of php-4 and php-5 ). I solved by rpm -e php httpd and yum -y install httpd php. Not the right or best way to solve it, but it worked for me.

srosa
Reply With Quote
  #3  
Old 9th April 2006, 13:28
malikp malikp is offline
Junior Member
 
Join Date: Apr 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Talking Mange to fix the problem

Quote:
Originally Posted by awd.pt
This is nothing related with ISPConfig since ISPConfig runs a separated HTTP server.
I've recently a problem like yours and it was related with apache configuration and php module (I had a mess of php-4 and php-5 ). I solved by rpm -e php httpd and yum -y install httpd php. Not the right or best way to solve it, but it worked for me.

srosa

i remove php4 and reinstall but did not fix.
Then I install php5 and now all working. I do not know how its fix but now all working.

Thank you all helping me
Reply With Quote
  #4  
Old 9th April 2006, 19:15
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,748 Times in 2,579 Posts
Default

I hope you installed Squirrelmail in a web site you created with ISPconfig and not in the default directory /var/www.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 10th April 2006, 12:43
malikp malikp is offline
Junior Member
 
Join Date: Apr 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up

Quote:
Originally Posted by falko
I hope you installed Squirrelmail in a web site you created with ISPconfig and not in the default directory /var/www.

Yes... not in the /var/www

and now its working fine
Reply With Quote
  #6  
Old 9th April 2006, 13:22
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,804
Thanks: 840
Thanked 5,613 Times in 4,424 Posts
Default

Quote:
Originally Posted by malikp
But ISP config works fine. I have no idea what else to look.
May be PHP configure for ISP Config only for apache 1.3 not for apache2. Is that the case how can I configure PHP for Apache2.
Did you create the website mail.test.com in ISPCOnfig? If yes, did you check the php cgeckbox for the site?

Be aware that ISPConfig has to deactivate your PHP installation in httpd.conf globally and re enables it for every website.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with the apache (I can't start ist) M.Behrens Installation/Configuration 11 31st March 2006 11:48
Downgrade php5 to php4.4.2 llizards Installation/Configuration 4 14th March 2006 00:58
all my site go to /var/www/ Absolusteph Installation/Configuration 14 11th March 2006 22:27
turn off "PHP Scripts" problem after updated php k-dev4edv Installation/Configuration 2 7th February 2006 10:34
Installation problem: PHP problem? hgoor Installation/Configuration 7 21st August 2005 23:15


All times are GMT +2. The time now is 21:56.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.