Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 24th May 2009, 18:06
dpicella dpicella is offline
Senior Member
 
Join Date: Apr 2009
Posts: 116
Thanks: 9
Thanked 8 Times in 7 Posts
Default Apache Configuration AllowOverride: "Options not allowed here" problems

I'm using the latest upgrade to ISPConfig 3 v3.0.1.2

I would like to allow users to browse password protected directories. I have tried setting up apache directives in:
.htaccess
.htpasswd
This works out OK, however, If I try to use the Apache "Options" directive for anything, I get the log error
"Options not allowed here"
I tried modifying the website conf files and setting "AllowOverride All"

But this does not work

I have the same problem when trying to use anything.cgi even though the CGI box is checked off on the website config.

For CGI, it states that "Options ExecCGI" is off ... turning it on in .htaccess produces the "Options not allowed here" error.

If I set AllowOverride to "All" shouldn't I be able to use the Options in .htaccess?

What am I doing wrong? I notice that there are a lot of AllowOverride directives in the ISPConfig files, so I am thinking there may be a conflict somewhere ... but it is weird that I can't use cgi when the website check box is configured to do so.

Thank you for any advice.

Cheers!

Last edited by dpicella; 24th May 2009 at 18:08. Reason: typos
Reply With Quote
Sponsored Links
  #2  
Old 25th May 2009, 13:45
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,748 Times in 2,579 Posts
Default

AFAIK, you cannot use Options in .htaccess files.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 25th May 2009, 19:55
dpicella dpicella is offline
Senior Member
 
Join Date: Apr 2009
Posts: 116
Thanks: 9
Thanked 8 Times in 7 Posts
Default How to use .htaccess apache Options with ISPConfig 3

Actually,

I was able to make this work.

I added

Code:
<Directory /path/to/the/dir/with .htaccess>
    AllowOverride All
    Order Allow,Deny
    Allow from all
</Directory>
To the apache directive box under options.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
All my mail is going to /var/mail/vmail _sluimers_ Installation/Configuration 21 10th January 2011 14:21
problems with suexec gobokster Installation/Configuration 7 7th May 2009 14:33
The system is currently updating the configuration files. warlock General 8 21st February 2009 19:15
FTP cannot open remote folder!?! andysm849 Server Operation 23 17th October 2008 00:34
Can't start apache Musty Server Operation 12 9th March 2008 14:58


All times are GMT +2. The time now is 04:40.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.