Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd August 2005, 14:30
hschel hschel is offline
Junior Member
 
Join Date: Aug 2005
Location: Doetinchem, Netherlands
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Problems installing ISPConfig Debian Sarge

I followed Falko's guide to the perfect debian sarge setup. No problems on that part. When I try to install ISPConfig and I get to that last part where you have to select the installation mode, I get the following error:

Checking for program httpd...
/usr/bin/httpd
OK
Checking the syntax of the httpd.conf...
Syntax error on line 7 of /etc/apache2/mods-enabled/proftpd.conf:
Invalid command 'ServerType', perhaps mis-spelled or defined by a module not included in the server configuration
ERROR: The syntax of your httpd.conf is not ok! Please correct the error. The installation routine stops here!

I examined the config file but can't find any invalid commands or syntax errors. Maybe I overlooked something or just made a mistake?
Reply With Quote
Sponsored Links
  #2  
Old 22nd August 2005, 14:52
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Quote:
Originally Posted by hschel
I followed Falko's guide to the perfect debian sarge setup. No problems on that part. When I try to install ISPConfig and I get to that last part where you have to select the installation mode, I get the following error:

Checking for program httpd...
/usr/bin/httpd
OK
Checking the syntax of the httpd.conf...
Syntax error on line 7 of /etc/apache2/mods-enabled/proftpd.conf:
Invalid command 'ServerType', perhaps mis-spelled or defined by a module not included in the server configuration
ERROR: The syntax of your httpd.conf is not ok! Please correct the error. The installation routine stops here!

I examined the config file but can't find any invalid commands or syntax errors. Maybe I overlooked something or just made a mistake?
Can you post /etc/apache2/mods-enabled/proftpd.conf here?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 22nd August 2005, 17:04
hschel hschel is offline
Junior Member
 
Join Date: Aug 2005
Location: Doetinchem, Netherlands
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok here is my /etc/apache2/mods-enabled/proftpd.conf

Code:
#
# /etc/proftpd.conf -- This is a basic ProFTPD configuration file.
# To really apply changes reload proftpd after modifications.
#

ServerName                      "Debian"
ServerType                      standalone
DeferWelcome                    off

MultilineRFC2228                on
DefaultServer                   on
ShowSymlinks                    on

TimeoutNoTransfer               600
TimeoutStalled                  600
TimeoutIdle                     1200

DisplayLogin                    welcome.msg
DisplayFirstChdir               .message
ListOptions                     "-l"

DenyFilter                      \*.*/

# Uncomment this if you are using NIS or LDAP to retrieve passwords:
#PersistentPasswd               off

# Uncomment this if you would use TLS module:
#TLSEngine                      on

# Uncomment this if you would use quota module:
#Quotas                         on

# Uncomment this if you would use ratio module:
#Ratios                         on

# Port 21 is the standard FTP port.
Port                            21

# To prevent DoS attacks, set the maximum number of child processes
# to 30.  If you need to allow more than 30 concurrent connections
# at once, simply increase this value.  Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd)
MaxInstances                    30

# Set the user and group that the server normally runs at.
User                            nobody
Group                           nogroup

# Umask 022 is a good standard umask to prevent new files and dirs
# (second parm) from being group and world writable.
Umask                           022  022
# Normally, we want files to be overwriteable.
AllowOverwrite                  on

# Delay engine reduces impact of the so-called Timing Attack described in
# http://security.lss.hr/index.php?page=details&ID=LSS-2004-10-02
# It is on by default.
#DelayEngine                    off

# A basic anonymous configuration, no upload directories.

# <Anonymous ~ftp>
#   User                                ftp
#   Group                               nogroup
#   # We want clients to be able to login with "anonymous" as well as "ftp"
#   UserAlias                   anonymous ftp
#   # Cosmetic changes, all files belongs to ftp user
#   DirFakeUser on ftp
#   DirFakeGroup on ftp
#
#   RequireValidShell           off
#
#   # Limit the maximum number of anonymous logins
#   MaxClients                  10
#
#   # We want 'welcome.msg' displayed at login, and '.message' displayed
#   # in each newly chdired directory.
#   DisplayLogin                        welcome.msg
#   DisplayFirstChdir           .message
#
#   # Limit WRITE everywhere in the anonymous chroot
#   <Directory *>
#     <Limit WRITE>
#       DenyAll
#     </Limit>
#   </Directory>
#
#   # Uncomment this if you're brave.
#   # <Directory incoming>
#   #   # Umask 022 is a good standard umask to prevent new files and dirs
#   #   # (second parm) from being group and world writable.
#   #   Umask                           022  022
#   #            <Limit READ WRITE>
#   #            DenyAll
#   #            </Limit>
#   #            <Limit STOR>
#   #            AllowAll
#   #            </Limit>
#   # </Directory>
#
# </Anonymous>
Reply With Quote
  #4  
Old 22nd August 2005, 17:31
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

That looks like /etc/proftpd.conf. It's the Proftpd configuration file and has nothing to do with Apache. Did you accidentally copy it to /etc/apache2/mods-enabled? If /etc/proftpd.conf is existing, then delete /etc/apache2/mods-enabled/proftpd.conf, otherwise move it to /etc.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 22nd August 2005, 20:46
hschel hschel is offline
Junior Member
 
Join Date: Aug 2005
Location: Doetinchem, Netherlands
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

You were right, I must have somehow copied the file to the mods-enabled directory.
Thanks for the help!

And btw I love your howtos, keep up the good work!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Compile Kernel 2.6 under Debian Sarge falko Kernel Questions 117 28th September 2009 14:03
Compile Kernel 2.6 under Debian Sarge falko HOWTO-Related Questions 5 17th October 2008 14:58
Getting problems when installing corn_planter Installation/Configuration 12 22nd August 2005 02:41
Little problems setting up the ISPConfig Luciano Installation/Configuration 1 15th August 2005 21:17
Install Debian Sarge with Kernel 2.6 root Installation/Configuration 4 10th May 2005 11:51


All times are GMT +2. The time now is 07:13.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.