#1  
Old 15th April 2009, 06:15
jamesls jamesls is offline
Member
 
Join Date: Apr 2009
Posts: 33
Thanks: 1
Thanked 0 Times in 0 Posts
Default Webmail won't work

I thiink my squirrel is hibernating

I'm running ubuntu 81.0, ispconfig 3 I used the ubuntu perfect server ispconfig 3.

Iv'e managed to get my web sites to resolve through a browser, and normal pop3 & smtp works ok for the 3 different sites.

Ive tried http:// ip add/webmail, 127.0.0.1/webmail, hostname/webmail, websites/webmail.

all come back with a not found error

In the dns records I have
A mail 10.0.0.10 0
A ns1 10.0.0.10 0
A victim6.co.co. 10.0.0.10 0
MX victim6.co.co. mail.victim6.co.co. 10
NS victim6.co.co. ns1.victim6.co.co.
that is al, not sure if I should alter any other records

When I was installing squirrel mail it worked ok, when tested with the http://ip/webmail - it came up with the login screen.

running ls -l /etc/apache2/conf.d
total 12
-rw-r--r-- 1 root root 237 20 18:31 apache2-doc
-rw-r--r-- 1 root root 269 21 01:05 charset
lrwxrwxrwx 1 root root 28 1 00:48 phpmyadmin.conf -> ../../phpmyadmin/apache.conf
-rw-r--r-- 1 root root 1464 ene 21 01:05 security

James
Reply With Quote
Sponsored Links
  #2  
Old 15th April 2009, 07:09
Horfic Horfic is offline
Senior Member
 
Join Date: Mar 2009
Location: Austria
Posts: 322
Thanks: 55
Thanked 89 Times in 54 Posts
Send a message via Skype™ to Horfic
Default

It sounds like your webmail folder isn't linked to the squirrel webmail folder.
__________________
web wack creations - We create your custom web application
Mailuser interface for ISPConfig 3
Reply With Quote
  #3  
Old 15th April 2009, 11:31
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Most likely you created a IP based website in ISPConfig instead of a namebased and now you can not access webmail over IP anymore. A slution is e.g. to create a symlink in your website that points to the squirrelmail sources.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 15th April 2009, 16:45
jamesls jamesls is offline
Member
 
Join Date: Apr 2009
Posts: 33
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Ok..... not sure quite what I've done then.

I've 3 web sites all test ones.
When I was setting up the dns bits I entered their domain names, and ips as follows.
DNS .. select client, zone "victim7.vx", NS "ns1" and gave it an email "admin.victim7.vx
Records select A, hostname "victim7.vx.", ip "10.0.0.10" (the ip of my host pc)
Select A, hostname "mail", ip "10.0.0.10"
Select A Hostname "ns1" ip "10.0.0.10"
Select MX hostname "victim7.vx.", mailserver "mail.victim7.vx"
Select NS zone "victim7.vx", hostname "ns1.victim7.vx."

Should I have entered 127.0.0.1 instead of 10.0.0.10, all the web sites point to 10.0.0.1

In the folder /var/www/ I have the following

FOLDERS Client, php-fcgi-scripts, webalizer
LINKS goof.tet, victim6.co.co, victim7.vx (3 web sites I made) webmail, and ispconfig which says its broken.
FILES index.html the original apache install "it works".

The questions now.
1. How do I change apache to names rather than ip's
I think I want to run names, I have 1 internet ip and 5 web sites.
At this point I don't want to have to configure extra virtual local IP's.

2. If I want to run SSL will I be able to do so if I'm using the "names" ?
SSL and WEBMAIL are optional to me, good to have and be able to do.

I'm fairly new to Linux, and know very little about ISP's other than using Cpanel as a client etc
Reply With Quote
  #5  
Old 15th April 2009, 19:47
jamesls jamesls is offline
Member
 
Join Date: Apr 2009
Posts: 33
Thanks: 1
Thanked 0 Times in 0 Posts
Default

I tried placing links to squirrelmail in each website folder, and that worked ok for my 3 different sites.

I'm still wondering if I have "names" or "ip" websites setup though, and how I change them to "names"

James

Many thanks for your help
Reply With Quote
  #6  
Old 16th April 2009, 12:33
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

If you select '*' in the IP field then your sites are nambased. If you select a IP they are IP based.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mail server using Postfix, Dovecot, Mysql... Postfix virtual maps doesn't work?? tarasbuljba HOWTO-Related Questions 33 28th May 2010 14:33
Webmail problems with only one domain? compner Installation/Configuration 14 16th February 2010 16:59
Uebimiau Webmail - Does this work. slaeya General 1 3rd April 2009 09:09
webmail doesen't work fswolf Installation/Configuration 3 21st August 2008 10:17
Email username and password do not work iratik Installation/Configuration 8 11th August 2006 17:22


All times are GMT +2. The time now is 02:44.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.