Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 9th April 2009, 13:21
tokamak tokamak is offline
Junior Member
 
Join Date: Apr 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default pureftp-d change default ftp port

It is possibel to change the dfault ftp prot ?

and how i can make it ^^

Thanks for infos
Reply With Quote
Sponsored Links
  #2  
Old 10th April 2009, 10:21
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,771
Thanks: 821
Thanked 5,331 Times in 4,183 Posts
Default

Which Linux distribution?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 10th April 2009, 14:24
gring gring is offline
Member
 
Join Date: Mar 2009
Posts: 46
Thanks: 2
Thanked 3 Times in 3 Posts
Default

on debian / ubuntu, you have to create /etc/pure-ftpd/conf/Bind and put in it your interface with this format:

<ip_address>,<port>

to listen to all interfaces on port 500, put:
*,500

The monitor in ispconfig won't find it, though, you have to setup it manually, there is a thread in the forum about this issue.
Reply With Quote
  #4  
Old 11th April 2009, 13:07
tokamak tokamak is offline
Junior Member
 
Join Date: Apr 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Yeah great :D

Big thx works fine
Reply With Quote
  #5  
Old 11th April 2009, 13:32
tokamak tokamak is offline
Junior Member
 
Join Date: Apr 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Monitor issue

you have to edit :

/usr/local/ispconfig/server/mods-available/monitor_core_module.inc.php

in line 388

if($this->_checkFtp('localhost', 21)) {

you have to change 21 to the port you have in the "Bind" file
Reply With Quote
  #6  
Old 10th August 2012, 19:07
metalcated metalcated is offline
Junior Member
 
Join Date: Aug 2012
Posts: 1
Thanks: 0
Thanked 1 Time in 1 Post
Thumbs up

The location of this parameter has changed -->

/usr/local/ispconfig/server/lib/classes/monitor_tools.inc.php

if ($this->_checkFtp('localhost', 21)) {

Hope this helps someone else.
Reply With Quote
The Following User Says Thank You to metalcated For This Useful Post:
billcouper81 (14th August 2014)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Proftpd + MySQL virtual users, can't connect geekman HOWTO-Related Questions 28 27th September 2010 18:03
how to change the default port 81 ? Jugernaut Installation/Configuration 12 10th February 2010 14:09
Change FTP port in Backup. Buzzen Installation/Configuration 2 16th February 2008 09:39
Exim MTA dazblade Server Operation 4 16th July 2007 18:42
High Availability Samba cluster - DRBD + Heartbeat djalex Server Operation 58 25th May 2007 19:38


All times are GMT +2. The time now is 05:53.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.