Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 24th March 2006, 17:45
Cirox Cirox is offline
Member
 
Join Date: Mar 2006
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Default Squirrelmail user-login Mail-Header From:

Hi,

i installed squirrelmail as webmail client with the plugin "virtusertable" to login with user@example.com. It was very easy to install. Just creating a new webmail.example.com domain in ispconfig and deleting the co-domain with no host after this. I used the root web folder from this domain in ispconfig. All to do was to read the installation tips they come with squirrelmail and the plugin.

But my problem is, if i host virtual domains with ispconfig and use the webmail tool, in my case squirrelmail, to sent some mail, the "from:" adress is always the domain i installed squirrelmail into.

Postfix is using the virtualusertable and there the email adress is mapped to the virtual user. So Postfix cant find the real fqdn of the virtual user?

Ok, i can put the real name and reply-to adress in the webmail frontend, but thats not professionell, exspecially for new users.

In UebiMiau, the webmailer that comes with ispconfig, you have to fill out the real name and reply-to adress, too, otherwise you cant sent email. i am still wondering.

So, how to solve the problem, that the user of virtual domains have the "from" adress in the mail header in the beginning, and not after you filled out the fields in the frontend?

Here you see the code from /var/log/mail.log and example.com is the adress i installed squirrelmail into and not the real virtual domain from the user:

Code:
Mar 24 16:30:27 srv02 postfix/smtpd[19880]: connect from localhost.localdomain[127.0.0.1]
Mar 24 16:30:27 srv02 postfix/smtpd[19880]: D23F5498053: client=localhost.localdomain[127.0.0.1]
Mar 24 16:30:27 srv02 postfix/cleanup[19881]: D23F5498053: message-id=<1072.84.188.246.247.1143214227.squirrel@webmail.example.com>
Mar 24 16:30:27 srv02 postfix/qmgr[17895]: D23F5498053: from=<web6_ralph@example.com>, size=764, nrcpt=1 (queue active)
Mar 24 16:30:27 srv02 postfix/smtpd[19880]: disconnect from localhost.localdomain[127.0.0.1]
Mar 24 16:30:27 srv02 imaplogin: Connection, ip=[::ffff:127.0.0.1]
Mar 24 16:30:27 srv02 imaplogin: LOGIN, user=web6_ralph, ip=[::ffff:127.0.0.1], protocol=IMAP
Mar 24 16:30:27 srv02 imaplogin: LOGOUT, user=web6_ralph, ip=[::ffff:127.0.0.1], headers=0, body=0, time=0
Mar 24 16:30:28 srv02 imaplogin: Connection, ip=[::ffff:127.0.0.1]
thx and greetings cirox

Last edited by Cirox; 24th March 2006 at 17:53.
Reply With Quote
Sponsored Links
  #2  
Old 24th March 2006, 18:55
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Quote:
Originally Posted by Cirox
Ok, i can put the real name and reply-to adress in the webmail frontend, but thats not professionell, exspecially for new users.
You always have to set the sender address, even in email clients like Outlook and Thunderbird. Nothing wrong here.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 24th March 2006, 19:55
Cirox Cirox is offline
Member
 
Join Date: Mar 2006
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi,

thx, but i configured postfix with cyrus-imap -> msql auxprop plugin (at another non-ispbox and the "from:" adress is like the email adress of the used virtual domain, if you dont set your reply-to adress

But i think with courier it isnt possible ?

greetings cirox
Reply With Quote
  #4  
Old 24th March 2006, 20:02
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

That happens because on your other box you're using virtual mailboxes where the usernames have the form of email addresses. On the ISPConfig system you have system users, not virtual users.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 24th March 2006, 20:15
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,266
Thanks: 82
Thanked 24 Times in 20 Posts
Default

I do not know if this helps but what I did is this: manually add a mail.* virtualdomain, create mail. subdomains for all your domains, so all your hosted domains can be reached by mail.domain.com - and you only have to install squirrelmail once because all mappings of mail.* point to this installation.

and inside the mailheaders the domain where the mail is sent from is always the domain used to logg in so if you logged into mail.domain1.com this is where the mail seems to be coming.

if you want even more comfort try the virtualuser plugin for squirrelmail - here you can set almost any setting you might want. (although that was too complicated for me and I am fine with the current solution)

hope this helped a bit... (as far as I rememberif I create a new user and do not set anything inside squirrelmail the sender is: also user@ main domain, but with the plugin I mentioned you should be able to fix that)
Reply With Quote
  #6  
Old 24th March 2006, 23:06
Cirox Cirox is offline
Member
 
Join Date: Mar 2006
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi,

ok i realized it. The "from:" Mailheader ist set by squirrelmail in his own config.php by "$domain". If you leave it empty the /etc/mailname is used, cause of "myorigin=/etc/mailname" in postfix.

So the only thing that works for me is to copy squirrelmail to each virtual domain and set the "$domain" in config.php. ....

Now the problem is the username. Here i can only delete the prefix in ispconfig, but then i had to use the whole username, to avoid conflictions with same names, if hosting in different virtual domains ..... andwhat is with "hans-mueller" ----- so i forget this and use the prefix.

For first ;-) its ok, when a new user send his first mail with squirrelmail and only the username is set to web_x and the domain is right.

But what is if using Thunderbird - oh my god - he have to fill in his right name and the right domain and user with prefix like web_x for smtp/imap server........ ( excellent, that you have to fill in the username/adress in thunderbird, instead of be able to overjump this)

greetings cirox

Last edited by Cirox; 24th March 2006 at 23:33.
Reply With Quote
  #7  
Old 12th July 2006, 03:48
admiral admiral is offline
Junior Member
 
Join Date: Jul 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default ISPConfig Virtual Hosts and SquirrelMail

Tenaka,
Anyway you can post a quick howto/tutorial on how you did that? It is exactly what I am looking for, but am running into some issues from an implementation standpoint. Thanks.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Statistic not working mzo Installation/Configuration 49 20th April 2011 12:19
Cant get mail after applying the update 2.1.2 mphayesuk Installation/Configuration 2 31st December 2008 14:48
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs ebbay Installation/Configuration 9 4th March 2006 11:47
User name rather than Real Name in mail header?? deanclaxton Installation/Configuration 1 19th October 2005 02:43
Total Frustration-HELP palkat Installation/Configuration 17 3rd September 2005 17:28


All times are GMT +2. The time now is 04:33.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.