#1  
Old 31st March 2009, 11:28
goolee goolee is offline
Junior Member
 
Join Date: Mar 2009
Posts: 12
Thanks: 1
Thanked 0 Times in 0 Posts
Smile Xen image creation problem

hi friends,,
i hav used the HOWTO in this link http://www.howtoforge.com/installing...tu-8.10-x86_64..

However i get the following error when i type "xm create /etc/xen/xen1.example.com.cfg"

ERROR Internal error: Could not obtain handle on privileged command interface (2 = No such file or directory)
Traceback (most recent call last):
File "/usr/sbin/xm", line 8, in <module>
from xen.xm import main
File "/usr/lib/python2.5/site-packages/xen/xm/main.py", line 61, in <module>
xc = xen.lowlevel.xc.xc()
xen.lowlevel.xc.Error: (1, 'Internal error', 'Could not obtain handle on privileged command interface (2 = No such file or directory)')

i hope i shall get the problem here.
Reply With Quote
Sponsored Links
  #2  
Old 1st April 2009, 13:43
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Did you boot into the Xen kernel? It seems as if Xen is not running.

What's the output of
Code:
uname -a
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 2nd April 2009, 16:51
goolee goolee is offline
Junior Member
 
Join Date: Mar 2009
Posts: 12
Thanks: 1
Thanked 0 Times in 0 Posts
Smile

Quote:
Originally Posted by falko View Post
Did you boot into the Xen kernel? It seems as if Xen is not running.

What's the output of
Code:
uname -a
?
Hi friend,,
thanks for the prompt reply..But unfortunatly i`m away from the computer now..However is shall provide u the output of that "Uname" command by tommrrow.
but here i wantd to ask a question..
when i follwed thta "HOW TO" ..it prompted me to install Xen thro internet and i did ..How ever when i rebooted the computer..there was no xen on grub..instead there was "UBUNTU server" on my ubuntu 8.10 desktop computer..

Thanks
Reply With Quote
  #4  
Old 3rd April 2009, 08:27
goolee goolee is offline
Junior Member
 
Join Date: Mar 2009
Posts: 12
Thanks: 1
Thanked 0 Times in 0 Posts
Smile Here is the output of uname -a

Hey..here is the output
pls have a look at the attachment
Attached Images
 
Reply With Quote
  #5  
Old 3rd April 2009, 12:42
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

That's the normal Ubuntu kernel which cannot be used for a Xen dom0.

What's the output of
Code:
ls -la /boot
, and what's in /boot/grub/menu.lst?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 7th April 2009, 10:47
goolee goolee is offline
Junior Member
 
Join Date: Mar 2009
Posts: 12
Thanks: 1
Thanked 0 Times in 0 Posts
Smile Here is the output of the command u gave

Here is the output


mamce@mamce-desktop:~$ sudo su
root@mamce-desktop:/home/mamce# ls -la /boot
total 39160
drwxr-xr-x 3 root root 4096 2009-04-01 14:00 .
drwxr-xr-x 20 root root 4096 2009-04-07 14:13 ..
-rw-r--r-- 1 root root 508385 2009-01-30 02:41 abi-2.6.27-11-generic
-rw-r--r-- 1 root root 510401 2009-01-30 02:56 abi-2.6.27-11-server
-rw-r--r-- 1 root root 507665 2008-11-05 02:30 abi-2.6.27-7-generic
-rw-r--r-- 1 root root 91358 2009-01-30 02:41 config-2.6.27-11-generic
-rw-r--r-- 1 root root 91522 2009-01-30 02:56 config-2.6.27-11-server
-rw-r--r-- 1 root root 91364 2008-11-05 02:30 config-2.6.27-7-generic
drwxr-xr-x 2 root root 4096 2009-04-01 14:01 grub
-rw-r--r-- 1 root root 8184671 2009-02-23 16:13 initrd.img-2.6.27-11-generic
-rw-r--r-- 1 root root 8214100 2009-03-30 14:55 initrd.img-2.6.27-11-server
-rw-r--r-- 1 root root 3097876 2009-04-01 14:00 initrd.img-2.6.27.5
-rw-r--r-- 1 root root 8180888 2009-02-23 16:10 initrd.img-2.6.27-7-generic
-rw-r--r-- 1 root root 124152 2008-09-12 01:41 memtest86+.bin
-rw-r--r-- 1 root root 1031799 2009-01-30 02:41 System.map-2.6.27-11-generic
-rw-r--r-- 1 root root 1052790 2009-01-30 02:56 System.map-2.6.27-11-server
-rw-r--r-- 1 root root 1029585 2008-11-05 02:30 System.map-2.6.27-7-generic
-rw-r--r-- 1 root root 1074 2009-01-30 02:42 vmcoreinfo-2.6.27-11-generic
-rw-r--r-- 1 root root 1073 2009-01-30 02:58 vmcoreinfo-2.6.27-11-server
-rw-r--r-- 1 root root 1073 2008-11-05 02:32 vmcoreinfo-2.6.27-7-generic
-rw-r--r-- 1 root root 2248912 2009-01-30 02:41 vmlinuz-2.6.27-11-generic
-rw-r--r-- 1 root root 2297776 2009-01-30 02:56 vmlinuz-2.6.27-11-server
-rw-r--r-- 1 root root 2244464 2008-11-05 02:30 vmlinuz-2.6.27-7-generic
-rw-r--r-- 1 root root 427143 2008-10-06 23:42 xen-3.3.gz
root@mamce-desktop:/home/mamce#

Last edited by goolee; 7th April 2009 at 10:50. Reason: image not attached properly
Reply With Quote
Reply

Bookmarks

Tags
xen, xm-create

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
Xen Networking Problem atjensen11 Installation/Configuration 2 28th January 2009 18:15
Problem with Xen / Debian & mkinitrd.yaird. TheDreamer HOWTO-Related Questions 3 1st November 2006 17:45
perfect Xen/Debian setup problem: No DMA support in xen 3.0.1 BCNW HOWTO-Related Questions 2 6th September 2006 19:06
The Perfect Xen 3.0 Setup For Debian - IpTables Problem Gurke666 HOWTO-Related Questions 2 21st April 2006 17:21


All times are GMT +2. The time now is 14:55.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.