#1  
Old 26th March 2009, 04:11
mghens mghens is offline
Junior Member
 
Join Date: Jan 2009
Posts: 19
Thanks: 3
Thanked 2 Times in 2 Posts
Default Spam Filter isp3.0.1

Just installed it today. It seems that amavis spam handing got changed from RC2.

RC2:

$final_virus_destiny = D_DISCARD; # (defaults to D_BOUNCE)
$final_banned_destiny = D_BOUNCE; # (defaults to D_BOUNCE)
$final_spam_destiny = D_REJECT; # (defaults to D_REJECT)
$final_bad_header_destiny = D_PASS; # (defaults to D_PASS), D_BOUNCE suggested

Final:

$final_virus_destiny = D_BOUNCE;
$final_spam_destiny = D_PASS;
$final_banned_destiny = D_BOUNCE;
$final_bad_header_destiny = D_PASS;


I looked into it because email that was higher than SPAM kill level from the console was leaking through.

Any thoughts???
Reply With Quote
Sponsored Links
  #2  
Old 26th March 2009, 09:31
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,413
Thanks: 834
Thanked 5,498 Times in 4,328 Posts
Default

The spam kill level is set in ISPConfig for every policy individually and not in this file. the setting in the rc2 was wrong as it caused nmail to be deleted even if spam scanning was deactivated for an account or domain.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 29th March 2009, 23:31
Mouton Mouton is offline
Junior Member
 
Join Date: Apr 2008
Posts: 10
Thanks: 0
Thanked 4 Times in 1 Post
Default

Same on my side...

I cannot find the way for emails tagged above the "Kill level" to be killed, for real. Any idea ?

(I upgraded from the 3.0.0.9rc2 to the 3.0.1 version, might it be linked ?)
Reply With Quote
  #4  
Old 30th March 2009, 00:49
technoid technoid is offline
Junior Member
 
Join Date: Mar 2009
Posts: 12
Thanks: 4
Thanked 0 Times in 0 Posts
Default

Same problem here. On the normal policy setting it is now passing things that are even marked spam in the logs.

Mar 29 17:42:14 blacksun amavis[1433]: (01433-01) Passed SPAM, [24.158.119.35] [24.158.119.35] <bambikay@XXXXX.org> -> <bambikay@XXXXX.org>, Message-ID: <20090329224212.8A70CA344@blacksun.XXXXXXXXX.com >, mail_id: D69Pwx2bjIMt, Hits: 29.839, size: 2327, queued_as: 8286DA345, 1675 ms

Before upgrading to 3.0.1 from 3.0.0.9RC this was working fine and things marked spam were not being delivered.

Any ideas what we need to change to fix this? My real fear is virus infected mail getting through.

Thank you,
technoid
Reply With Quote
  #5  
Old 30th March 2009, 01:03
technoid technoid is offline
Junior Member
 
Join Date: Mar 2009
Posts: 12
Thanks: 4
Thanked 0 Times in 0 Posts
Default

For more information:

I changed the following line in /etc/amavis/conf.d/50-user:
$final_spam_destiny = D_PASS;
to
$final_spam_destiny = D_DISCARD;

then restarted amavis and my server is now blocking spam again, such as:

Mar 29 17:55:53 blacksun amavis[2593]: (02593-01) Blocked SPAM, [189.1.187.134] [189.1.187.134] <jeremiah@XXXXX.org> -> <jeremiah@XXXXX.org>, Message-ID: <20090329225551.3E2CCA344@blacksun.XXXXXXXXX.com >, mail_id: NDVWtU6Y74vx, Hits: 31.039, size: 2304, 999 ms

So it appears that the policy setting in ISPConfig are not correctly controlling the flow of spam.

Thank you,
technoid
Reply With Quote
  #6  
Old 3rd May 2009, 14:52
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,266
Thanks: 82
Thanked 24 Times in 20 Posts
Default

is there any thread where these policies are explained? I just started experimenting with ispcfg3 and am quite confused about these "virus lover" "spam lover" etc. expressions as I don't know what they mean and what happens in the background based on them...
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISP Config hesitation when opening web pages frankb Installation/Configuration 7 15th December 2008 13:06
Ubuntu 8.04 Spamsnake - all SA scores 0.00 Thomas_Powers HOWTO-Related Questions 23 24th June 2008 17:37
network issues now it says "401 The web site is blocked by administrator" Check General 3 26th February 2008 14:22
Apache2 Freezes celtic Server Operation 31 28th May 2007 17:18
php script injections Grizzly General 21 18th July 2006 08:55


All times are GMT +2. The time now is 09:29.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.