Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd March 2006, 14:56
Nejko Nejko is offline
Senior Member
 
Join Date: Jan 2006
Posts: 132
Thanks: 0
Thanked 0 Times in 0 Posts
Default Problem with BIND and ISPConfigs's DNS Manager

Hello,

i solved all my problems except this one. I have problem with bind and ispconfig. When i create a domain (either master or slave), BIND goes down, and give an error like:
Quote:
Failed to start BIND : Starting named: Error in named configuration: zone 0.0.127.in-addr.arpa/IN: loaded serial 1997022700 zone aljaz.nero-server.com/IN: loading master file pri.aljaz.nero-server.com: file not found _default/aljaz.nero-server.com/IN: file not found zone nero-server.com/IN: loaded serial 1142422867 zone dnt-celje.com/IN: loaded serial 1142681570 [SPODLETELO]
and as soon as i delete domain from ispconfig, iw works normally again. If i create domain in Webmin, it works perfectly... I realy have to fix that, becouse i don't want to create all domains for my resellers and costumers manualy. Any suggestions?

Have A Nice Day, Nejko
Reply With Quote
Sponsored Links
  #2  
Old 22nd March 2006, 16:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

It's not an ISPConfig problem, the problem is that Webmin and ISPConfig are interfering because both try to configure the same service. Either use ISPConfig or Webmin for configuring BIND, but not both.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 22nd March 2006, 19:17
Nejko Nejko is offline
Senior Member
 
Join Date: Jan 2006
Posts: 132
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok, i stopped Webmin, but it's same problem..... It just won't work. Is it possible, that i give u acess and u take closer look? It would be easier i guess...

?
Reply With Quote
  #4  
Old 23rd March 2006, 00:31
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

If you need this kind of support, have a look here: http://www.ispconfig.org/support.htm

But the problem should be easy to solve: have a look at named.conf, then have a look at the error message, and also have a look at your zone files. Normally you should see then where the problem is.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 23rd March 2006, 13:40
Nejko Nejko is offline
Senior Member
 
Join Date: Jan 2006
Posts: 132
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Look, i created 123.nero-server.com and i get:
Quote:
Failed to start BIND : Starting named: Error in named configuration: zone 0.0.127.in-addr.arpa/IN: loaded serial 1997022700 zone 2.168.192.in-addr.arpa/IN: loading master file pri.2.168.192.in-addr.arpa: file not found _default/2.168.192.in-addr.arpa/IN: file not found zone 123.nero-server.com/IN: loading master file pri.123.nero-server.com: file not found _default/123.nero-server.com/IN: file not found zone nero-server.com/IN: loaded serial 1142867358 [SPODLETELO]
And If i look in it's zone file, there's notjing in it, but in named.conf is:
Quote:
zone "123.nero-server.com" {
type master;
file "pri.123.nero-server.com";
};
and the working domain created in webmin(nero-server.com) is:
Quote:
zone "nero-server.com" {
type master;
file "/var/named/nero-server.com.hosts";
};
Why is the file url diffarent?
Reply With Quote
  #6  
Old 23rd March 2006, 17:27
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Quote:
Originally Posted by Nejko
zone "123.nero-server.com" {
type master;
file "pri.123.nero-server.com";
};
You shouldn't use subdomains in zones. Use

Code:
zone "nero-server.com" {
  type master;
  file "pri.nero-server.com";
};
instead.
What's in your named.conf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 10:34.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.