Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 6th March 2009, 11:10
ignasigarcia ignasigarcia is offline
Member
 
Join Date: May 2006
Posts: 39
Thanks: 5
Thanked 1 Time in 1 Post
Default ispconfig3 bug: client cannot modify web settings

Hi, I have several test installations of ispconfig all running fine. Yesterday, though, I did a new one. I noticed some changes in comparison with the others (from 2 weeks ago, like /var/www/clients instead of /var/clients, etc). I also noticed a possible bug:

admin can create and modify web site settings in ispconfig panel. However, client can create the web site entry, but after that, future changes (size, php type, auto-subdomain) are not applied. Client can delete the web site though. Using the admin account I have deleted all related entries, even the client has been deleted. After recreating everything the problem reappears. Looks like the web site form might have a problem updating data to the database when being used as a client (again, as admin everything works fine)

Any ideas?

Ignacio
Reply With Quote
Sponsored Links
  #2  
Old 6th March 2009, 11:36
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,811
Thanks: 821
Thanked 5,339 Times in 4,188 Posts
Default

Thats not a bug, its the intended behaviour. Clients shall not be able to edit the settings of a website that a administrator created because this would allow them to extend their website quota etc. If a client created the website itself then he can change the settings of course.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 6th March 2009, 11:43
ignasigarcia ignasigarcia is offline
Member
 
Join Date: May 2006
Posts: 39
Thanks: 5
Thanked 1 Time in 1 Post
Default

that's a great idea, but in this case it is the client who has created the web site, not the admin.
Reply With Quote
  #4  
Old 6th March 2009, 11:47
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,811
Thanks: 821
Thanked 5,339 Times in 4,188 Posts
Default

You can post a bug report in the bugtracker if you want that we check it.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 6th March 2009, 12:10
ignasigarcia ignasigarcia is offline
Member
 
Join Date: May 2006
Posts: 39
Thanks: 5
Thanked 1 Time in 1 Post
Default

Great. I just did it.

Thanks

Ignacio
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
freebsd 7, samba 3, domain controller alexdimarco Suggest HOWTO 6 5th November 2010 16:54
ffmpeg Video support for ubuntu 7.10 [suphp-ispconfig] amaurib Installation/Configuration 13 16th February 2010 17:26
Possible Bug with Web Creation bolero Installation/Configuration 7 23rd July 2008 19:09
get thousands of "Mailsize" mails from own server torusturtle Installation/Configuration 20 24th December 2006 14:51


All times are GMT +2. The time now is 14:08.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.