#1  
Old 25th February 2009, 22:56
DestRoYeD DestRoYeD is offline
Junior Member
 
Join Date: Feb 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy Ispconfig 3 Vhost issues.

I Have Ispconfig 3 installed, One of my Coworkers was setting up awstats and made a mess of the Vhost files, I Have managed to fix this problem, But now many of my sites including the ispconfig 3 Admin, No longer work they just Redirect to the Default page.

Nothing in the apache error.log or the error log for that particular vhost.

I Have check the vhost files of the sites that don't work and they look fine.

This is the error i get when i restart apache2

Quote:
XXXXXX@XXXX:/etc/apache2/sites-available$ sudo /etc/init.d/apache2 start
* Starting web server apache2

[Thu Feb 26 10:45:50 2009] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
[Thu Feb 26 10:45:50 2009] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
[Thu Feb 26 10:45:50 2009] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
[Thu Feb 26 10:45:50 2009] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
[Thu Feb 26 10:45:50 2009] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
[Thu Feb 26 10:45:50 2009] [error] VirtualHost _default_:8080 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
[Thu Feb 26 10:45:50 2009] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
[Thu Feb 26 10:45:50 2009] [warn] NameVirtualHost *:8080 has no VirtualHosts

Quote:
[Thu Feb 26 10:45:50 2009] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
I have heard that this is a common problem with Ubuntu/Debian and has to do with the default file.


Any Ideas?

Brett

Last edited by DestRoYeD; 25th February 2009 at 23:04. Reason: Addition for Clarity
Reply With Quote
Sponsored Links
  #2  
Old 25th February 2009, 23:41
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,977
Thanks: 825
Thanked 5,369 Times in 4,216 Posts
Default

Yes, thats a issie with the default file. Open the apache default host file and replace * with *:80 in thevhost and the namevirtualhost directive and then restart apache.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 26th February 2009, 00:55
DestRoYeD DestRoYeD is offline
Junior Member
 
Join Date: Feb 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Cheers till,

I tried this and it just made all sites go to the default

Quote:
* Stopping web server apache2
[Thu Feb 26 12:51:22 2009] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Thu Feb 26 12:51:22 2009] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Thu Feb 26 12:51:22 2009] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Thu Feb 26 12:51:22 2009] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Thu Feb 26 12:51:22 2009] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Thu Feb 26 12:51:22 2009] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Thu Feb 26 12:51:22 2009] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Thu Feb 26 12:51:22 2009] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Thu Feb 26 12:51:22 2009] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Thu Feb 26 12:51:22 2009] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Thu Feb 26 12:51:22 2009] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Thu Feb 26 12:51:22 2009] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Thu Feb 26 12:51:22 2009] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Thu Feb 26 12:51:22 2009] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Thu Feb 26 12:51:22 2009] [warn] NameVirtualHost *:8080 has no VirtualHosts
My main problem is not being able to access the ispconfig administration. It just goes to the Default page e.t.c /var/www/index.php
Reply With Quote
  #4  
Old 26th February 2009, 09:13
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,977
Thanks: 825
Thanked 5,369 Times in 4,216 Posts
Default

Looks as if you specified more then one default host manually in your installation. You will have to remove them.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 26th February 2009, 21:08
DestRoYeD DestRoYeD is offline
Junior Member
 
Join Date: Feb 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Smile Thanks

Thanks Till, That was it still getting the same messages when i restart apache, But everything seems to be working now

Cheers
Reply With Quote
  #6  
Old 25th November 2010, 11:29
vk1003 vk1003 is offline
Junior Member
 
Join Date: Nov 2010
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default small issue

hi there,

not sure if i have to post this here or as a new topic.. we have installed the centos 5.5 and installed ispconfig3 as well, mails are working perfectly for the domain we create via the ispconfig control panel and ftp is working absolutely fine showing all folders inside and uploading is smooth as well.

but the website alone is not showing up.. for what ever domain account we create it shows the apache test page only and not that of the one we uploaded on ftp..

We installed apache and everything via the ispconfig3 and nothign was manually edited.. can some one help us where the mistake is hapening to sort the same.

regards
venkat v
Reply With Quote
  #7  
Old 21st July 2011, 06:17
gawry gawry is offline
Junior Member
 
Join Date: Jun 2010
Posts: 23
Thanks: 3
Thanked 1 Time in 1 Post
Default All domains pointing to the same page

All my domains added in the ISP config panel are pointing to the same page.

This is what i get when I restart Apache.

Code:
root@web1:/etc/apache2# /etc/init.d/apache2 restart
Restarting web server: apache2[Thu Jul 21 00:52:31 2011] [warn] NameVirtualHost 192.168.175.56:443 has no VirtualHosts
 ... waiting [Thu Jul 21 00:52:33 2011] [warn] NameVirtualHost 192.168.175.56:443 has no VirtualHosts
Any ideas?
Reply With Quote
  #8  
Old 21st July 2011, 10:15
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,977
Thanks: 825
Thanked 5,369 Times in 4,216 Posts
Default

Make sure that you selected either * or the ip address for all websites and do not mix that. If you selcted now * for all sites and get the behaviour that you described, then switch all sites to use the IP address.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 21st July 2011, 22:54
gawry gawry is offline
Junior Member
 
Join Date: Jun 2010
Posts: 23
Thanks: 3
Thanked 1 Time in 1 Post
Default Problem solved

I've fixed the issue but I don't know what was the cause. As it was a fresh installation I've just reinstalled everything again an it worked.
Reply With Quote
  #10  
Old 21st July 2011, 22:58
gawry gawry is offline
Junior Member
 
Join Date: Jun 2010
Posts: 23
Thanks: 3
Thanked 1 Time in 1 Post
Default

I would love to help ISP Config with a UX Redesign. I have a UX Consultancy from Brazil and I'm using for some of our servers. I think that ISP Config is great in some aspects but it lacks a better UI and some functionality.

Client templates for example could be more powerful, I had to create a manual procedure to "Add new site" to remember that emails, ftp, ssh, domains and etc need do be configured each time i add a new website
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3.0.0.4 Beta Released till General 54 4th March 2009 09:55
Ubuntu and ISPConfig, vhost problem jero Installation/Configuration 6 27th February 2008 16:40
vhost not working on ISPConfig 2.2.13 tannnk Installation/Configuration 2 22nd June 2007 14:31
Some ISPConfig issues... Caledfwlch Installation/Configuration 1 23rd June 2006 11:28
FC4 Setup DNS and ISPCONFIG issues The General Installation/Configuration 7 15th May 2006 09:45


All times are GMT +2. The time now is 03:58.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.