Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 4th February 2009, 23:25
koltz koltz is offline
Member
 
Join Date: Feb 2007
Posts: 61
Thanks: 0
Thanked 2 Times in 2 Posts
Default Issues with MyDNS and ISPConfig 3.0.0.8

I am having some issues. I followed the Ubnuntu 8.04 instructions on installing, but it shows DNS-Server is Offline in ISPConfig. I believe it is running though can't verify it.

Also, when I setup virtual hosts, they are not directing to the correct virtual host directory, they are just going to the first virtual host on that IP (I have two seperate IP addresses). So the first vhost for example is example.com, second is example2.com, but it is going to example.com's website instead. This is doing the same on both IP addresses. I am not sure if this is a DNS issue or not. I have not setup any DNS entries either as I can't find directions to the proper procedure.

Any help would be great!

Thanks,

Corey
Reply With Quote
Sponsored Links
  #2  
Old 5th February 2009, 11:01
peterspoon peterspoon is offline
Junior Member
 
Join Date: Jul 2007
Location: Blagoevgrad, Bulgaria
Posts: 12
Thanks: 36
Thanked 1 Time in 1 Post
Default Vhosts

I have similar problem with virtual hosts. It appears when setting up a site (vhost) I choose IP address (one server with one IP) from drop down menu. Then all domains point to one site (every domain shows the same site content). When I choose a star * instead of IP, everything works fine (sites show normally).
Almost fine, because then I get apache error at the server startup:
Code:
[error] Virtual Host *:80 --mixing * ports and non-* ports with a NameVirtualHost address is not supported...
So when shall we choose an IP and when a star?

the server is Debian Etch

Last edited by peterspoon; 5th February 2009 at 11:04.
Reply With Quote
  #3  
Old 5th February 2009, 18:09
koltz koltz is offline
Member
 
Join Date: Feb 2007
Posts: 61
Thanks: 0
Thanked 2 Times in 2 Posts
Default

I get the same error for Apache2 also when loading. I haven't tried the *, just assigned it per IP address that I wanted each domain because couple of them will require SSL.
Reply With Quote
  #4  
Old 5th February 2009, 18:59
koltz koltz is offline
Member
 
Join Date: Feb 2007
Posts: 61
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Well tried changing mine to an * and same thing. I get the following for error messages with Apache2:

Code:
[Tue Feb 03 17:21:40 2009] [warn] VirtualHost 172.21.152.31:80 overlaps with VirtualHost 172.21.152.31:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:21:40 2009] [warn] VirtualHost 172.21.152.32:80 overlaps with VirtualHost 172.21.152.32:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:21:40 2009] [warn] VirtualHost 172.21.152.31:80 overlaps with VirtualHost 172.21.152.31:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:21:40 2009] [warn] VirtualHost 172.21.152.31:80 overlaps with VirtualHost 172.21.152.31:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:21:40 2009] [warn] VirtualHost 172.21.152.31:80 overlaps with VirtualHost 172.21.152.31:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:21:40 2009] [warn] VirtualHost 172.21.152.31:80 overlaps with VirtualHost 172.21.152.31:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:21:40 2009] [warn] VirtualHost 172.21.152.32:80 overlaps with VirtualHost 172.21.152.32:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:21:40 2009] [warn] VirtualHost 172.21.152.32:80 overlaps with VirtualHost 172.21.152.32:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:21:40 2009] [warn] VirtualHost 172.21.152.32:80 overlaps with VirtualHost 172.21.152.32:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:21:40 2009] [warn] VirtualHost 172.21.152.32:80 overlaps with VirtualHost 172.21.152.32:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:21:40 2009] [warn] VirtualHost 172.21.152.31:80 overlaps with VirtualHost 172.21.152.31:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:21:40 2009] [warn] VirtualHost 172.21.152.31:80 overlaps with VirtualHost 172.21.152.31:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:21:40 2009] [warn] VirtualHost 172.21.152.31:80 overlaps with VirtualHost 172.21.152.31:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:21:40 2009] [warn] NameVirtualHost *:80 has no VirtualHosts
Reply With Quote
  #5  
Old 5th February 2009, 22:10
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,748 Times in 2,579 Posts
Default

Quote:
Originally Posted by koltz View Post
I am having some issues. I followed the Ubnuntu 8.04 instructions on installing, but it shows DNS-Server is Offline in ISPConfig. I believe it is running though can't verify it.
Try
Code:
/etc/init.d/mydns restart
Waht's in /etc/apache2/sites-available/default and in one of the other vhosts?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 6th February 2009, 03:04
koltz koltz is offline
Member
 
Join Date: Feb 2007
Posts: 61
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Code:
NameVirtualHost *
<VirtualHost *>
        ServerAdmin webmaster@localhost

        DocumentRoot /var/www/
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /var/www/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog /var/log/apache2/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog /var/log/apache2/access.log combined
        ServerSignature On

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>
I have tried restarting MyDNS before including stop and start and doesn't seem to change the status in the backend. How can I verify it is running from the command line, netstat?
Reply With Quote
  #7  
Old 6th February 2009, 11:53
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,804
Thanks: 840
Thanked 5,613 Times in 4,424 Posts
Default

You have to change the lines:

NameVirtualHost *
<VirtualHost *>


to:

NameVirtualHost *:80
<VirtualHost *:80>

and then restart apache.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 6th February 2009, 19:18
koltz koltz is offline
Member
 
Join Date: Feb 2007
Posts: 61
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Thank you for the post, here is what I get when I restart Apache now, and still not working on the frontend.

Code:
 * Restarting web server apache2                                                                                                                                                                               [Tue Feb 03 17:15:02 2009] [error] (EAI 2)Name or service not known: Could not resolve host name *80 -- ignoring!
[Tue Feb 03 17:15:02 2009] [warn] VirtualHost 172.21.152.31:80 overlaps with VirtualHost 172.21.152.31:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:15:02 2009] [warn] VirtualHost 172.21.152.32:80 overlaps with VirtualHost 172.21.152.32:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:15:02 2009] [warn] VirtualHost 172.21.152.31:80 overlaps with VirtualHost 172.21.152.31:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:15:02 2009] [warn] VirtualHost 172.21.152.31:80 overlaps with VirtualHost 172.21.152.31:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:15:02 2009] [warn] VirtualHost 172.21.152.31:80 overlaps with VirtualHost 172.21.152.31:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:15:02 2009] [warn] VirtualHost 172.21.152.31:80 overlaps with VirtualHost 172.21.152.31:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:15:02 2009] [warn] VirtualHost 172.21.152.32:80 overlaps with VirtualHost 172.21.152.32:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:15:02 2009] [warn] VirtualHost 172.21.152.32:80 overlaps with VirtualHost 172.21.152.32:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:15:02 2009] [warn] VirtualHost 172.21.152.32:80 overlaps with VirtualHost 172.21.152.32:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:15:02 2009] [warn] VirtualHost 172.21.152.32:80 overlaps with VirtualHost 172.21.152.32:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:15:02 2009] [warn] VirtualHost 172.21.152.31:80 overlaps with VirtualHost 172.21.152.31:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:15:02 2009] [warn] VirtualHost 172.21.152.31:80 overlaps with VirtualHost 172.21.152.31:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:15:02 2009] [warn] VirtualHost 172.21.152.31:80 overlaps with VirtualHost 172.21.152.31:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:15:12 2009] [error] (EAI 2)Name or service not known: Could not resolve host name *80 -- ignoring!
[Tue Feb 03 17:15:12 2009] [warn] VirtualHost 172.21.152.31:80 overlaps with VirtualHost 172.21.152.31:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:15:12 2009] [warn] VirtualHost 172.21.152.32:80 overlaps with VirtualHost 172.21.152.32:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:15:12 2009] [warn] VirtualHost 172.21.152.31:80 overlaps with VirtualHost 172.21.152.31:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:15:12 2009] [warn] VirtualHost 172.21.152.31:80 overlaps with VirtualHost 172.21.152.31:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:15:12 2009] [warn] VirtualHost 172.21.152.31:80 overlaps with VirtualHost 172.21.152.31:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:15:12 2009] [warn] VirtualHost 172.21.152.31:80 overlaps with VirtualHost 172.21.152.31:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:15:12 2009] [warn] VirtualHost 172.21.152.32:80 overlaps with VirtualHost 172.21.152.32:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:15:12 2009] [warn] VirtualHost 172.21.152.32:80 overlaps with VirtualHost 172.21.152.32:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:15:12 2009] [warn] VirtualHost 172.21.152.32:80 overlaps with VirtualHost 172.21.152.32:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:15:12 2009] [warn] VirtualHost 172.21.152.32:80 overlaps with VirtualHost 172.21.152.32:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:15:12 2009] [warn] VirtualHost 172.21.152.31:80 overlaps with VirtualHost 172.21.152.31:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:15:12 2009] [warn] VirtualHost 172.21.152.31:80 overlaps with VirtualHost 172.21.152.31:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 03 17:15:12 2009] [warn] VirtualHost 172.21.152.31:80 overlaps with VirtualHost 172.21.152.31:80, the first has precedence, perhaps you need a NameVirtualHost directive
Reply With Quote
  #9  
Old 6th February 2009, 19:36
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,748 Times in 2,579 Posts
Default

Can you post one of the vhosts created by ISPConfig (you can find them in the /etc/apache2/sites-available directory as well)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
MyDNS And The MyDNSConfig Control Panel and ISPConfig pg001 General 2 29th July 2008 03:31
ispconfig 3 joining frontend Snowman General 1 28th June 2008 18:28
MyDNS + ISPConfig msource General 1 5th May 2007 14:05
MyDNS and ISPConfig CoDonCo General 3 27th July 2006 09:25
ISPConfig Devel Report. till Developers' Forum 3 27th November 2005 16:07


All times are GMT +2. The time now is 19:25.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.