Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd January 2009, 16:18
GOSBX GOSBX is offline
Junior Member
 
Join Date: Sep 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Help dsn=5.4.6, status=bounced (mail for xx.com loops back to myself) ispconfig

Hi friends

i have Ispconfig, that is working ok (few months) but yesterday postfix dont receibe any mail i dont change anything, i run rkhunter and see nothing wrong.

my postfix cf.

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
broken_sasl_auth_clients = yes
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/libexec/postfix
debug_peer_level = 2
home_mailbox = Maildir/
html_directory = no
inet_interfaces = all
mail_owner = postfix
mailbox_command =
mailq_path = /usr/bin/mailq.postfix
manpage_directory = /usr/share/man
mydestination = /etc/postfix/local-host-names
myhostname = tuweb.us
mynetworks = 127.0.0.0/8
newaliases_path = /usr/bin/newaliases.postfix
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/postfix-2.3.3/README_FILES
sample_directory = /usr/share/doc/postfix-2.3.3/samples
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdrop
smtp_tls_note_starttls_offer = yes
smtp_use_tls = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_authenticated_header = yes
smtpd_sasl_local_domain =
smtpd_sasl_security_options = noanonymous
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_auth_only = no
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
smtpd_use_tls = yes
tls_random_source = dev:/dev/urandom
unknown_local_recipient_reject_code = 550


i see in HowtoForge some threads, i try all i see but i have the same error:

Jan 22 09:21:49 ns1 postfix/smtpd[10069]: connect from rv-out-0708.google.com[209.85.198.241]
Jan 22 09:21:50 ns1 postfix/smtpd[10069]: 44A3A530477: client=rv-out-0708.google.com[209.85.198.241]
Jan 22 09:21:50 ns1 postfix/cleanup[10066]: 44A3A530477: message-id=<61d6a27f0901220621o63855160qfc128cdebf56ac90@m ail.gmail.com>
Jan 22 09:21:50 ns1 postfix/qmgr[10015]: 44A3A530477: from=<giacomo.o@gmail.com>, size=1848, nrcpt=1 (queue active)
Jan 22 09:21:50 ns1 postfix/smtp[10020]: warning: numeric domain name in resource data of MX record for tuweb.us: 190.95.170.246
Jan 22 09:21:50 ns1 postfix/smtp[10020]: 44A3A530477: to=<web4_test@tuweb.us>, orig_to=<test@kvantmedical.com>, relay=none, delay=0.52, delays=0.52/0/0/0, dsn=5.4.6, status=bounced (mail for tuweb.us loops back to myself)
Jan 22 09:21:50 ns1 postfix/cleanup[10066]: 9C19C530483: message-id=<20090122142150.9C19C530483@tuweb.us>
Jan 22 09:21:50 ns1 postfix/qmgr[10015]: 9C19C530483: from=<>, size=3590, nrcpt=1 (queue active)
Jan 22 09:21:50 ns1 postfix/bounce[10068]: 44A3A530477: sender non-delivery notification: 9C19C530483
Jan 22 09:21:50 ns1 postfix/qmgr[10015]: 44A3A530477: removed


and i receibe that when i send mail to some user in my server:

This is the mail system at host tuweb.us.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to <postmaster>

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The mail system

<web4_test@tuweb.us> (expanded from <test@kvantmedical.com>): mail for tuweb.us
loops back to myself

Final-Recipient: rfc822; web4_test@tuweb.us
Original-Recipient: rfc822;test@kvantmedical.com
Action: failed
Status: 5.4.6
Diagnostic-Code: X-Postfix; mail for tuweb.us loops back to myself

Help Me please friends.
Reply With Quote
Sponsored Links
  #2  
Old 23rd January 2009, 09:43
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

You are breaking RFC regulations by using an ip address for the MX record instead of a name.

The loopback problem is usually where DNS points to a machine which itself is not accepting mail for the domain.

Fix your DNS
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #3  
Old 5th November 2009, 11:12
thabangk thabangk is offline
Member
 
Join Date: Sep 2009
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I got the same problem and it's becoming so frustrating for me,my mailserver is behind the firewall and i'm using dyndns to test and it only recognize the IP that's at my firewall.how can i make my other NIC to be recognized by DynDNS.

HELP HELP HELP
Reply With Quote
  #4  
Old 6th November 2009, 14:40
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Can you post the exact error messages from your mail log?
What's the output of
Code:
ifconfig
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 6th November 2009, 14:53
thabangk thabangk is offline
Member
 
Join Date: Sep 2009
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Default

eth0 Link encap:Ethernet HWaddr 00:1E:903:32:71
inet addr:192.168.10.225 Bcast:192.168.10.255 Mask:255.255.255.0
inet6 addr: fe80::21e:90ff:fed3:3271/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:151549 errors:0 dropped:0 overruns:0 frame:0
TX packets:10265 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:13033179 (12.4 MiB) TX bytes:2478415 (2.3 MiB)
Interrupt:201 Base address:0x2800

eth1 Link encap:Ethernet HWaddr 00:21:91:0C:00:31
inet addr:192.168.10.226 Bcast:192.168.10.255 Mask:255.255.255.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:169 Base address:0xc00

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2802 errors:0 dropped:0 overruns:0 frame:0
TX packets:2802 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2648815 (2.5 MiB) TX bytes:2648815 (2.5 MiB)
Reply With Quote
  #6  
Old 6th November 2009, 14:57
thabangk thabangk is offline
Member
 
Join Date: Sep 2009
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Default

The mailog errors are as attached
Attached Files
File Type: txt maillog.txt (3.5 KB, 311 views)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
localhost postfix/master: fatal: bind 127.0.0.1 port 125: Permission denied g18c Installation/Configuration 4 24th March 2009 17:39
Postfix & mail forwarding loop varnik Server Operation 21 9th December 2008 15:13
Filtering emails using Spamassassin and Clamav for Exchange 2000 Server Rocky Server Operation 19 11th March 2008 08:27
Would the problem come from postfix? satimis Server Operation 10 27th January 2008 10:31


All times are GMT +2. The time now is 20:36.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.