Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 7th March 2006, 03:01
ryanhs ryanhs is offline
Junior Member
 
Join Date: Mar 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default postfix TLS problem - please help!

hello I have successfully installed howtoforge ubuntu breezy and everything is working great except smtp tls. here is a copy of the problem from mail.log. I would very much appreciate any information that woudl help me with this issue. I have been trying to figure this out all day.

Mar 6 20:47:22 bbmail3 postfix/smtpd[15657]: warning: cannot get private key from file /etc/postfix/ssl/smtpd.crt
Mar 6 20:47:22 bbmail3 postfix/smtpd[15657]: warning: TLS library problem: 15657:error:0906D06C:PEM routines:PEM_read_bio:no start lineem_lib.c:642:Expecting: ANY PRIVATE KEY:
Mar 6 20:47:22 bbmail3 postfix/smtpd[15657]: warning: TLS library problem: 15657:error:140B0009:SSL routines:SSL_CTX_use_PrivateKey_file:PEM lib:ssl_rsa.c:709:
Mar 6 20:47:22 bbmail3 postfix/smtpd[15657]: cannot load RSA certificate and key data
Mar 6 20:47:27 bbmail3 postfix/smtpd[15657]: connect from unknown[67.50.128.80]
Mar 6 20:47:42 bbmail3 postfix/smtpd[15657]: lost connection after STARTTLS from unknown[67.50.128.80]
Mar 6 20:47:42 bbmail3 postfix/smtpd[15657]: disconnect from unknown[67.50.128.80]



Additional information:
-----------------------------------------------------------------------
ls -l /etc/postfix/ssl
total 20
-rw-r--r-- 1 root root 969 2006-03-06 20:12 cacert.pem
-rw-r--r-- 1 root root 963 2006-03-06 20:12 cakey.pem
-rw-r--r-- 1 root root 741 2006-03-06 20:11 smtpd.crt
-rw-r--r-- 1 root root 631 2006-03-06 20:11 smtpd.csr
-rw-r--r-- 1 root root 887 2006-03-06 20:11 smtpd.key
root@bbmail3:/etc/postfix#

------------------------------------------------------------------------
root@bbmail3:/etc/postfix/ssl# cat smtpd.crt
-----BEGIN CERTIFICATE-----
MIIB9TCCAV4CCQDG3QcPheHAVjANBgkqhkiG9w0BAQQFADA/MQswCQYDVQQGEwJV
UzOpkSo2VCwtCQoa7755gAmldydeOru
vacIU4Heskrv6PVj/0CWLvDhh7gvkydN0XLZMp21j22b2m8fRhuI+X9c/neesEQ0
BxV0F+ixLs+2bIMseMFBrSrCx6AuBITL9Q==
-----END CERTIFICATE-----
root@bbmail3:/etc/postfix/ssl#

NOTE: The middle of the ssl cert was removed for security.

I was not able to find any information online about the problem that I am having.

I have redone the openssl steps from:
http://howtoforge.com/perfect_setup_ubuntu_5.10_p4

Last edited by ryanhs; 7th March 2006 at 17:35.
Reply With Quote
Sponsored Links
  #2  
Old 7th March 2006, 10:14
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Hm, maybe you have a corrupt SSL cert (but you have already redone all the steps from the tutorial...).

If you don't need TLS I wouldn't use it.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 7th March 2006, 17:34
ryanhs ryanhs is offline
Junior Member
 
Join Date: Mar 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default is there perhaps..

is there some other agent that relays the ssl cert to postfix/smtpd?

Last edited by ryanhs; 7th March 2006 at 17:38.
Reply With Quote
  #4  
Old 7th March 2006, 23:17
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

How do you mean that?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 9th August 2006, 22:40
paolo paolo is offline
Junior Member
 
Join Date: Aug 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Same problem here...
Reply With Quote
  #6  
Old 10th August 2006, 18:27
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

What's the exact problem? What's in your logs?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix ISPconfig problem matehortua Installation/Configuration 8 3rd September 2006 17:03
postfix auth problem (sasl) lerra Installation/Configuration 40 10th May 2006 23:36
postfix problem flourishing General 1 7th December 2005 17:39
Postfix mail problem rytech Installation/Configuration 1 21st November 2005 16:44
Postfix Problem m u r Installation/Configuration 0 8th August 2005 19:12


All times are GMT +2. The time now is 16:07.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.