#1  
Old 6th March 2006, 10:30
KamiTsunami KamiTsunami is offline
Junior Member
 
Join Date: Mar 2006
Location: Los Angeles
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default Relay access denied

hi,

i did the perfect setup for debian sarge. i can send email o.k., but when receiving email, /var/log/mail.log shows "Relay access denied".

Mar 6 01:09:41 trackandfieldphoto postfix/smtpd[15466]: connect from mail.sysmatrix.net[65.170.133.30]
Mar 6 01:09:41 trackandfieldphoto postfix/smtpd[15466]: NOQUEUE: reject: RCPT from mail.sysmatrix.net[65.170.133.30]: 554 <root@TrackAndFieldPhoto.net>: Relay access denied; from=<randy@trackandfieldphoto.com> to=<root@TrackAndFieldPhoto.net> proto=ESMTP helo=<mail.sysmatrix.net>
Mar 6 01:09:41 trackandfieldphoto postfix/smtpd[15466]: disconnect from mail.sysmatrix.net[65.170.133.30]

i restarted postfix, saslauthd, bind, and same errors. i followed the steps in the tutorial, and setup /etc/pam.d/smtp as i read on several threads.

i wonder what i'm missing ?
Reply With Quote
Sponsored Links
  #2  
Old 6th March 2006, 10:55
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Is TrackAndFieldPhoto.net in mydestination in /etc/postfix/main.cf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 6th March 2006, 11:42
KamiTsunami KamiTsunami is offline
Junior Member
 
Join Date: Mar 2006
Location: Los Angeles
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

WOW THAT WORKED ! THANX ;-) now email is received in ~/Maildir/new.

then i tried pop email (Mozilla/XP) from my laptop, and i get:

Mar 6 02:24:22 trackandfieldphoto authdaemond.mysql: failed to connect to mysql server (server=localhost, userid=provider_admin)
Mar 6 02:24:27 trackandfieldphoto courierpop3login: LOGIN FAILED, ip=[::ffff:12.226.178.67]
Mar 6 02:24:42 trackandfieldphoto courierpop3login: Connection, ip=[::ffff:12.226.178.67]
Mar 6 02:24:48 trackandfieldphoto authdaemond.mysql: failed to connect to mysql server (server=localhost, userid=provider_admin)
Mar 6 02:24:53 trackandfieldphoto courierpop3login: LOGIN FAILED, ip=[::ffff:12.226.178.67]
Mar 6 02:24:55 trackandfieldphoto authdaemond.mysql: failed to connect to mysql server (server=localhost, userid=provider_admin)
Mar 6 02:25:00 trackandfieldphoto courierpop3login: LOGIN FAILED, ip=[::ffff:12.226.178.67]

i double checked the courier-pop3 sentences in the tutorial. hmmm...
Reply With Quote
  #4  
Old 6th March 2006, 11:55
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Is MySQL running, and is the username/password correct? Please post the output of
Code:
netstat -tap
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 7th March 2006, 00:49
KamiTsunami KamiTsunami is offline
Junior Member
 
Join Date: Mar 2006
Location: Los Angeles
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

hi,

i setup /etc/courier/authmysqlrc with the correct MYSQL_USERNAME and MYSQL_PASSWORD. still the login fails.

"netstat -tap" displays:

------------------------------------------------------------------------------------
tcp 0 0 *:imaps *:* LISTEN 19562/couriertcpd
tcp 0 0 *op3s *:* LISTEN 19546/couriertcpd
tcp 0 0 *:mysql *:* LISTEN 13401/mysqld
tcp 0 0 *op3 *:* LISTEN 19407/couriertcpd
tcp 0 0 *:imap2 *:* LISTEN 19985/couriertcpd
tcp 0 0 *:10000 *:* LISTEN 7935/perl
tcp 0 0 *:www *:* LISTEN 1541/apache2
tcp 0 0 *:ftp *:* LISTEN 15583/inetd
tcp 0 0 trackandfieldpho:domain *:* LISTEN 12128/named
tcp 0 0 localhost.locald:domain *:* LISTEN 12128/named
tcp 0 0 *:ssh *:* LISTEN 1537/sshd
tcp 0 0 *:smtp *:* LISTEN 20846/master
tcp 0 0 localhost.localdoma:953 *:* LISTEN 12128/named
tcp 0 0 *:https *:* LISTEN 1541/apache2
tcp 0 0 trackandfieldphot:41412 12-226-178-67.cli:51136 TIME_WAIT -
tcp 0 0 trackandfieldphoto.:ftp 12-226-178-67.cli:50506 ESTABLISHED27212/in.ftpd: 12-2
tcp 0 300 trackandfieldphoto.:ssh 12-226-178-67.cli:57422 ESTABLISHED30368/sshd: admin [
------------------------------------------------------------------------------------

"tail -n100 /var/log/mail.log" shows:

------------------------------------------------------------------------------------
Mar 6 15:40:01 trackandfieldphoto postfix/pickup[26953]: 82DEB6FCFB: uid=105 from=<smmsp>
Mar 6 15:40:01 trackandfieldphoto postfix/cleanup[27299]: 82DEB6FCFB: message-id=<20060306234001.82DEB6FCFB@server1.trackandfiel dphoto.net>
Mar 6 15:40:01 trackandfieldphoto postfix/qmgr[20851]: 82DEB6FCFB: from=<smmsp@trackandfieldphoto.net>, size=680, nrcpt=1 (queue active)
Mar 6 15:40:01 trackandfieldphoto postfix/local[27301]: 82DEB6FCFB: to=<admin@trackandfieldphoto.net>, orig_to=<root>, relay=local, delay=0, status=sent (delivered to maildir)
Mar 6 15:40:01 trackandfieldphoto postfix/qmgr[20851]: 82DEB6FCFB: removed
Mar 6 15:42:26 trackandfieldphoto courierpop3login: Connection, ip=[::ffff:12.226.178.67]
Mar 6 15:42:37 trackandfieldphoto courierpop3login: LOGIN FAILED, ip=[::ffff:12.226.178.67]
Mar 6 15:43:04 trackandfieldphoto last message repeated 2 times
------------------------------------------------------------------------------------
Reply With Quote
  #6  
Old 7th March 2006, 01:51
KamiTsunami KamiTsunami is offline
Junior Member
 
Join Date: Mar 2006
Location: Los Angeles
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i found the problem, please ignore my last message. i had a mysql database with the exact same name 'provider' from some other server. i dropped it.

now, when i try to used mozilla/xp to access pop3, it can't find he database 'provider':

--------------------------------------------------------------------------------------------
Mar 6 16:40:01 trackandfieldphoto postfix/pickup[27863]: D92E36FCFB: uid=105 from=<smmsp>
Mar 6 16:40:01 trackandfieldphoto postfix/cleanup[27898]: D92E36FCFB: message-id=<20060307004001.D92E36FCFB@server1.trackandfiel dphoto.net>
Mar 6 16:40:01 trackandfieldphoto postfix/qmgr[27864]: D92E36FCFB: from=<smmsp@trackandfieldphoto.net>, size=680, nrcpt=1 (queue active)
Mar 6 16:40:01 trackandfieldphoto postfix/local[27900]: D92E36FCFB: to=<admin@trackandfieldphoto.net>, orig_to=<root>, relay=local, delay=0, status=sent (delivered to maildir)
Mar 6 16:40:01 trackandfieldphoto postfix/qmgr[27864]: D92E36FCFB: removed
Mar 6 16:40:42 trackandfieldphoto courierpop3login: Connection, ip=[::ffff:12.226.178.67]
Mar 6 16:40:42 trackandfieldphoto authdaemond.mysql: authmysql: mysql_select_db(provider) error: Unknown database 'provider'
Mar 6 16:40:47 trackandfieldphoto courierpop3login: LOGIN FAILED, ip=[::ffff:12.226.178.67]
Mar 6 16:40:56 trackandfieldphoto authdaemond.mysql: authmysql: mysql_select_db(provider) error: Unknown database 'provider'
Mar 6 16:41:01 trackandfieldphoto courierpop3login: LOGIN FAILED, ip=[::ffff:12.226.178.67]
--------------------------------------------------------------------------------------------

so i tried

apt-get remove courier-imap courier-imap-ssl courier-pop courier-pop-ssl
apt-get install courier-imap courier-imap-ssl courier-pop courier-pop-ssl

but i get the same errors. i guess i need the tutorial on how to setup 'courier- pop3'.

...randy in l.a.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Relay access denied when using SMTP to external recipients Kamran Shah Installation/Configuration 111 14th May 2014 18:10
Relay access denied maxx Installation/Configuration 17 4th April 2011 12:34
relay access denied (i've readen the previous post about this ) jeanjacquesjeanjacques Installation/Configuration 5 21st April 2006 23:34
Bug? (postfix refuses mail, relay access denied) st2xo General 2 31st January 2006 16:00
Everything is working except Access denied page SeaWolf Installation/Configuration 2 10th December 2005 15:16


All times are GMT +2. The time now is 23:55.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.