#1  
Old 13th November 2008, 18:26
turbolad turbolad is offline
Junior Member
 
Join Date: Nov 2008
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default Can send but cant receive email

I have some more questions I hope someone can answer

I have installed the roundcube webmail package... However when using it I can only send email and not receive it?
If i request a receipt when sending an email to the domain hosted on my ispconfig server I instantly get a reply:
Quote:
This is the mail system at host webserver.mydomain.co.uk.

Your message was successfully delivered to the destination(s)
listed below. If the message was delivered to mailbox you will
receive no further notifications. Otherwise you may still receive
notifications of mail delivery errors from other systems.

The mail system

<me@mydomain.co.uk>: alias expanded
which means postfix has accepted it, yes?
So why does it not appear in my roundcube mailbox?

Here are the DNS settings on my registrar, 123-reg account (I don't think these are the problem although I've prob done something wrong)

The nameservers are 123 reg's. Is this OK? or should I use my ispconfig server?

Quote:
Name type content
@ A ISPCONFIG external IP
ftp A ISPCONFIG external IP
mail A ISPCONFIG external IP
webserver A ISPCONFIG external IP
www A ISPCONFIG external IP

MX Record
mail.mydomain.co.uk.
In ISPCONFIG under DNS management for mydomain.co.uk under options tab I have,
Quote:
Nameserver1 webserver.mydomain.co.uk
Nameserver2 webserver.mydomain.co.uk
Under records tab I have,

Quote:
A Record
IP-Adresse Hostname
192.168.0.100 www

MX
Mailserver Hostname
webserver.around-it.co.uk *blank*

Hostname
mydomain.co.uk
under ISP manager on the ISP Site under the Basis tab I have "create DNS" ticked and "create DNS MX" unticked.
Reply With Quote
Sponsored Links
  #2  
Old 13th November 2008, 23:09
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,717
Thanks: 820
Thanked 5,322 Times in 4,175 Posts
Default

please post the exact messages that apper in the mail log file when you send a email to a local account.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 14th November 2008, 12:35
turbolad turbolad is offline
Junior Member
 
Join Date: Nov 2008
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Till,

Would this be the bit I should look at: (changed ip and domains)
Quote:
Nov 14 11:16:45 server1 postfix/qmgr[4916]: 7BB69ABE5A2: from=<adam@mydomain2.com>, size=502, nrcpt=1 (queue active)
Nov 14 11:16:45 server1 postfix/smtp[5647]: connect to webserver.mydomain1.co.uk[87.111.111.1]:25: Connection refused
Nov 14 11:16:45 server1 postfix/smtp[5647]: 7BB69ABE5A2: to=<web9_adam@webserver.mydomain1.co.uk>, orig_to=<adam.surname@mydomain1.co.uk>, relay=none, delay=1098, delays=1098/0.02/0.07/0, dsn=4.4.1, status=$
Nov 14 11:17:44 server1 imapd: Connection, ip=[::ffff:127.0.0.1]
I notice that my connection is being refused? The domain I use for ispconfig is also my recipient above - would that make a difference?
also where it says server1 - that is the old name of the server.
When I installed ispconfig I used server1.example.com and afterwards changed it to a proper domain webserver.mydomain1.co.uk.
I used the following commands to change the host and domain.
/etc/hostname, /etc/hosts, /home/admispconfig/ispconfig/lib/config.inc.php and /root/ispconfig/httpd/conf/httpd.conf - Is that OK?
Reply With Quote
  #4  
Old 14th November 2008, 12:54
turbolad turbolad is offline
Junior Member
 
Join Date: Nov 2008
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I've managed to track the problem down:

/etc/postfix/main.cf had the entry server1.example.com name instead of my new webserver.mydomain1.co.uk.

Quote:
#mydestination = webserver.mydomain1.co.uk, localhost.example.com, localhost.localdomain, localhost
thanks till you pointed me in the right direction.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't send or receive email! sergio.morales Installation/Configuration 51 20th July 2008 20:04
Postfix won't receive external email fred!head Server Operation 2 29th June 2008 19:30
Cant send and receive email after remove dkfilter conf blackmask Installation/Configuration 1 20th December 2007 16:01
Max email send and receive size? statiic Installation/Configuration 2 9th November 2006 18:50
Can Send email but not receive it using sendmail on debian ZeroDni Installation/Configuration 7 25th June 2006 06:04


All times are GMT +2. The time now is 20:23.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.