Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Closed Thread
 
Thread Tools Display Modes
  #1  
Old 31st October 2008, 09:27
coolen coolen is offline
Junior Member
 
Join Date: Oct 2008
Posts: 26
Thanks: 3
Thanked 0 Times in 0 Posts
Default email receiving died ??? + report a bug in ispconfig email add/remove

I did set up ispconfig and suse 11.0 from scratch again, after some initial tries, and to avoid the errors I made earlier.

Everything seemed to work fine after I was ready, and also after the restart of my box (after having solved that I had to add some extra ports for proftpd to my firewall)

now suddenly after 2-3 days, I still am able to send mail from all the domains, but receiving mail doesn't seem to work anymore. I sure didn't change anything to the box as far as I know, and I am not able to see any error messages in the log files I think i need to check (mail.log, mail.warn, mail.error,mail.info)
since I'm new to ispconfig and pretty new to mailserver isssues I was wondering if one of you ppl could give me some clues about where to start looking.


Furthermore I want to report a bug:
I added a new mailuser in one of my webs, but forgot to set a pwd. So I deleted that email user again. Now it seems impossible to add that email user new again, since ispconfig keeps complaining that the email still exists. I have no clue where to look to remove that erreneous email user, so I can add it again.
Sponsored Links
  #2  
Old 31st October 2008, 12:04
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,258 Times in 4,122 Posts
Default

Which messages appear in the mail log when you send a message from a account on your server to another account on your server?

Quote:
Furthermore I want to report a bug:
I added a new mailuser in one of my webs, but forgot to set a pwd. So I deleted that email user again. Now it seems impossible to add that email user new again, since ispconfig keeps complaining that the email still exists. I have no clue where to look to remove that erreneous email user, so I can add it again.
Thats no bug. You just missed to empty the recycle bin
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
  #3  
Old 31st October 2008, 12:47
coolen coolen is offline
Junior Member
 
Join Date: Oct 2008
Posts: 26
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Hi Till, thanks for answering so quickly.

Oops

ok no bug then, just never could have thought that it would go to the recycle bin first.


As for the email, I do not have users that can log into the box, nor an email program there. But I'll try to set that up as test first.

I'll be back at you
  #4  
Old 31st October 2008, 13:44
coolen coolen is offline
Junior Member
 
Join Date: Oct 2008
Posts: 26
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Hi Till,

this is in /var/log/mail when I try to send from one till another client:

Oct 31 13:27:58 idefix postfix/pickup[32081]: 67AF1A563: uid=10003 from=<web2_arthur>
Oct 31 13:27:58 idefix postfix/cleanup[6998]: 67AF1A563: message-id=<20081031122758.67AF1A563@server1.example.com>
Oct 31 13:27:58 idefix postfix/qmgr[32084]: 67AF1A563: from=<web2_arthur@server1.example.com>, size=505, nrcpt=1 (queue active)
Oct 31 13:27:58 idefix postfix/smtp[7000]: 67AF1A563: to=<web3_henk@server1.example.com>, orig_to=<henk@cafestrings.com>, relay=none, delay=0.23, delays=0.13/0.02/0.08/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=server1.example.com type=AAAA: Host not found)
Oct 31 13:27:58 idefix postfix/cleanup[6998]: A008CA564: message-id=<20081031122758.A008CA564@server1.example.com>
Oct 31 13:27:58 idefix postfix/qmgr[32084]: A008CA564: from=<>, size=2527, nrcpt=1 (queue active)
Oct 31 13:27:58 idefix postfix/bounce[7001]: 67AF1A563: sender non-delivery notification: A008CA564
Oct 31 13:27:58 idefix postfix/qmgr[32084]: 67AF1A563: removed
Oct 31 13:27:58 idefix postfix/smtp[7000]: A008CA564: to=<web2_arthur@server1.example.com>, relay=none, delay=0.14, delays=0.06/0/0.08/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=server1.example.com type=AAAA: Host not found)
Oct 31 13:27:58 idefix postfix/qmgr[32084]: A008CA564: removed



for now I (try) not to use DNS, I have no clue what to prepare for it, and I want to configure the server step by step, hoping to solve the problems one by one.
So

I have set DNS in manager to off (hoping that all DNS issues are set aside with that) but obviously they haven't )


My dns services are done via afraid.org, and I did add smtp/pop3 and mail entries there.

on the websites on my server the MX boxis set to off but I do seem to have DNS entries in the DNS part of the ISPConfig UI
  #5  
Old 1st November 2008, 09:14
coolen coolen is offline
Junior Member
 
Join Date: Oct 2008
Posts: 26
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Nobody any suggestions anymore ?
  #6  
Old 1st November 2008, 16:21
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Please create an A record for server1.example.com. As a temporary workaround, you can add server1.example.com to /etc/hosts.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
email forwarding locally consumes all resources rdells General 20 1st May 2006 19:43
ISPConfig 2.2.0 problem with email addresses DataJet General 1 29th March 2006 13:29
ISPConfig Devel Report. till Developers' Forum 3 27th November 2005 15:07
ISP-Ubuntu breezy ispconfig dns email e-mail working finally yellowjelly HOWTO-Related Questions 0 19th November 2005 20:30
Receiving Email and Username Problem dstme General 20 16th November 2005 09:33


All times are GMT +2. The time now is 13:28.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.