Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 8th October 2008, 19:20
SupuS SupuS is offline
HowtoForge Supporter
 
Join Date: May 2006
Posts: 202
Thanks: 68
Thanked 14 Times in 12 Posts
Default IMAP Error: Account's mailbox directory is not owned by the correct uid or gid

Hi

I was forced to renew webs from zip backups from broken server on new one. Now when I would like to use IMAP it returns this error (tested as described on http://www.courier-mta.org/authlib/R...authdebug.html)

Code:
telnet localhost 143
Trying 127.0.0.1...
Connected to localhost.localdomain.
Escape character is '^]'.
* OK [CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA IDLE ACL ACL2=UNION STARTTLS] Courier-IMAP ready. Copyright 1998-2005 Double Precision, Inc.  See COPYING for distribution information.
a login username password
* BYE [ALERT] Fatal error: Account's mailbox directory is not owned by the correct uid or gid:
Connection closed by foreign host.
Error doesn't include any uid or gid so I don't know correct value.

Unfortunatelly zip doesn't support of preserve permissions so I manually changed owner and group of Maildir directory and its content to current user. I tested chmod to 777 to but without success. So at this time I cannot use IMAP. POP3 works fine.
Another strange thing is permissions of courierpop3dsizelist file. Its group changes from correct usergroup to 10027 number sometime. Probably old group id from old server?

I would like to use IMAP again but I didn't find any helpfull sollution. Any idea will be appreciated.

SupuS
Reply With Quote
Sponsored Links
  #2  
Old 9th October 2008, 14:22
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,177
Thanks: 829
Thanked 5,414 Times in 4,257 Posts
Default

Please edit a setting of this user in ispconfig, e.g. the quota value and click on save so ISPConfig updates the user and then try to access the mailbox again.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 9th October 2008, 14:34
SupuS SupuS is offline
HowtoForge Supporter
 
Join Date: May 2006
Posts: 202
Thanks: 68
Thanked 14 Times in 12 Posts
Default

Hi Till

Thank you for replay. I changed quota but error is still same. Only courierpop3dsizelist has right permissions. I have no idea where is problem. I installed everything as usually except renew from zips.
I found that problem is on whole server even on new created account .. could it be some misconfiguration during setup?

edit: courierpop3dsizelist has 10027 gid again.

SupuS
Reply With Quote
  #4  
Old 10th October 2008, 14:11
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Please check if the UIDs and GIDs in /etc/passwd and /etc/group look ok.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 13th October 2008, 00:23
SupuS SupuS is offline
HowtoForge Supporter
 
Join Date: May 2006
Posts: 202
Thanks: 68
Thanked 14 Times in 12 Posts
Default

Quote:
Originally Posted by falko View Post
Please check if the UIDs and GIDs in /etc/passwd and /etc/group look ok.
Hi falko

These files looks ok .. I cannot find any strange differences between this ispconfig server and files on the other servers

Right gid number for tested user is 10017 .. gid 10027 is not presented in group file

Last edited by SupuS; 13th October 2008 at 00:28.
Reply With Quote
  #6  
Old 13th October 2008, 12:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Do you have a web27 in your ISPConfig database somewhere?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig install issues... flyingaggie Installation/Configuration 2 18th July 2008 10:46
add web site serr57 Installation/Configuration 18 13th April 2008 11:40
directories in /home/admispconfig/ispconfig renamed? Spudchat General 10 12th April 2007 19:37
Systemimager (rsync) doesn't copy all comedit HOWTO-Related Questions 11 19th January 2007 17:17
setup fails on debian 3.1 dtrumbower Installation/Configuration 7 7th March 2006 13:42


All times are GMT +2. The time now is 20:45.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.