Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 26th September 2008, 09:26
justsayclint justsayclint is offline
Junior Member
 
Join Date: Sep 2008
Location: Brisvegas, Australia
Posts: 7
Thanks: 1
Thanked 0 Times in 0 Posts
Default Samba error while following "running-a-file-and-print-server-with-ebox"

Hi everyone,

Firstly a big thanks to all who keep this site alive, I am very new to linux and this site has been a god send.

I was able to follow the The Perfect Server - Ubuntu Hardy Heron (Ubuntu 8.04 LTS Server) instructions to chapter 10 as directed.

Then I got through chapter 1 - 3 in Running A File And Print-Server With eBox On Ubuntu 8.04 Server, but started running into problems in chapter 4.

I selected the modules required. When selecting "file sharing" the pop-up displayed and when I pressed "accept" nothing happened for about 10 minutes, as the others had been closing in a matter of seconds I assumed something was wrong and pressed the "X" to close the pop-up. When it closed a tick was there for "file sharing" so I proceeded.

When I pressed "Save Changes" it went throught the modules and then displayed the error:

Quote:
Some modules reported error when saving changes . More information on the logs in /var/log/ebox/
Now I cannot add a group as the following error is displayed and trying to add a group does not save.

Quote:
An internal error has ocurred. This is most probably a bug, relevant information can be found in the logs.
the line in ebox.log in /var/log/ebox/ which seems to be the error generated when the above is displayed.

Quote:
2008/09/26 16:57:58 ERROR> Global.pm:401 EBox::Global::saveAllModules - The following modules failed while saving their changes, their state is unknown: samba
And this error is generated when the I try to add groups:

Quote:
2008/09/26 17:18:45 ERROR> Ldap.pm:126 EBox::Ldap::ldapCon - Can't create ldapi connection
I have tried installing samba manually but it didn't seem to make any difference. I tried removing and re-installing ebox too but also that did not help.

Thanks in advance for help you may be able to lend.

Clinton
Reply With Quote
Sponsored Links
  #2  
Old 27th September 2008, 13:16
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Are there any errors in the other logs?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 28th September 2008, 00:32
justsayclint justsayclint is offline
Junior Member
 
Join Date: Sep 2008
Location: Brisvegas, Australia
Posts: 7
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Hi,

The error.log had hundreds of line and I wasn't sure which related, so I went into ebox and deselected all the modules again and got the same error message in the ebox.log as above and the following appeared in the error.log: (Sorry to include everything I'm not sure what is relevant and what is not)

Quote:
[Sun Sep 28 08:23:06 2008] [error] [client 192.168.0.107] File does not exist: /usr/share/ebox/www/favicon.ico, referer: https://192.168.0.100/
Subroutine EBox::Loggerd::O_APPEND redefined at /usr/share/perl/5.8/Exporter.pm line 65.
at /usr/lib/perl/5.8/POSIX.pm line 19
Subroutine EBox::Loggerd::O_CREAT redefined at /usr/share/perl/5.8/Exporter.pm line 65.
at /usr/lib/perl/5.8/POSIX.pm line 19
Subroutine EBox::Loggerd::O_EXCL redefined at /usr/share/perl/5.8/Exporter.pm line 65.
at /usr/lib/perl/5.8/POSIX.pm line 19
Subroutine EBox::Loggerd::O_RDWR redefined at /usr/share/perl/5.8/Exporter.pm line 65.
at /usr/lib/perl/5.8/POSIX.pm line 19
Subroutine EBox::Loggerd::O_APPEND redefined at /usr/share/perl/5.8/Exporter.pm line 65.
at /usr/lib/perl/5.8/POSIX.pm line 19
Subroutine EBox::Loggerd::O_CREAT redefined at /usr/share/perl/5.8/Exporter.pm line 65.
at /usr/lib/perl/5.8/POSIX.pm line 19
Subroutine EBox::Loggerd::O_EXCL redefined at /usr/share/perl/5.8/Exporter.pm line 65.
at /usr/lib/perl/5.8/POSIX.pm line 19
Subroutine EBox::Loggerd::O_RDWR redefined at /usr/share/perl/5.8/Exporter.pm line 65.
at /usr/lib/perl/5.8/POSIX.pm line 19
Subroutine EBox::Loggerd::O_RDWR redefined at /usr/share/perl/5.8/Exporter.pm line 65.
at /usr/lib/perl/5.8/POSIX.pm line 19
SIOCGMIIPHY on 'eth0' failed: Operation not supported
no MII interfaces found
Use of uninitialized value in concatenation (.) or string at /usr/share/perl5/HTML/Mason/Tools.pm line 114.
[Sun Sep 28 08:23:38 2008] [error] [client 192.168.0.107] File does not exist: /usr/share/ebox/www/images/thead-b.png, referer: https://192.168.0.100/ebox/ServiceModule/StatusView
Use of uninitialized value in substitution (s///) at /usr/share/perl5/EBox/CGI/ClientBase.pm line 40.
Use of uninitialized value in concatenation (.) or string at /usr/share/perl5/EBox/CGI/ClientBase.pm line 44.
Subroutine EBox::Loggerd::O_APPEND redefined at /usr/share/perl/5.8/Exporter.pm line 65.
at /usr/lib/perl/5.8/POSIX.pm line 19
Subroutine EBox::Loggerd::O_CREAT redefined at /usr/share/perl/5.8/Exporter.pm line 65.
at /usr/lib/perl/5.8/POSIX.pm line 19
Subroutine EBox::Loggerd::O_EXCL redefined at /usr/share/perl/5.8/Exporter.pm line 65.
at /usr/lib/perl/5.8/POSIX.pm line 19
Subroutine EBox::Loggerd::O_RDWR redefined at /usr/share/perl/5.8/Exporter.pm line 65.
at /usr/lib/perl/5.8/POSIX.pm line 19
Use of uninitialized value in concatenation (.) or string at /usr/share/perl5/HTML/Mason/Tools.pm line 114.
[Sun Sep 28 08:23:49 2008] [error] [client 192.168.0.107] File does not exist: /usr/share/ebox/www/images/thead-b.png, referer: https://192.168.0.100/ebox/ServiceModule/StatusView
Subroutine EBox::Loggerd::O_APPEND redefined at /usr/share/perl/5.8/Exporter.pm line 65, <DATA> line 228.
[Sun Sep 28 08:23:49 2008] [error] [client 192.168.0.107] File does not exist: /usr/share/ebox/www/images/thead-b.png, referer: https://192.168.0.100/ebox/ServiceModule/StatusView
Subroutine EBox::Loggerd::O_APPEND redefined at /usr/share/perl/5.8/Exporter.pm line 65, <DATA> line 228.
at /usr/lib/perl/5.8/POSIX.pm line 19
Subroutine EBox::Loggerd::O_CREAT redefined at /usr/share/perl/5.8/Exporter.pm line 65, <DATA> line 228.
at /usr/lib/perl/5.8/POSIX.pm line 19
Subroutine EBox::Loggerd::O_EXCL redefined at /usr/share/perl/5.8/Exporter.pm line 65, <DATA> line 228.
at /usr/lib/perl/5.8/POSIX.pm line 19
Subroutine EBox::Loggerd::O_RDWR redefined at /usr/share/perl/5.8/Exporter.pm line 65, <DATA> line 228.
at /usr/lib/perl/5.8/POSIX.pm line 19
Subroutine EBox::Loggerd::O_APPEND redefined at /usr/share/perl/5.8/Exporter.pm line 65, <DATA> line 228.
at /usr/lib/perl/5.8/POSIX.pm line 19
Subroutine EBox::Loggerd::O_CREAT redefined at /usr/share/perl/5.8/Exporter.pm line 65, <DATA> line 228.
at /usr/lib/perl/5.8/POSIX.pm line 19
Subroutine EBox::Loggerd::O_EXCL redefined at /usr/share/perl/5.8/Exporter.pm line 65, <DATA> line 228.
at /usr/lib/perl/5.8/POSIX.pm line 19
Subroutine EBox::Loggerd::O_RDWR redefined at /usr/share/perl/5.8/Exporter.pm line 65, <DATA> line 228.
at /usr/lib/perl/5.8/POSIX.pm line 19
Use of uninitialized value in substitution (s///) at /usr/share/perl5/EBox/CGI/ClientBase.pm line 40.
Use of uninitialized value in concatenation (.) or string at /usr/share/perl5/EBox/CGI/ClientBase.pm line 44.
Use of uninitialized value in substitution (s///) at /usr/share/perl5/EBox/CGI/ClientBase.pm line 40.
Use of uninitialized value in concatenation (.) or string at /usr/share/perl5/EBox/CGI/ClientBase.pm line 44.
Use of uninitialized value in substitution (s///) at /usr/share/perl5/EBox/CGI/ClientBase.pm line 40.
Use of uninitialized value in concatenation (.) or string at /usr/share/perl5/EBox/CGI/ClientBase.pm line 44.
Use of uninitialized value in substitution (s///) at /usr/share/perl5/EBox/CGI/ClientBase.pm line 40.
Use of uninitialized value in concatenation (.) or string at /usr/share/perl5/EBox/CGI/ClientBase.pm line 44.
Reply With Quote
  #4  
Old 29th September 2008, 17:17
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Maybe eBox wasn't fully installed. Do you have enough disk space? What's the output of
Code:
df -h
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
justsayclint (30th September 2008)
  #5  
Old 30th September 2008, 09:57
justsayclint justsayclint is offline
Junior Member
 
Join Date: Sep 2008
Location: Brisvegas, Australia
Posts: 7
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Thanks for taking an interest in this....

There should be heaps of space, its a new 230gb hdd. the whole ubuntu is fresh install on a new hdd.

i followed the steps in the "Perfect Server" walkthrough which used the default partitioning.

Quote:
Filesystem Size Used Avail Use% Mounted on
/dev/sda1 230G 1.2G 217G 1% /
varrun 252M 256K 252M 1% /var/run
varlock 252M 0 252M 0% /var/lock
udev 252M 44K 252M 1% /dev
devshm 252M 0 252M 0% /dev/shm
Reply With Quote
  #6  
Old 1st October 2008, 13:10
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Did you disable AppArmor?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Tags
ebox, error, installation, samba

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
freebsd 7, samba 3, domain controller alexdimarco Suggest HOWTO 6 5th November 2010 16:54
cupsaddsmb fails -- unable to share print drivers from samba sgla1 Server Operation 5 16th July 2008 21:28
Problem installing ISPconfig on Ubuntu 6.06 LTS ennodj Installation/Configuration 6 4th May 2008 18:12
Ubuntu Desktop and Sharing printers with XP SawtheLight Desktop Operation 24 19th January 2007 08:34
Samba server on RHES 4 beren Server Operation 0 8th May 2006 09:45


All times are GMT +2. The time now is 21:27.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.