Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd September 2008, 09:43
blesbok blesbok is offline
Junior Member
 
Join Date: Mar 2008
Posts: 11
Thanks: 3
Thanked 3 Times in 2 Posts
Question drupal, phpmyadmin and localhost: drupal installation

had phpmyadmin installed on my fedora8 box in /var/www/html. (lamp and ispconfig are set up too) when installing drupal, i was prompted about overwriting phpmyadmin files in this directory (files had identical names), i knew proceeding would mess things up.

consequently, i moved the contents of folder html to another in the same directory, html3. although impractical, either drupal or phpmyadmin can be run by editing DocumentRoot in apache: (in /etc/httpd/conf/httpd.conf)

DocumentRoot "/var/www/html3" and changing this line.

drupal is not yet fully installed as the step of creating the database is fraught with problems. what should the hostname be? (no remote hosting is intended) have had no success doing this from the command line and phpmyadmin is even less usable. on command line it goes like this:

[root@billsrange ~]# mysqladmin -u admin -p create db_d
Enter password:
mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'admin'@'localhost' (using password: YES)'

something similar happens on the drupal installation after giving database details of a database which looked alright (i'd seen it in phpmyadmin with 43 tables) http://localhost/install.php?profile=default&locale=en, the database configuration screen gives this result:

Failed to connect to your MySQL database server. MySQL reports the following message: Access denied for user 'admin'@'localhost' (using password: YES).

please chuckle or laugh at this newby (i'll bear with some sneering too) and then tell me how to have htpd accept both drupal and phpmyadmin's existence and how i can continue with my drupal installation.
Reply With Quote
Sponsored Links
  #2  
Old 23rd September 2008, 20:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Please try root instead of admin as the MySQL username.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
blesbok (7th October 2008)
  #3  
Old 26th September 2008, 19:33
blesbok blesbok is offline
Junior Member
 
Join Date: Mar 2008
Posts: 11
Thanks: 3
Thanked 3 Times in 2 Posts
Thumbs up thanks, but sorry, i'll need more time

thanks Falko

regretably, i've been away from internet access for a couple of days and am just passing through now.

please bear with me; i've tried the root username and the zero response from konsole means it's okay . on Mon 6 October i'll post to say how the installation proceeded.
Reply With Quote
  #4  
Old 6th October 2008, 14:06
blesbok blesbok is offline
Junior Member
 
Join Date: Mar 2008
Posts: 11
Thanks: 3
Thanked 3 Times in 2 Posts
Question

unfortunately, this drupal installation remains elusive.

after entering the database details on drupal's install wizard (for want of a better name), it crashed. am still able to run the install by posting http://localhost/install.php in a browser and that takes me to the first page where i select the install drupal in english option. on the next screen, with url
http://localhost/install.php?profile=default&locale=en,
firefox presents a blank screen with done underneath. konqueror will give this error (same as mentioned in the crash):

An error occurred while loading http://localhost/install.php?profile=default&locale=en:
Internal error in server
localhost

("page loaded." was displayed below, only to disappear again)

in the apache error log, i get the following:

[error] [client ::1] PHP Fatal error: Call to undefined function _user_password_dynamic_validation() in /var/www/html/install.ph
p on line 727, referer: http://localhost/install.php?profile=default

is this environment of mine perhaps a little drupal unfriendly or have i stumbled on a bug? perhaps the real bug's the one with ten fingers rattling the keyboard... sorry to 'bug' you again, but any help will be much appreciated
Reply With Quote
  #5  
Old 6th October 2008, 16:53
marpada marpada is offline
Senior Member
 
Join Date: Sep 2008
Posts: 139
Thanks: 2
Thanked 14 Times in 14 Posts
Default

Google the error (_user_password_dynamic_validatio), there some some threads about this problems in drupal site.
________
Essential Vaaapp
________
C25XE

Last edited by marpada; 13th May 2011 at 01:46.
Reply With Quote
The Following User Says Thank You to marpada For This Useful Post:
blesbok (7th October 2008)
  #6  
Old 7th October 2008, 09:11
blesbok blesbok is offline
Junior Member
 
Join Date: Mar 2008
Posts: 11
Thanks: 3
Thanked 3 Times in 2 Posts
Smile jawohl, i do smell a(nother) bug!

thanks m (sorry, can't see your name now)

had thought of googling as you suggested. now to tell the others what i found...

this thread http://drupal.org/node/203187#comment-701024 with 56 posts shed some light. post 52 said do this:

mysql -u root -p
i added: USE db_d
then (as given): mysql> UPDATE system SET status=1 WHERE name='block' OR name='user' OR name='node' OR name='filter';

RESULT: PROGRESS!!

am now on the Configure site dialogue
Reply With Quote
Reply

Bookmarks

Tags
drupal and mysql, drupal and phpmyadmin, drupal apache, drupal documentroot, installing drupal

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Perfect 10.1 SuSE setup - postfix lt_wentoncha HOWTO-Related Questions 4 2nd July 2006 17:46


All times are GMT +2. The time now is 02:53.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.