Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 19th September 2008, 16:33
dezigner dezigner is offline
Junior Member
 
Join Date: Sep 2008
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation RoundCube login and username problems with multiple domains

Hi,
I'm quite new with RCube and I realy need your help!

I'm running my own dedicated server with CentosOS 4.6 system. For administration things i'm using Webmin 1.400, plus i'v got nearlly 30 domains runing on my webserver. The thing is, that i installed RCube on my webserver and I want to use it instead of squiremail.

Problem Nr.1 50% Solved
When I creating a user for some domain with Webmin it creates like this: user.domain and to login to RCube to check email I must enter exactly same username, like system created for me. I tried to to chane main.inc.php and entered value: $rcmail_config['virtuser_file'] = '/etc/postfix/virtusertable'; but still I need to login by user.domain.
How can I do to login like user@domain.com ?

1/2 - I have changed $rcmail_config['virtuser_file'] = '/etc/postfix/virtusertable';to $rcmail_config['virtuser_file'] = '/etc/mail/virtusertable'; - now I can login normaly user@domain.com

2/2 - How to disable logging as : user.domain ?

Problem Nr.2
In main.inc.php file as default host i put 'localhost', and thats looked to be allright, but when I checked settings and look at identities i saw this:
Name: user.domain
Email: user.domain@localhost

And of course if i woun't change my email setings to normal, then person who receives my email my addres will see like this: user.domain@myservername.com

How to make automaticly set settings this way:
Name: user
Email: user@domain.com
that receiver will see normal user addres: user@domain.com

Thanks in advance for your help

Last edited by dezigner; 19th September 2008 at 17:21.
Reply With Quote
Sponsored Links
  #2  
Old 20th September 2008, 14:15
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

I don't know Roundcube, but I think you must set the correct sender address in the account settings of that email account.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 20th September 2008, 17:45
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,263
Thanks: 216
Thanked 649 Times in 295 Posts
Default

Falko is right about that.

To login with user@domain.tld, you need to change:

$rcmail_config['smtp_user'] = '%u';
into
$rcmail_config['smtp_user'] = '';

within main.inc.php.
__________________
Hans

MrHostman | Managed Hosting
Reply With Quote
  #4  
Old 21st September 2008, 20:58
dezigner dezigner is offline
Junior Member
 
Join Date: Sep 2008
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have canged %u to '' but i still can login with user.domain .. how to disable that?
Reply With Quote
  #5  
Old 21st September 2008, 23:29
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,263
Thanks: 216
Thanked 649 Times in 295 Posts
Default

Not sure, but I think because your previous successfull login with user.domain was stored into the RoundCube database.
__________________
Hans

MrHostman | Managed Hosting
Reply With Quote
  #6  
Old 22nd September 2008, 07:56
dezigner dezigner is offline
Junior Member
 
Join Date: Sep 2008
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Problem Nr.2
In main.inc.php file as default host i put 'localhost', and thats looked to be allright, but when I checked settings and look at identities i saw this:
Name: user.domain
Email: user.domain@localhost
And of course if i woun't change my email setings to normal, then person who receives my email my addres will see like this: user.domain@myservername.com

How to make automaticly set settings this way:
Name: user
Email: user@domain.com that receiver will see normal user addres: user@domain.com

what about this part?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
thunderbird imap login username bassplayer General 1 19th August 2008 15:07
can't login to the webmail (RoundCube or SquirrelMail) martial Installation/Configuration 1 10th April 2008 18:57
Roundcube login bswinnerton Installation/Configuration 1 28th January 2008 03:53
Squirrelmail login issue (ISPConfig, dovecot, full username) ./w Installation/Configuration 5 19th May 2007 12:00
admin login problems. robd Installation/Configuration 15 1st August 2006 13:39


All times are GMT +2. The time now is 04:38.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.