Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 24th July 2008, 18:46
hairydog2 hairydog2 is offline
Senior Member
 
Join Date: Oct 2005
Posts: 196
Thanks: 9
Thanked 2 Times in 2 Posts
Exclamation over quota .htpasswd problem

I tried to add a new user to an access-restricted directory today.

I hadn't noticed that this account had gone over quota.

Adding the user failed with an error message that didn't explain what the problem was, but that's not a big deal.

What was more of a problem was that it replaced the .htpasswd file with one of 0 bytes, immediately locking all the current users out.

It would be good to have some checking built in to stop this happening!
Reply With Quote
Sponsored Links
  #2  
Old 24th July 2008, 18:48
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,579
Thanks: 792
Thanked 4,980 Times in 3,901 Posts
Default

Thanks for reporting this. I added it to the bugtracker.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 18th August 2008, 15:43
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by hairydog2 View Post
I tried to add a new user to an access-restricted directory today.

I hadn't noticed that this account had gone over quota.

Adding the user failed with an error message that didn't explain what the problem was, but that's not a big deal.

What was more of a problem was that it replaced the .htpasswd file with one of 0 bytes, immediately locking all the current users out.

It would be good to have some checking built in to stop this happening!
Where exactly did you have this problem? Under Web-FTP, when you try to password-protect a directory?

I've just tried that and couldn't reproduce it.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 21st September 2008, 18:13
hairydog2 hairydog2 is offline
Senior Member
 
Join Date: Oct 2005
Posts: 196
Thanks: 9
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by falko View Post
Where exactly did you have this problem? Under Web-FTP, when you try to password-protect a directory?

I've just tried that and couldn't reproduce it.
Yes, that was what I did.

However, there seem to be other quota problems. I'd really like to rebuild the quota files, but I'm not sure how to do it.

quotaoff -av
quotacheck -augvm
quotaon -a

don't sort it out for me. I get this:

# quotaon -a
quotaon: using //quota.group on /dev/md/0 [/]: No such process
quotaon: Quota format not supported in kernel.
quotaon: using //quota.user on /dev/md/0 [/]: No such process
quotaon: Quota format not supported in kernel.


Any ideas?
Reply With Quote
  #5  
Old 22nd September 2008, 13:15
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Are the quota modules loaded? Please try
Code:
modprobe quota_v1
modprobe quota_v2
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 22nd September 2008, 20:16
hairydog2 hairydog2 is offline
Senior Member
 
Join Date: Oct 2005
Posts: 196
Thanks: 9
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by falko View Post
Are the quota modules loaded? Please try
Code:
modprobe quota_v1
modprobe quota_v2
Seems not:

FATAL: Could not load /lib/modules/2.6.26-bytemark-x86/modules.dep: No such file or directory

So what should I do to fix it?

Last edited by hairydog2; 22nd September 2008 at 20:53. Reason: added a question
Reply With Quote
  #7  
Old 23rd September 2008, 21:28
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

What are the outputs of
Code:
ls -la /lib/modules/2.6.26-bytemark-x86/
and
Code:
uname -a
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
empty maildir /tmp after quota problem clamav Jorem General 5 20th June 2008 13:24
Virtual users... Ubuntu 8.04 spaceuser HOWTO-Related Questions 12 19th June 2008 08:04
Maildir Quota Problem grafzahl Installation/Configuration 2 7th March 2008 17:07
postfix + dovecot + postfixadmin - problem with quota kosta Server Operation 3 24th August 2007 22:08
Quota Problem with Procmail rafaelenrike Installation/Configuration 1 16th June 2006 02:32


All times are GMT +2. The time now is 12:30.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.