Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 11th July 2008, 17:50
fouad fouad is offline
Junior Member
 
Join Date: Jul 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Opensuse 11.0 cc1: error: unrecognized ...

Opensuse 11.0
Linux mail 2.6.25.9-0.2-pae #1 SMP 2008-06-28 00:00:07 +0200 i686 athlon i386 GNU/Linux

Followed this howto exactly : http://www.howtoforge.com/perfect-server-opensuse11-p1 to 6
All the package installation went fine until arrived at the Ispconfig setup where i get the following error:

-------------------------------
Configured for linux-elf.
making all in crypto...
make[1]: Entering directory `/root/install_ispconfig/compile_aps/openssl-0.9.7m/crypto'
( echo "#ifndef MK1MF_BUILD"; \
echo ' /* auto-generated by crypto/Makefile for crypto/cversion.c */'; \
echo ' #define CFLAGS "gcc -DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -DOPENSSL_NO_KRB5 -DL_ENDIAN -DTERMIO-O3 -fomit-frame-pointer -m486 -Wall -DSHA1_ASM -DMD5_ASM -DRMD160_ASM"'; \
echo ' #define PLATFORM "linux-elf"'; \
echo " #define DATE \"`LC_ALL=C LC_TIME=C date`\""; \
echo '#endif' ) >buildinf.h
gcc -I. -I.. -I../include -DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -DOPENSSL_NO_KRB5 -DL_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -m486 -Wall -DSHA1_ASM -DMD5_ASM -DRMD160_ASM -c -o cryptlib.o cryptlib.c
cc1: error: unrecognized command line option "-m486"
make[1]: *** [cryptlib.o] Error 1
make[1]: Leaving directory `/root/install_ispconfig/compile_aps/openssl-0.9.7m/crypto'
make: *** [sub_all] Error 1
ERROR: Could not make OpenSSL

---------------

All new distro's use gcc4.3 and not 4.2. I gues that's where Ispconfig produces this error.
allso the deprecated ? option "-m486" is still used ??

Please how to solve this problem or work-around to install ISPconfig on Opensuse 11.0 ?


thnx.
Reply With Quote
Sponsored Links
  #2  
Old 11th July 2008, 19:18
fouad fouad is offline
Junior Member
 
Join Date: Jul 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default OPensuse 11.0 cc1 error ... Solved

Ok, i unpacked ISPconfig again and went into install_ispconfig/compile_aps/
unpacked openssl-0.9.7m.tar.gz, made some changes in Makefile and Configure
where I replaced -m486 with -mtune=i486

run setup and all went fine ;-)
Reply With Quote
  #3  
Old 28th July 2008, 10:32
Zaphod Zaphod is offline
Junior Member
 
Join Date: Jul 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default please explain in detail

Hello fouad,
I have the same problem, trying to install ISP on a vmware.
Can you please explain in detail, which changes you made in the Makefile and with which options you started the ./configure command.

Thanx
Reply With Quote
  #4  
Old 28th July 2008, 15:46
saxynet saxynet is offline
Junior Member
 
Join Date: Jul 2008
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

zaphod... in both files configure and makefile replace all the "-m486" with "-mtune=i486". you have to do it just in package openssl-0.9.7m.tar.gz!

it works for me 2.
Reply With Quote
  #5  
Old 28th July 2008, 16:08
Zaphod Zaphod is offline
Junior Member
 
Join Date: Jul 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default didn´t work

Hi saxynet,

thanx for help, but unfortunately I get the error now from gcc:
gcc -I. -I.. -I../include -DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -DOPENSSL_NO_KRB5 -DL_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -m486 -Wall -DSHA1_ASM -DMD5_ASM -DRMD160_ASM -c -o cryptlib.o cryptlib.c
cc1: error: unrecognized command line option "-m486"
=> seems the call is still -m486

I could only change the Configure-File, because the only -m486-entry in the Makefile was # off topic

But thank you anyway
Reply With Quote
  #6  
Old 23rd August 2008, 13:08
batkuip batkuip is offline
Junior Member
 
Join Date: Aug 2008
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks it did the trick...

Had replaced -m486 for -mtune=i486 (in the Makefile and Configure files) and repacked the openssl dir.

Code:
tar -pczf openssl-0.9.7m.tar.gz openssl-0.9.7m
Thanks!

Last edited by batkuip; 23rd August 2008 at 13:29.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenSuse 11 support p.a Feature Requests 3 9th July 2008 08:28
broadband problem in opensuse 10.3 ab25 HOWTO-Related Questions 1 18th March 2008 15:39
VMware with opensuse can't windows files rwar Installation/Configuration 3 26th January 2008 19:11
Question Regarding: Installing Lighttpd With PHP5 And MySQL Support On OpenSUSE 10.3 Gokou023 HOWTO-Related Questions 3 12th December 2007 16:06
ffmpeg install issue on OpenSuse t471039 Server Operation 3 1st October 2007 10:51


All times are GMT +2. The time now is 21:40.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.