Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 26th June 2008, 17:00
peter7 peter7 is offline
Junior Member
 
Join Date: Jun 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default HOWTO: Unlock A LUKS Encrypted Root Partition Via SSH On Ubuntu

I am trying to apply the Howto indicated in the title to a fully encrypted (by alternative
install) Kubuntu 8.04. I can login over ssh after the boot but the
"unlock" command is just hanging there with the message:

Code:
Setting up cryptographic volume sda2_crypt (based on /dev/disk/by-uuid/...
It never prompts for the pass phrase or does anything.

I was wondering if anybody has some idea how to proceed. I tried to do
manually what unlock does with the same result.
Reply With Quote
Sponsored Links
  #2  
Old 26th June 2008, 20:22
sjau sjau is offline
Local Meanie
 
Join Date: Apr 2006
Location: Switzerland
Posts: 1,146
Thanks: 4
Thanked 55 Times in 51 Posts
Default

you do have a fully encrypted system?
__________________
"Common sense is not as common as commonly believed" by sjau

Auto-Install Script for ISPConfig and Horde on a Vanilla Debian Stable

Need more Repos for Ubuntu? Repository Generator
Need more Repos for Debian? Debian Repository Generator
Reply With Quote
  #3  
Old 26th June 2008, 23:02
peter7 peter7 is offline
Junior Member
 
Join Date: Jun 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes I do, except the /boot partition of course.
Reply With Quote
  #4  
Old 27th June 2008, 08:30
sjau sjau is offline
Local Meanie
 
Join Date: Apr 2006
Location: Switzerland
Posts: 1,146
Thanks: 4
Thanked 55 Times in 51 Posts
Default

Post your /etc/initramfs-tools/scripts/local-top/cryptroot script
__________________
"Common sense is not as common as commonly believed" by sjau

Auto-Install Script for ISPConfig and Horde on a Vanilla Debian Stable

Need more Repos for Ubuntu? Repository Generator
Need more Repos for Debian? Debian Repository Generator
Reply With Quote
  #5  
Old 27th June 2008, 17:56
peter7 peter7 is offline
Junior Member
 
Join Date: Jun 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by sjau View Post
Post your /etc/initramfs-tools/scripts/local-top/cryptroot script
This directory is empty.

If you mean the file /scripts/local-top/cryptroot in the netboot initrd image then it is the same as what is in the original initrd. Which in turn comes from /usr/share/initramfs-tools/scripts/local-top/cryptroot unmodified. These files are part of the cryptsetup package and are the same over all ubuntu based distros. My cryptsetup is version 2:1.0.5-2ubuntu12

What I noticed that the prompt asking for the pass phrase showed up on the console instead of in my ssh session but took no input.
Reply With Quote
  #6  
Old 27th June 2008, 20:17
sjau sjau is offline
Local Meanie
 
Join Date: Apr 2006
Location: Switzerland
Posts: 1,146
Thanks: 4
Thanked 55 Times in 51 Posts
Default

are you using LVM?
__________________
"Common sense is not as common as commonly believed" by sjau

Auto-Install Script for ISPConfig and Horde on a Vanilla Debian Stable

Need more Repos for Ubuntu? Repository Generator
Need more Repos for Debian? Debian Repository Generator
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix email server problems Access denied 554 554 5.7.1 state 14 AceRimmer Server Operation 4 19th June 2008 14:36
i am having some problem ? cobro Installation/Configuration 20 30th April 2008 16:26
Apache domain to directory? badgerbox76 Server Operation 27 29th January 2008 20:07
Add Webmin to the system sushestvo Installation/Configuration 44 21st August 2007 16:52
cannot connect to ispconfig guidovanh Installation/Configuration 22 3rd March 2006 19:52


All times are GMT +2. The time now is 23:41.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.