Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Closed Thread
 
Thread Tools Display Modes
  #1  
Old 7th June 2008, 18:51
jcdole jcdole is offline
Junior Member
 
Join Date: Aug 2007
Location: Pyrennee Atlantique (64) FRANCE
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Default SMBLDAP-TOOLS SAMBA LDAP . Problem when filling ldap.

Hello,

I am trying to modify smbldap-populate for filling people user in the people ou field, and computers in the computer ou field.

I want this organization :

people user in : "ou=people,ou=user,dc=ldap_srv,dc=net"
computer user in : "ou=computers,ou=user,dc=ldap_srv,dc=net"


Which relationships (IF ANY IS MANDATORY) is there between LDAP definitions in smb.conf

ldap suffix = dc=ldap_srv,dc=net
ldap machine suffix = ou=??????????????????????
ldap user suffix = ou=???????????????????????
ldap group suffix = ou=Groups
ldap domain suffix = ou=Domains


and LDAP definitions in smbldap.conf


# LDAP Suffix
suffix="dc=ldap_srv,dc=net"

# Domain name the Samba server is in charged.
sambaDomain="MON-DOMAINE.NWK"

# Where are stored peoples and computers
usersdn="ou=Users,${suffix}"

# Where are stored groups
groupsdn="ou=Groups,${suffix}"

# Where are stored domains
domainsdn="ou=Domains,${suffix}"

# Where are stored peoples
peoplesdn="ou=Peoples, ou=Users,${suffix}"

# Where are stored computers
computersdn="ou=Computers, ou=Users,${suffix}"

# Where to store next uidNumber and gidNumber available for new users and groups
# If not defined, entries are stored in sambaDomainName object.
sambaUnixIdPooldn="sambaDomainName=MON-DOMAINE.NET,ou=Domains,${suffix}"


When I start smbldap-populate, I get the following errors :

Use of uninitialized value in pattern match (m//) at /usr/local/sbin/smbldap-populate line 179.
Use of uninitialized value in concatenation (.) or string at /usr/local/sbin/smbldap-populate line 180.
Use of uninitialized value in concatenation (.) or string at /usr/local/sbin/smbldap-populate line 190
Use of uninitialized value in concatenation (.) or string at


Lignes 179, 180 et 190, ..... which are relatives to ou=computers et ou=peoples, ............

I have no errors about ou=users ( parent of computer and people ).
I have no errors about ou=Domains parent for sambaUnixIdPooldn.

The ldif file is generated, but there is some blank field about ou computer field and ou people field.

Thank you for any help.
Sponsored Links
  #2  
Old 27th June 2008, 01:45
sangamc sangamc is offline
Junior Member
 
Join Date: Jun 2008
Posts: 11
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by jcdole View Post
Hello,

I am trying to modify smbldap-populate for filling people user in the people ou field, and computers in the computer ou field.

I want this organization :

people user in : "ou=people,ou=user,dc=ldap_srv,dc=net"
computer user in : "ou=computers,ou=user,dc=ldap_srv,dc=net"
i dont think you can put a single object into multiple ou, if it is possible you should leave it alone until you get more comfortable with ldap. try instead

computers in: "ou=computers,dc=ldap-srv,dc=net"
users in: "ou=People,dc=ldap-srv,dc=net"

Quote:
Which relationships (IF ANY IS MANDATORY) is there between LDAP definitions in smb.conf

ldap suffix = dc=ldap_srv,dc=net
ldap machine suffix = ou=??????????????????????
ldap user suffix = ou=???????????????????????
ldap group suffix = ou=Groups
ldap domain suffix = ou=Domains
they are all required for your setup to work, use
ldap user suffix = ou=Users
ldap machine suffix = ou=Computers

Quote:
and LDAP definitions in smbldap.conf
# LDAP Suffix
suffix="dc=ldap_srv,dc=net"

...

Thank you for any help.
they are all required for the setup to work. if your smb.conf is setup correctly (execute # testparm to find out) you can use /usr/share/doc/smbldap-tools-0.9.4/configure.pl to configure you smbldap_bind and smbldap.conf for you automatically. just enter the password for you ldap server when the script asks you
  #3  
Old 15th July 2008, 23:38
jcdole jcdole is offline
Junior Member
 
Join Date: Aug 2007
Location: Pyrennee Atlantique (64) FRANCE
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Default

For now I can't do any test. I have change my PC and done a fresh install. But I ran into some other samba problem. See my today's post about port 139 wich is closed.
  #4  
Old 10th August 2008, 06:14
ryazkhan ryazkhan is offline
Junior Member
 
Join Date: Apr 2008
Location: US
Posts: 18
Thanks: 1
Thanked 0 Times in 0 Posts
Send a message via Skype™ to ryazkhan
Default

Quote:
Originally Posted by jcdole View Post
For now I can't do any test. I have change my PC and done a fresh install. But I ran into some other samba problem. See my today's post about port 139 wich is closed.
I would use phpldapadmin for this (add/remove) task. If you want to setup again follow this www.freetech.selfip.info/smbldap.php
__________________
-------------
Ryaz Khan
-------------
My Website
  #5  
Old 10th August 2008, 17:09
jcdole jcdole is offline
Junior Member
 
Join Date: Aug 2007
Location: Pyrennee Atlantique (64) FRANCE
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Default

As it seems too difficult to modify smbldap tools I did the job by hand.

Have generate the ldif file
smbldap-populate -e an_ldif_file
Have edit the ldif file to fill blank file accordingly with my ldap schema
before edit
dn: ou=Peoples,ou=Users,dc=ldap_hathor,dc=nwk
objectClass: top
objectClass: organizationalUnit
ou:
description: 5 - Container pour les Personnes
after edit
dn: ou=Peoples,ou=Users,dc=ldap_hathor,dc=nwk
objectClass: top
objectClass: organizationalUnit
ou: Peoples
description: 5 - Container pour les Personnes

and load the ldif file :

slapadd -b a_domain -v -l an_ldif_file

Thanks everybody for your time.

This thread should be closed
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba Ldap Problem ZenMatrix Server Operation 1 10th August 2008 07:02
Virtual users... Ubuntu 8.04 spaceuser HOWTO-Related Questions 12 19th June 2008 08:04
OpenLDAP + Samba Domain Controller On Ubuntu 7.10 E1sbaer HOWTO-Related Questions 3 7th May 2008 18:41
LDAP Problem pinguingilo Installation/Configuration 4 22nd December 2007 21:32
Samba Ldap PDC in Suse 10.0 budianto Server Operation 2 21st June 2007 06:50


All times are GMT +2. The time now is 16:51.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.