Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 14th May 2008, 17:37
vestport vestport is offline
Member
 
Join Date: Aug 2007
Posts: 45
Thanks: 1
Thanked 0 Times in 0 Posts
Cool ISPCONFIG Anti-Spam filter not causing problems for user account

Hello group,

I have an ISPCONFIG box running on CentOS 5.0. ISPCONFIG has been running like a top up until recently. The problem is that one of my user accounts is blocking all or most of my incoming email due to the spam filter or rather spamassasin. Under "Spam Filter and AntiVirus" for the user account I have:

Spam Filter: checked
Spam Hits: 5.0
ReWrite Subject: checked
Subject: ***SPAM***
Use URIBL: checked

These are the exact same settings as most of my other accounts however inbound email is being blocked all of a sudden just on one account. I have had several persons recently inform me that they cannot get mail through and are getting errors. The only way to allow mail is to "uncheck" Spam Filter which I have done so that I can communicate with the world on this account in question.

I downloaded and installed all of the latest CentOs updates and also upgraded to the latest ISPCONFIG from 2.2.18 to 2.2.23 in hopes that this would be resolved but no luck. What is going on here. Very Strange. Somehow the spam filter is getting way too strict for this user. I am not sure exactly how I should approach resolving this issue. It appears that a "lockfile" cannot be created for this user.

Here is the actual email (minus the real servernames) that got bounced back.

Message 1:
From MAILER-DAEMON@notmyserver.com Wed May 14 10:45:08 2008
Date: Wed, 14 May 2008 10:44:43 -0400 (EDT)
From: MAILER-DAEMON@ns1.myserver.com (Mail Delivery System)
Subject: Undelivered Mail Returned to Sender
To: art@notmyserver.com
Auto-Submitted: auto-replied
MIME-Version: 1.0
Content-Type: multipart/report; report-type=delivery-status;
boundary="3148F2451714.1210776283/ns1.myserver.com"

This is a MIME-encapsulated message.

--3148F2451714.1210776283/ns1.myserver.com
Content-Description: Notification
Content-Type: text/plain; charset=us-ascii

This is the mail system at host ns1.myserver.com.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to <postmaster>

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The mail system

<notmyserver.com.art@ns1.myserver.com> (expanded from <art@myserver.com>): can't
create user output file. Command output: ==================== QUOTA:
31457280000 INBOXSIZE: 51198963 MAXMSG: 2147483647 [3341] warn:
auto-whitelist: open of auto-whitelist file failed: locker: safe_lock:
cannot create tmp lockfile
/var/www/web4/.spamassassin/auto-whitelist.lock.ns1.myserver.com.3341 for
/var/www/web4/.spamassassin/auto-whitelist.lock: No such file or directory
procmail: Error while writing to "/var/mail/myserver.com.art"

--3148F2451714.1210776283/ns1.myserver.com
Content-Description: Delivery report
Content-Type: message/delivery-status

Reporting-MTA: dns; ns1.myserver.com
X-Postfix-Queue-ID: 3148F2451714
X-Postfix-Sender: rfc822; art@notmyserver.com
Arrival-Date: Wed, 14 May 2008 10:44:39 -0400 (EDT)

Final-Recipient: rfc822; myserver.com.art@ns1.myserver.com
Original-Recipient: rfc822;art@myserver.com
Action: failed
Status: 5.2.0
Diagnostic-Code: x-unix; ==================== QUOTA: 31457280000 INBOXSIZE:
51198963 MAXMSG: 2147483647 [3341] warn: auto-whitelist: open of
auto-whitelist file failed: locker: safe_lock: cannot create tmp lockfile
/var/www/web4/.spamassassin/auto-whitelist.lock.ns1.myserver.com.3341 for
/var/www/web4/.spamassassin/auto-whitelist.lock: No such file or directory
procmail: Error while writing to "/var/mail/myserver.com.art"

--3148F2451714.1210776283/ns1.myserver.com
Content-Description: Undelivered Message
Content-Type: message/rfc822

Received: from notmyserver.com (notmyserver.com [999.999.999.999])
(using TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits))
(No client certificate requested)
by ns1.myserver.com (Postfix) with ESMTP id 3148F2451714;
Wed, 14 May 2008 10:44:39 -0400 (EDT)
Received: from notmyserver.com (notmyserver.com [127.0.0.1])
by notmyserver.com (8.12.8/8.12.8) with ESMTP id m4EEi3J3023402;
Wed, 14 May 2008 10:44:23 -0400
Received: (from art@localhost)
by notmyserver.com (8.12.8/8.12.8/Submit) id m4EEhrxX023399;
Wed, 14 May 2008 10:43:53 -0400
Date: Wed, 14 May 2008 10:43:53 -0400
From: art@notmyserver.com
Message-Id: <200805141443.m4EEhrxX023399@notmyserver.com>
To: art@myserver.com
Cc: workinguser@myserver.com

retest with new ispconfig

--3148F2451714.1210776283/ns1.myserver.com--

*****************END*********************



myserver.com is the server in question that is not creating the lock file for this one user. It had been up until about a week ago then all of a sudden things stopped working. My other email accounts are configured exactly the same and have no problems with spam filter enabled for the user. Again, the only way I can get email inbound to my "art@myserver.com" right now is by unchecking or rather deactivating the spam filter.

Any help is welcome and thanks in advance for your reply.


Art
Reply With Quote
Sponsored Links
  #2  
Old 15th May 2008, 19:31
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Seems to be a quota issue. What's the output of
Code:
repquota -avug
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 15th May 2008, 19:49
vestport vestport is offline
Member
 
Join Date: Aug 2007
Posts: 45
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Hello falko,

Ther results of repquota -avug for the user in question is:

mydomain.com.art -- 1872424 20480000 20481024 39821 0 0


I just did not want to include the whole output because of spam potential for all of the other users and domains.


The rest of the output is as follows:

*** Report for user quotas on device /dev/mapper/VolGroup00-LogVol00
Block grace time: 7days; Inode grace time: 7days
Block limits File limits
User used soft hard grace used soft hard grace
----------------------------------------------------------------------
root -- 13744872 0 0 452796 0 0
daemon -- 20 0 0 3 0 0
lp -- 16 0 0 2 0 0
news -- 7332 0 0 183 0 0
uucp -- 1356 0 0 18 0 0
games -- 344 0 0 86 0 0
nobody -- 4 0 0 1 0 0
rpm -- 100756 0 0 123 0 0
smmsp -- 8 0 0 1 0 0
vcsa -- 8 0 0 1 0 0
rpcuser -- 36 0 0 5 0 0
pcap -- 308 0 0 13 0 0
apache -- 24092 0 0 1641 0 0
avahi -- 12 0 0 3 0 0
ntp -- 12 0 0 2 0 0
postgres -- 5516 0 0 281 0 0
mysql -- 76216 0 0 2786 0 0
webalizer -- 32 0 0 4 0 0
squid -- 16 0 0 2 0 0
hsqldb -- 16 0 0 2 0 0
named -- 140 0 0 28 0 0
xfs -- 0 0 0 1 0 0
postfix -- 236 0 0 73 0 0
ident -- 8 0 0 1 0 0
dovecot -- 8 0 0 1 0 0
radvd -- 8 0 0 1 0 0
tomcat -- 96 0 0 24 0 0
amanda -- 364 0 0 17 0 0
cyrus -- 16112 0 0 24 0 0
radiusd -- 72 0 0 18 0 0
quagga -- 36 0 0 5 0 0
ldap -- 716 0 0 12 0 0
exim -- 56 0 0 7 0 0
piranha -- 16 0 0 3 0 0
pvm -- 8 0 0 1 0 0
privoxy -- 792 0 0 43 0 0
luci -- 178992 0 0 20622 0 0
ricci -- 44 0 0 8 0 0
beaglidx -- 61124 0 0 24 0 0
nx -- 164 0 0 20 0 0
art -- 92704 0 0 1316 0 0
admispconfig -- 135996 0 0 4174 0 0
#10004 -- 8 0 0 2 0 0
#12011 -- 0 512000 513024 0 0 0

Statistics:
Total blocks: 17
Data blocks: 6
Entries: 102
Used average: 17.000000

*** Report for group quotas on device /dev/mapper/VolGroup00-LogVol00
Block grace time: 7days; Inode grace time: 7days
Block limits File limits
Group used soft hard grace used soft hard grace
----------------------------------------------------------------------
root -- 13500312 0 0 443327 0 0
daemon -- 36 0 0 5 0 0
sys -- 24 0 0 3 0 0
tty -- 24 0 0 2 0 0
disk -- 1664 0 0 79 0 0
lp -- 124 0 0 26 0 0
kmem -- 32 0 0 1 0 0
mail -- 232120 0 0 90 0 0
news -- 7600 0 0 186 0 0
uucp -- 1384 0 0 20 0 0
man -- 256 0 0 32 0 0
games -- 7376 0 0 640 0 0
lock -- 28 0 0 2 0 0
nobody -- 96 0 0 2 0 0
rpm -- 100756 0 0 123 0 0
utmp -- 50516 0 0 5 0 0
smmsp -- 844 0 0 9 0 0
utempter -- 324 0 0 2 0 0
rpcuser -- 36 0 0 5 0 0
gdm -- 8 0 0 1 0 0
pcap -- 308 0 0 13 0 0
slocate -- 28404 0 0 3 0 0
apache -- 24712 0 0 1686 0 0
avahi -- 12 0 0 3 0 0
ntp -- 12 0 0 2 0 0
postgres -- 5516 0 0 281 0 0
mysql -- 76220 0 0 2787 0 0
squid -- 216 0 0 7 0 0
hsqldb -- 16 0 0 2 0 0
named -- 8308 0 0 401 0 0
xfs -- 0 0 0 1 0 0
postdrop -- 368 0 0 4 0 0
postfix -- 132 0 0 60 0 0
ident -- 8 0 0 1 0 0
dovecot -- 32 0 0 5 0 0
radvd -- 8 0 0 1 0 0
tomcat -- 11784 0 0 994 0 0
mailman -- 53040 0 0 2743 0 0
radiusd -- 24 0 0 3 0 0
quaggavt -- 4 0 0 1 0 0
quagga -- 32 0 0 4 0 0
ldap -- 732 0 0 15 0 0
exim -- 56 0 0 7 0 0
piranha -- 4 0 0 1 0 0
pvm -- 8 0 0 1 0 0
privoxy -- 792 0 0 43 0 0
screen -- 356 0 0 2 0 0
pegasus -- 86232 0 0 5145 0 0
luci -- 178992 0 0 20622 0 0
ricci -- 344 0 0 9 0 0
beaglidx -- 61124 0 0 24 0 0
art -- 92700 0 0 1315 0 0
admispconfig -- 129972 0 0 3627 0 0
web4 -- 62177400 153600000 153601024 1254582 0 0
web8 -- 719408 204800000 204801024 5477 0 0
web10 -- 773788 204800000 204801024 39022 0 0
web11 -- 39476 2048000 2049024 2147 0 0
web12 -- 694304 204800000 204801024 34327 0 0
web13 -- 1149392 204800000 204801024 13705 0 0
web14 -- 376 0 0 47 0 0
ispconfigend -- 36 0 0 9 0 0
#10002 -- 8 0 0 2 0 0
#12011 -- 0 512000 513024 0 0 0

Statistics:
Total blocks: 15
Data blocks: 4
Entries: 63
Used average: 15.750000

Thanks!
Reply With Quote
  #4  
Old 16th May 2008, 15:25
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

What's the output of
Code:
ls -la /var/www/web4/.spamassassin
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 16th May 2008, 19:39
vestport vestport is offline
Member
 
Join Date: Aug 2007
Posts: 45
Thanks: 1
Thanked 0 Times in 0 Posts
Default

[root@ns1 ~]# ls -la /var/www/web4/.spamassassin
lrwxrwxrwx 1 root root 42 Dec 19 08:17 /var/www/web4/.spamassassin -> /var/www/web4/user/web4_art/.spamassassin/
[root@ns1 ~]#
Reply With Quote
  #6  
Old 17th May 2008, 03:16
vestport vestport is offline
Member
 
Join Date: Aug 2007
Posts: 45
Thanks: 1
Thanked 0 Times in 0 Posts
Default

I deleted as many useless emails in my mail box that I could just to free up some space and to see what happened. It appears that now I can receive emails even with anti-spam engaged. My quota did not appear to be exceeded previously so I figured I should try deleting old messaged. I am just worried that this problem is going to happen again soon and that something else is really causing the lockout of inbound email. This is my main account and it has caused lots of grief blocking so many clients, customers and friends.

Please let me know if you see anything else that may have caused the problem from the "ls -la /var/www/web4/.spamassassin" printout that you requested.


Thanks Falko!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Multiple ISPConfig & DNS Questions and Problems bfriend Installation/Configuration 3 6th January 2007 06:14
Ispconfig update problems from 2.4 to 2.6 adrenalinic Installation/Configuration 23 7th September 2006 12:58
ISPConfig + Perfect Setup Ubuntu 5.10 + Smtp SPAM problems lyndros Installation/Configuration 11 15th April 2006 17:07
Problems with domain and host name ispconfig 2.1.1 grantdutoit Installation/Configuration 8 6th April 2006 21:53
Users and websites aren't created Glorfindel Installation/Configuration 9 23rd February 2006 04:20


All times are GMT +2. The time now is 06:24.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.