Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 24th April 2008, 21:36
t.roijers t.roijers is offline
Member
 
Join Date: Feb 2006
Posts: 53
Thanks: 0
Thanked 0 Times in 0 Posts
Default Ubuntu 8 LTS Server ISPCONFIG

Today i upgraded Ubuntu Server 6 LTS to Ubuntu Server 8 LTS. The network upgrade worked perfect! Afterward i reinstalled ISPConfig because it's wasn't functioning properly. When reinstalling ISPConfig it stopped after a while with the announcement ISPConfig will not work with the installed version.

To bad, have to wait for an ISPConfig release that works with the new Ubuntu LTS 8 server.

Just wanted to warn the rest before you have to restore from backup

Greetinx,
Tim
Reply With Quote
Sponsored Links
  #2  
Old 24th April 2008, 21:50
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Which ISPConfig version did you use? As far as I know, Falko installed the current ISPConfig stable version on Ubuntu 8.04 (see rhe tutorial on the howtoforge frontpage).
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 25th April 2008, 00:35
make-fun make-fun is offline
Member
 
Join Date: Jan 2008
Posts: 92
Thanks: 8
Thanked 8 Times in 7 Posts
Default

Could this have to do with the change of the default shell, maybe…?

Quote:
Originally Posted by http://www.ubuntu.com/getubuntu/releasenotes/804

/bin/sh is now dash
  • To improve overall system performance, the /bin/sh shell in Ubuntu 6.10 and later is dash, rather than bash as it was in Ubuntu 6.06 LTS. This may cause compatibility problems for local shell scripts. Please see DashAsBinSh for more information.
http://www.ubuntu.com/getubuntu/releasenotes/804
This stopped me from jumping right into it in the first place — plus I do not like the idea of upgrading a running server the day after any new release. So, this will all better be testet on a VM-Install beforehand.

Cheers
Reply With Quote
  #4  
Old 25th April 2008, 00:45
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Set up your server as shown here: http://www.howtoforge.com/perfect-server-ubuntu8.04-lts
and you won't have any issues.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 25th April 2008, 00:57
make-fun make-fun is offline
Member
 
Join Date: Jan 2008
Posts: 92
Thanks: 8
Thanked 8 Times in 7 Posts
Default

The more convenient way for an existing sys is of course using the new "update-manager-core" package. Have you maybe tested this Falko?

Cheers

Last edited by make-fun; 25th April 2008 at 01:00.
Reply With Quote
  #6  
Old 25th April 2008, 01:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by make-fun
Have you maybe tested this Falko?

Cheers
No, not for 8.04.
I think that AppArmor could cause problems. It's enabled by default, and in my tutorial, I disable it.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 26th April 2008, 11:00
t.roijers t.roijers is offline
Member
 
Join Date: Feb 2006
Posts: 53
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
Which ISPConfig version did you use? As far as I know, Falko installed the current ISPConfig stable version on Ubuntu 8.04 (see rhe tutorial on the howtoforge frontpage).
I used to have Ubuntu Server 6.06 Dapper LTS and Upgraded Ubuntu Server 8.04 LTS server edition.

The upgrade of Ubuntu works just fine, but ISPConfig come with a lot of errors when rebooting.

Tim
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
php Apps email not going through palkat General 8 21st September 2011 05:35
Trying to install - Ubuntu 6.xx LTS for a mail server Happy Installation/Configuration 8 18th August 2007 11:44
Rejecting outbound mail tristanlee85 General 11 20th May 2007 17:04
Ubuntu 6.06 LTS ISP Server Setup with DTC seadap06 HOWTO-Related Questions 9 23rd January 2007 18:48
Request: Perfect Ubuntu 6.06 LTS - Automatic LAMP Server Installation (co-location) Anim Suggest HOWTO 19 6th June 2006 11:30


All times are GMT +2. The time now is 08:52.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.