#1  
Old 14th April 2008, 03:45
bswinnerton bswinnerton is offline
Senior Member
 
Join Date: Jul 2007
Location: Connecticut, US
Posts: 502
Thanks: 51
Thanked 16 Times in 13 Posts
Default CSS Question

Hey everybody,

I'm a little new to css. But I'm having a lot of trouble. I am trying to get my main title to display in Copperplate Gothic Light, and the rest of my site in Lucida Sans, Lucida Grande, or sans-serif. But for some reason the entire site (Only in IE, not Firefox or Safari) is in Lucida Sans, Lucida Grande, sans-serif.

Anyways, here is my style.css can someone show me how to fix this?

Code:
<style type="text/css">

A:link { COLOR: blue; text-decoration: underline}
A:visited { COLOR: blue; text-decoration: underline}
A:active { COLOR: blue; text-decoration: underline}
A:hover { COLOR: blue; text-decoration: none}
body {
	margin-left: 20%;
	margin-right: 20%;
	background-color: #FDFDFD;
	font-family: Lucida Sans, Lucida Grande, sans-serif;
	font-size:11px;
	font-color: #242424;
}
.style1 {font-family: Copperplate Gothic Light; font-size: 24px;}    
.style2 {color: #990000; font style: bold;}                  
.style3 {color: #990000;}                                              
.style4 {font-size: 14px; color: #990000; font-weight: bold} 
#Layer1 {
	position:absolute;
	left:20px;
	top:38px;
	width:105px;
	height:197px;
	z-index:1;
	background-color: #FDFDFD;
	font-family: Lucida Sans, Lucida Grande, sans-serif;
	font-size: 11px;
}

</style>
Reply With Quote
Sponsored Links
  #2  
Old 14th April 2008, 15:58
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

I've stopped counting the hours that I've wasted fixing code so that it works in stupid IE... That browser (is it a browser?) should be forbidden...

Anyway, can you try
Code:
body .style1 {font-family: Copperplate Gothic Light; font-size: 24px;}
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 14th April 2008, 18:19
bswinnerton bswinnerton is offline
Senior Member
 
Join Date: Jul 2007
Location: Connecticut, US
Posts: 502
Thanks: 51
Thanked 16 Times in 13 Posts
Default

=( That didn't seem to work, I have been having so much trouble with it. Here is the page:

Code:
Removed for privacy
And here is what I have been checking to see if it works:

http://ipinfo.info/netrenderer/index.php

Last edited by bswinnerton; 5th May 2008 at 13:49.
Reply With Quote
  #4  
Old 15th April 2008, 16:34
KenJackson KenJackson is offline
Junior Member
 
Join Date: Jul 2006
Location: Maryland, USA
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I pasted your CSS page into the W3C CSS Validation Service and got these errors:

Code:
 9   body      Family names containing whitespace should be quoted. If 
quoting is omitted, any whitespace characters before and after the name 
are ignored and any sequence of whitespace characters inside the name 
is converted to a single space.

13   .style1   Family names containing whitespace should be quoted. If 
quoting is omitted, any whitespace characters before and after the name 
are ignored and any sequence of whitespace characters inside the name 
is converted to a single space.

25   #Layer1   Family names containing whitespace should be quoted. If 
quoting is omitted, any whitespace characters before and after the name 
are ignored and any sequence of whitespace characters inside the name 
is converted to a single space.
So try this, and similarly for the other lines:
Code:
.style1 {font-family: "Copperplate Gothic Light"; font-size: 24px;}
In this particular case, IE didn't actually do it wrong. Firefox and Safari are apparently just more kind and forgiving.
__________________
Why I prefer GNU/Linux
Reply With Quote
  #5  
Old 16th April 2008, 19:25
bswinnerton bswinnerton is offline
Senior Member
 
Join Date: Jul 2007
Location: Connecticut, US
Posts: 502
Thanks: 51
Thanked 16 Times in 13 Posts
Default

Hmm, Well i fixed that and made it so that there were no errors, but I'm still having the problem =( I'm about to just give up.
Reply With Quote
  #6  
Old 1st May 2008, 00:37
Ryanmt Ryanmt is offline
Member
 
Join Date: Apr 2008
Posts: 92
Thanks: 15
Thanked 6 Times in 4 Posts
Default

Do all pcs have Copperplate Gothic Light installed? Its generally a bad idea to use non standard fonts on a website, if the computer installed doesn't have them then it just chooses another font. According to google it only comes with the Microsoft Office Value Pack

Chances are that net render service doesn't have those fonts which is why it wont work, nor will it work on my ubuntu install.

You should make it an image in photoshop, if it needs to be dynamic look into generating it with php as you can use any font you want to do that.

Last edited by Ryanmt; 1st May 2008 at 00:40.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Yet another Postfix smarthost question jokn Server Operation 4 18th February 2008 09:53
Hard drive partitions question bil992 Installation/Configuration 2 11th October 2007 15:34
Proftpd stops and general install question JaJunk Installation/Configuration 6 10th May 2007 21:17
sendmail config question westb Server Operation 1 1st September 2006 17:00
Really Basic Question !!! brainz Installation/Configuration 7 13th March 2006 23:20


All times are GMT +2. The time now is 10:44.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.