#1  
Old 24th January 2006, 11:54
domenico domenico is offline
Junior Member
 
Join Date: Jan 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation Send mail but don't receive

Hi,

I installed ispconfig on Fedora core 4 with Perfectsetup instructions and
I've got a problem where my mail server can't receive mail but can send it.

A look at maillog show those lines

Jan 21 08:56:13 sele postfix/smtpd[3411]: connect from
smtp6.libero.it[193.70.192.59]
Jan 21 08:56:13 sele postfix/smtpd[3411]: B7C6459EA87:
client=smtp6.libero.it[193.70.192.59]
Jan 21 08:56:13 sele postfix/cleanup[3418]: B7C6459EA87:
message-id=<ITFNDL$5F486655CEAD6CEFDBA22CEFF1EECBC2@libero .it>
Jan 21 08:56:13 sele postfix/qmgr[2844]: B7C6459EA87:
from=<domenico.squadrito@libero.it>, size=1225, nrcpt=1 (queue active)
Jan 21 08:56:13 sele postfix/local[3419]: B7C6459EA87:
to=<root@sele.intranet.lan>, orig_to=<info@itisvarese.it>, relay=local,
delay=0, status=sent (delivered to mailbox)
Jan 21 08:56:13 sele postfix/qmgr[2844]: B7C6459EA87: removed
Jan 21 08:56:18 sele postfix/smtpd[3411]: disconnect from
smtp6.libero.it[193.70.192.59]

in the main.cf I have the lines

queue_directory = /var/spool/postfix
command_directory = /usr/sbin
daemon_directory = /usr/libexec/postfix
mail_owner = postfix
inet_interfaces = all
unknown_local_recipient_reject_code = 550
alias_database = hash:/etc/aliases
debug_peer_level = 2
debugger_command =
PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
xxgdb $daemon_directory/$process_name $process_id & sleep 5
sendmail_path = /usr/sbin/sendmail.postfix
newaliases_path = /usr/bin/newaliases.postfix
mailq_path = /usr/bin/mailq.postfix
setgid_group = postdrop
html_directory = no
manpage_directory = /usr/share/man
sample_directory = /usr/share/doc/postfix-2.2.2/samples
readme_directory = /usr/share/doc/postfix-2.2.2/README_FILES
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions =
permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
virtual_alias_domains = itisvarese.it
virtual_alias_maps = hash:/etc/postfix/virtusertable

and the virtusertable has the line

info@itisvarese.it info

What is wrong?

Thanks
Reply With Quote
Sponsored Links
  #2  
Old 24th January 2006, 12:11
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,034
Thanks: 826
Thanked 5,383 Times in 4,230 Posts
Default

The mail does got delivered to the root user. Your main.cf file does not look like it was modified by the ISPConfig installer. Did you got any errors during installation?

In main.cf the following line is missing:

mydestination = /etc/postfix/local-host-names
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 24th January 2006, 12:55
domenico domenico is offline
Junior Member
 
Join Date: Jan 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes,
I changed manually the entry in main .cf:
virtual_alias_domain with mydestination without obtain results.
The fact is that the mail is delivered in the /var/mail/root mailbox but I expect it in /home/www/www.itisvarese.it/user/info/Maildir
I proved to set home_mailbox = Maildir/ in main.cf without results
Tanks
Reply With Quote
  #4  
Old 24th January 2006, 12:59
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,034
Thanks: 826
Thanked 5,383 Times in 4,230 Posts
Default

Have you checked the maildir Checkbox in ISPConfig under management > Server > settings on the mail tab? have you installed dovecot or courier as pop3 and imap daemon?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 24th January 2006, 20:50
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Please check /etc/aliases if mails for info are redirected to root.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 25th January 2006, 10:47
domenico domenico is offline
Junior Member
 
Join Date: Jan 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok Falko,
I changed /etc/aliases and effectively now there is no more redirect and the received mail is putted into /var/mail/info file.
Ok Till,
I changed ISPConfig under management > Server > settings on the mail tab by checking Maildir box and now the received mail is putted into /home/www/www.itisvarese.it/user/info/maildir/new

It remain that I can send correctly mail from squirrelmail but don't see received mail in INBOX of squirremail, I think some process must move mail from /home/www/www.itisvarese.it/user/info/maildir/new to /home/www/www.itisvarese.it/user/info/INBOX but the INBOX file does not exist so what is wrong ?
Reply With Quote
  #7  
Old 25th January 2006, 19:25
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Which POP3 daemon do you use? Please post the output of
Code:
netstat -tap
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 26th January 2006, 11:44
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,034
Thanks: 826
Thanked 5,383 Times in 4,230 Posts
Default

Quote:
Originally Posted by domenico
I changed ISPConfig under management > Server > settings on the mail tab by checking Maildir box and now the received mail is putted into /home/www/www.itisvarese.it/user/info/maildir/new
Okay, as you posted later that you use the imap package, youhave to uncheck the maildir checkbox again.

When the mail is delivered to /var/spool/mail/info file, you should be able to fetch it with pop3 and imap. Have you tried a normal mailclient like outlook or thunderbird instead of using the webmail program?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Filtering emails using Spamassassin and Clamav for Exchange 2000 Server Rocky Server Operation 19 11th March 2008 08:27
Read but not send mail briggers HOWTO-Related Questions 24 7th April 2006 19:22
Mail server jas_esp Server Operation 1 7th December 2005 18:17
I can't seem to send or receive mail indicator72 Installation/Configuration 21 19th November 2005 20:46
90% perfect (can't receive mail) CorrosionX General 2 7th November 2005 17:40


All times are GMT +2. The time now is 04:24.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.