Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 21st January 2006, 07:33
ccix ccix is offline
Junior Member
 
Join Date: Jan 2006
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default Postfix SMTP Port 25 Problem/Question

I've had a email server setup for awhile now with sendmail. i've since installed a new hard drive and started with the fresh setup for the debian 3.1 how to. Everything seems to work great except this....

If i'm on the local host i can telnet to port 25 and send mail/etc.... But if i try to login from outside the domain (say from dialup or not from my office...at my parents house) it doesn't connect, just times out? What am i missing? Is there a setting i missed. Followed the setup perfectly (set it up a few times actually why playing around). One note, i'm not using ISPCONFIG.

Any help would be appreciated.

Eric
Reply With Quote
Sponsored Links
  #2  
Old 21st January 2006, 07:42
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,711
Thanks: 1,900
Thanked 2,702 Times in 2,545 Posts
Default

Are you using Sendmail or Postfix right now? If you use Postfix, have a look at the
Code:
inet_interfaces
setting in /etc/postfix/main.cf, if you use Sendmail, have a look here: http://www.howtoforge.com/forums/showthread.php?t=25

Might also be a firewall problem. Please post the output of
Code:
iptables -L
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 21st January 2006, 07:49
ccix ccix is offline
Junior Member
 
Join Date: Jan 2006
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I am using Postfix (setup via the howto for the perfect setup+SQL/auth/etc)

inet_interfaces = all

ns:/etc/postfix# iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination


mail server is mail.ccix.com if you'd like to telnet in and see what happens.... any other ideas? Let me know if you want a copy of any other config settings/files.


Eric
Reply With Quote
  #4  
Old 21st January 2006, 07:51
themachine themachine is offline
Senior Member
 
Join Date: Oct 2005
Location: Texas, USA
Posts: 109
Thanks: 0
Thanked 0 Times in 0 Posts
Default

are you behind a firewall??? if so, perhaps you need to open the port up and configure port forwarding... by default the port is probably blocked at the firewall.
__________________
themachine
5dollarwhitebox.org
Reply With Quote
  #5  
Old 21st January 2006, 07:56
ccix ccix is offline
Junior Member
 
Join Date: Jan 2006
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

No physical firewall in front of the server. If i plugin the old harddrive and use my old setup then i can send email fine through sendmail (was using debian 3.0 ...worked okay but i liked the way the howto setup things this way).

So definately no firewall (Cisco 675 for DSL, then into a 4 port up ...where the server is connected directly).
Reply With Quote
  #6  
Old 21st January 2006, 16:59
themachine themachine is offline
Senior Member
 
Join Date: Oct 2005
Location: Texas, USA
Posts: 109
Thanks: 0
Thanked 0 Times in 0 Posts
Default

You might want to contact your ISP and inquire as to whether they block port 25 or not. I see customers all the time that cannot send/receive SMTP email *exect* through the servers that are provided by the ISP. It is likely that port 25 is being blocked at the ISP level.
__________________
themachine
5dollarwhitebox.org
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mailserver / Postfix Problems oaky Server Operation 31 7th August 2007 19:50
Suse Postfix + Dovecot + ISP Config + smtp Auth; recieving problem! fatum112 HOWTO-Related Questions 2 15th January 2006 19:03
postfix starts and stops why lhatle Installation/Configuration 2 21st December 2005 15:20
ISPs blocking smtp-auth on port 25 oneinchpunch HOWTO-Related Questions 1 8th December 2005 02:36
Postfix SMTP Auth Configuration kisong Installation/Configuration 6 20th October 2005 01:06


All times are GMT +2. The time now is 09:04.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.