#1  
Old 20th January 2006, 03:51
enriquecm enriquecm is offline
Junior Member
 
Join Date: Jan 2006
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Lightbulb Ubunto+ISP

well i have problema with the configuration

http://www.howtoforge.com/perfect_setup_ubuntu_5.04

I have one public IP (200.123.123.123)

In my server i have two network interface
1 for lan: eth0 (private IP) (192.168.0.1) <--- for give to the lan administration and internet service
1 for wan: eth1 (200.123.123.123)

I buy tree dns (www.nic.com)
pepito.com = (200.123.123.123)
pancho.com = (200.123.123.123)
cool.com = (200.123.123.123)

to do that I edit /etc/network/interfaces

auto eth1
auto eth0
iface eth0 inet static
address 192.168.0.1
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.0.255
gateway 192.168.0.1

then I restart my service
/etc/init.d/networking restart

I edit /etc/hosts
127.0.0.1 localhost.localdomain localhost server

then
echo localhost.localdomain > /etc/hostname
/bin/hostname -F /etc/hostname

Well i think that i dont know what is the problem, but the idea is that:
one user of the lan can access with this ip 192.168.0.1
and the users of the wan can access with this ip 200.123.123.123

and my dns pepito.com, pancho.com, cool.com connect to my server to the wan

ANY IDEAS !!?!?!??!
Reply With Quote
Sponsored Links
  #2  
Old 20th January 2006, 05:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

What exactly is the problem?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 20th January 2006, 10:01
enriquecm enriquecm is offline
Junior Member
 
Join Date: Jan 2006
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy well !!! thats a good question

When i finished to configure my ISP

First the lan cant connect to https://192.168.1.1:80
With the connection wan i dont have any problem

But, when i made emails i cant do users
Only give me the message: That User exists

When i restart my server (ubuntu) says me that i have a bad configuration in
/etc/hosts

and the server connects in a virtual mode.

I dont know why
Reply With Quote
  #4  
Old 20th January 2006, 10:53
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Quote:
Originally Posted by enriquecm
But, when i made emails i cant do users
Only give me the message: That User exists
You add the emal where, in ISPConfig? Have you created an email user before and deleted it, the empty the recycle bin.

If you created a system user manually before or use an username like root, the the username is blocked in ISPConfig for security reasons. Please chose another username.


Quote:
When i restart my server (ubuntu) says me that i have a bad configuration in
/etc/hosts
I guess your /etc/network/interfaces must be like this:

Code:
auto eth0
iface eth0 inet static
        address 192.168.0.1
        netmask 255.255.255.0
        network 192.168.0.0
        broadcast 192.168.0.255
        gateway 192.168.0.1

auto eth1
iface eth1 inet static
        address 200.123.123.123
        netmask 255.255.255.0
        network 200.123.123.0
        broadcast 200.123.123.255
        gateway 200.123.123.123
You will have to set the gateway, netmask and nezwork for eth1 accordingly o the values you got from your ISP.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 22nd January 2006, 13:51
enriquecm enriquecm is offline
Junior Member
 
Join Date: Jan 2006
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up Finished it!!!

Problem #1
In my server i have two network interface
1 for lan: eth0 (private IP) (192.168.0.1) <--- for give to the lan administration and internet service
1 for wan: eth1 (200.123.123.123)

Answer #1
configure /etc/network/interface

iface eth1 inet dhcp #I put that first to give the gateway of the wan connection

auto eth0
iface eth0 inet static
address 192.168.0.1
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.0.255
gateway 192.168.0.1

auto eth1

then restart de interfaces
/etc/init.d/networkin restart

configure /etc/hosts

127.0.0.1 localhost.localdomain localhost server1 server1.example.com
200.123.123.123 server1.example.com

then
echo server1.example.com > /etc/hostname
/bin/hostname -F /etc/hostname

continues in page: http://www.howtoforge.com/perfect_setup_ubuntu_5.10_p3

Problem #2
But, when i made emails i cant do users
Only give me the message: That User exists

Answer 2:
Well the problem was the hosts!!!

In my case:
Only i can send message, but i cant received!!
And what i do for this case to resolved that problem!?
Well the problem was the DNS of the server
Go to https://localhost:81
and then go to management - server - settings - DNS
Default NS1: 66.94.230.40 (yahoo dns)
Default NS2: 192.168.0.100 (localserver)
Default MX: On

now I can send/receive msg

Thanks!!

I hope that i can help some persons !!!

Every day its a great day but some days are betters than others
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 20:17.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.