Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 4th March 2008, 13:43
malinens malinens is offline
Member
 
Join Date: Jan 2008
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Default Phpmyadmin import max size (Max: 8,192 KiB), how can I change it?

Hi!
Can you tell me how can I change max file size on phpmyadmin? MY php.ini:
memory_limit = 512M
post_max_size = 80M
upload_max_filesize = 200M
I have restarted apache several times and no results.
Thank you for reply

Last edited by malinens; 4th March 2008 at 14:07.
Reply With Quote
Sponsored Links
  #2  
Old 4th March 2008, 13:56
zcworld zcworld is offline
Senior Member
 
Join Date: Jul 2006
Location: South Australia
Posts: 329
Thanks: 2
Thanked 37 Times in 37 Posts
Send a message via MSN to zcworld Send a message via Skype™ to zcworld
Default

check and edit your php.ini file and the my.cnf file

restart apache / mysql
and it should update the size limit

PS. its bites when you do an big sql upload / reload
__________________
Shane Ebert :: Facebok
Reply With Quote
  #3  
Old 4th March 2008, 14:12
malinens malinens is offline
Member
 
Join Date: Jan 2008
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Default

this is my my.cnf (I have restarted mysql and apache2...)

Code:
#
# The MySQL database server configuration file.
#
# You can copy this to one of:
# - "/etc/mysql/my.cnf" to set global options,
# - "~/.my.cnf" to set user-specific options.
#
# One can use all long options that the program supports.
# Run program with --help to get a list of available options and with
# --print-defaults to see which it would actually understand and use.
#
# For explanations see
# http://dev.mysql.com/doc/mysql/en/server-system-variables.html

# This will be passed to all mysql clients
# It has been reported that passwords should be enclosed with ticks/quotes
# escpecially if they contain "#" chars...
# Remember to edit /etc/mysql/debian.cnf when changing the socket location.
[client]
port            = 3306
socket          = /var/run/mysqld/mysqld.sock

# Here is entries for some specific programs
# The following values assume you have at least 32M ram

# This was formally known as [safe_mysqld]. Both versions are currently parsed.
[mysqld_safe]
socket          = /var/run/mysqld/mysqld.sock
nice            = 0

[mysqld]
#
# * Basic Settings
#
user            = mysql
pid-file        = /var/run/mysqld/mysqld.pid
socket          = /var/run/mysqld/mysqld.sock
port            = 3306
basedir         = /usr
datadir         = /var/lib/mysql
tmpdir          = /tmp
language        = /usr/share/mysql/english
skip-external-locking
#
# The MySQL database server configuration file.
#
# You can copy this to one of:
# - "/etc/mysql/my.cnf" to set global options,
# - "~/.my.cnf" to set user-specific options.
#
# One can use all long options that the program supports.
# Run program with --help to get a list of available options and with
# --print-defaults to see which it would actually understand and use.
#
# For explanations see
# http://dev.mysql.com/doc/mysql/en/server-system-variables.html

# This will be passed to all mysql clients
# It has been reported that passwords should be enclosed with ticks/quotes
# escpecially if they contain "#" chars...
# Remember to edit /etc/mysql/debian.cnf when changing the socket location.
[client]
port            = 3306
socket          = /var/run/mysqld/mysqld.sock

# Here is entries for some specific programs
# The following values assume you have at least 32M ram

# This was formally known as [safe_mysqld]. Both versions are currently parsed.
[mysqld_safe]
socket          = /var/run/mysqld/mysqld.sock
nice            = 0
[mysqld]
#
# * Basic Settings
#
user            = mysql
pid-file        = /var/run/mysqld/mysqld.pid
socket          = /var/run/mysqld/mysqld.sock
port            = 3306
basedir         = /usr
datadir         = /var/lib/mysql
tmpdir          = /tmp
language        = /usr/share/mysql/english
skip-external-locking
#
# localhost which is more compatible and is not less secure.
#bind-address           = 127.0.0.1
#
# * Fine Tuning
#
key_buffer              = 160M
max_allowed_packet      = 160M
thread_stack            = 128K
thread_cache_size       = 8
max_connections        = 1000
#table_cache            = 64
#thread_concurrency     = 10
#
# * Query Cache Configuration
#
query_cache_limit       = 10M
query_cache_size        = 160M
#
# * Logging and Replication
#
# Both location gets rotated by the cronjob.
# Be aware that this log type is a performance killer.
#log            = /var/log/mysql/mysql.log
#
# Error logging goes to syslog. This is a Debian improvement :)
#
# Here you can see queries with especially long duration
#log_slow_queries       = /var/log/mysql/mysql-slow.log
#long_query_time = 2
#log-queries-not-using-indexes
#
# The following can be used as easy to replay backup logs or for replication.
# note: if you are setting up a replication slave, see README.Debian about
#       other settings you may need to change.
#server-id              = 1
log_bin                 = /var/log/mysql/mysql-bin.log
# WARNING: Using expire_logs_days without bin_log crashes the server! See README.Debian!
expire_logs_days        = 10
max_binlog_size         = 100M
#binlog_do_db           = include_database_name
#binlog_ignore_db       = include_database_name
#
# * BerkeleyDB
#
# Using BerkeleyDB is now discouraged as its support will cease in 5.1.12.
skip-bdb
#
# * InnoDB
#
# InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.
# Read the manual for more InnoDB related options. There are many!
# You might want to disable InnoDB to shrink the mysqld process by circa 100MB.
#skip-innodb
#
# * Security Features
#
# Read the manual, too, if you want chroot!
# chroot = /var/lib/mysql/
#
# For generating SSL certificates I recommend the OpenSSL GUI "tinyca".
#
# ssl-ca=/etc/mysql/cacert.pem
# ssl-cert=/etc/mysql/server-cert.pem
# ssl-key=/etc/mysql/server-key.pem



[mysqldump]
quick
quote-names

max_allowed_packet      = 160M

[mysql]
#no-auto-rehash # faster start of mysql but no tab completition

[isamchk]
key_buffer              = 160M

#
# * NDB Cluster
#
# See /usr/share/doc/mysql-server-*/README.Debian for more information.
#
# The following configuration is read by the NDB Data Nodes (ndbd processes)
# not from the NDB Management Nodes (ndb_mgmd processes).
#
# [MYSQL_CLUSTER]
# ndb-connectstring=127.0.0.1


#
# * IMPORTANT: Additional settings that can override those from this file!
#
!includedir /etc/mysql/conf.d/
# Read the manual, too, if you want chroot!
# chroot = /var/lib/mysql/
#
# For generating SSL certificates I recommend the OpenSSL GUI "tinyca".
#
# ssl-ca=/etc/mysql/cacert.pem
# ssl-cert=/etc/mysql/server-cert.pem
# ssl-key=/etc/mysql/server-key.pem



[mysqldump]
quick
quote-names

max_allowed_packet      = 160M

[mysql]
#no-auto-rehash # faster start of mysql but no tab completition

[isamchk]
key_buffer              = 160M

#
# * NDB Cluster
#
# See /usr/share/doc/mysql-server-*/README.Debian for more information.
#
# The following configuration is read by the NDB Data Nodes (ndbd processes)
# not from the NDB Management Nodes (ndb_mgmd processes).
#
# [MYSQL_CLUSTER]
# ndb-connectstring=127.0.0.1


#
# * IMPORTANT: Additional settings that can override those from this file!
#
!includedir /etc/mysql/conf.d/
Reply With Quote
  #4  
Old 4th March 2008, 14:44
zcworld zcworld is offline
Senior Member
 
Join Date: Jul 2006
Location: South Australia
Posts: 329
Thanks: 2
Thanked 37 Times in 37 Posts
Send a message via MSN to zcworld Send a message via Skype™ to zcworld
Default

-nods-
ok i will have an test play on to see if i can work it out

dont have ISP installed in an test box ATM
so give me about an 2 hrs to get one up n running

its got me r***TED

when i do an info.php
to display the php settings
its tells me im over the 8 MB limit but still its only says 8 MB on the phpmyadmin page
maybe try to ssh tunnel in and use mysql admin to reload the SQL database or ZIP the file to see if you can upload it to the box that way


UPDATE / EDIT
but try
Partial import
Allow interrupt of import in case script detects it is close to time limit. This might be good way to import large files, however it can break transactions.
Number of records(queries) to skip from start
see if thats works
never used it but i see it on the import page
__________________
Shane Ebert :: Facebok

Last edited by zcworld; 4th March 2008 at 17:59.
Reply With Quote
  #5  
Old 4th March 2008, 18:33
zcworld zcworld is offline
Senior Member
 
Join Date: Jul 2006
Location: South Australia
Posts: 329
Thanks: 2
Thanked 37 Times in 37 Posts
Send a message via MSN to zcworld Send a message via Skype™ to zcworld
Default

if you only want the phpmyadmin for yourself
to do backup / restores

than make an demo
and set it to be only access via your IP address
and put in an .htaccess file with username / password

than goto the phpmyadmin website and download the script itself and go from there

its got my r***ted big time :/
sorry i can't be any more help
maybe one of them key ispconfig members can help you out more


or mabye
if the SQL file got more than one database inside
( personal i do once a week or when i do big changes / updates to my video DBs i do an full backup of them
i got 3 x video DB
)



if you can and how what your doing
make an backup
and than a backup of the master again
2 x backup( incase)
than open it in an context ( notepad editor with color coding)

than find the first SQL database copy it and save it
than find the second one copy it save it

than try to reload it that way
__________________
Shane Ebert :: Facebok

Last edited by zcworld; 4th March 2008 at 18:38.
Reply With Quote
  #6  
Old 31st July 2008, 01:53
Tommahawk Tommahawk is offline
Member
 
Join Date: May 2007
Posts: 70
Thanks: 0
Thanked 10 Times in 5 Posts
Default

Phpmyadmin says

upload_max_filesize, memory_limit and post_max_size in the php.ini configuration file. All of these three settings limit the maximum size of data that can be submitted and handled by PHP. One user also said that post_max_size and memory_limit need to be larger than upload_max_filesize.

You may also need to change Maximum execution time setting

The PHP.ini associated with ISPConfig is not found with /etc/php.ini it with your ispconfig version of apache. e.g /<root>/ispconfig/php/php.ini

change the settings and restart ISPConfig the 8,000kib will change
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian Sarge - phpMyAdmin has no import Nap Installation/Configuration 10 14th November 2006 10:51
phpmyAdmin doesn't have Import option Nap Installation/Configuration 4 25th October 2006 11:28


All times are GMT +2. The time now is 09:47.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.