#1  
Old 14th January 2006, 16:28
ruskicar ruskicar is offline
Junior Member
 
Join Date: Jan 2006
Location: Slovenia
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default php5 on debian sarge (stable)

How to install php5 on Debian 3.1 stable?
Reply With Quote
Sponsored Links
  #2  
Old 14th January 2006, 17:16
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,504
Thanks: 813
Thanked 5,265 Times in 4,129 Posts
Default

Quote:
Originally Posted by ruskicar
How to install php5 on Debian 3.1 stable?
You can use the php5 package from backports.org. Instrctions on how to configure your sources list where provided here:

http://www.backports.org/instructions.html

The PHP5 backports package is named "php5".
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 14th January 2006, 17:31
ruskicar ruskicar is offline
Junior Member
 
Join Date: Jan 2006
Location: Slovenia
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Great! Thanks
Reply With Quote
  #4  
Old 15th February 2006, 11:30
geek.de.nz geek.de.nz is offline
Member
 
Join Date: Feb 2006
Posts: 65
Thanks: 0
Thanked 2 Times in 2 Posts
Send a message via ICQ to geek.de.nz Send a message via MSN to geek.de.nz
Default PHP5 on debian sarge

I tried like described at
http://www.debianhelp.co.uk/php5.htm

But for some reason I still can't run PHP5. It is installed as shown by apt-get. But when I run
#php -v
I get:
PHP 4.3.10-16 (cli) (built: Aug 24 2005 20:25:01)
Copyright (c) 1997-2004 The PHP Group
Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies

Also, when I run the phpinfo(); I get:
PHP Version 4.3.10-16
...

Someone knows how to actually activate php5? I even deleted php4 with
#apt-get remove php4
and restarted the webserver with
#/etc/init.d/apache2 restart
Even tried rebooting, but still it didn't work.

I need PHP5 because I'm using classes etc, otherwise I'll have to rewrite a lot of the stuff I'm developing to run on my vserver.
Reply With Quote
  #5  
Old 15th February 2006, 20:43
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by geek.de.nz
I tried like described at
http://www.debianhelp.co.uk/php5.htm

But for some reason I still can't run PHP5. It is installed as shown by apt-get. But when I run
#php -v
I get:
PHP 4.3.10-16 (cli) (built: Aug 24 2005 20:25:01)
Copyright (c) 1997-2004 The PHP Group
Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies
You used the command line PHP here. Did you install php5-cli?


Quote:
Originally Posted by geek.de.nz
Also, when I run the phpinfo(); I get:
PHP Version 4.3.10-16
...
Did you run that on the command line or in a web browser?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 16th February 2006, 03:06
geek.de.nz geek.de.nz is offline
Member
 
Join Date: Feb 2006
Posts: 65
Thanks: 0
Thanked 2 Times in 2 Posts
Send a message via ICQ to geek.de.nz Send a message via MSN to geek.de.nz
Default

Quote:
Originally Posted by falko
You used the command line PHP here. Did you install php5-cli?


Did you run that on the command line or in a web browser?
I did run that part in a web browser.

Anyway, I got it sorted now. I don't know why, but when I went through the steps again, it just worked. I think I might have missed out on the lib module or something. Well, anyway, it's working now, thnx though.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sarge php5 freeType gd pontifex Installation/Configuration 6 7th December 2005 09:37
e-mail problem!!! Debian 3.1 maroonworks Installation/Configuration 18 6th December 2005 14:42
Debian Sarge RAID5 killfrog Installation/Configuration 2 23rd October 2005 21:43
Perfect setup (debian sarge) Pelle Installation/Configuration 4 11th October 2005 17:17
Install Debian Sarge with Kernel 2.6 root Installation/Configuration 4 10th May 2005 10:51


All times are GMT +2. The time now is 09:12.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.