Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 11th January 2006, 06:49
amoswright amoswright is offline
Junior Member
 
Join Date: Jan 2006
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Red face novice question.. I gave wrong IP for install, how to change?

Hi,

I just completed an install of ISPConfig on fc4 as described in "the perfect set up". I thought that things had gone well, untill I tried to log in on port 80... no go, connection timmed out... then I realized that I'd made a mistake in assigning the IP at the end of the ISPConfig install (ISPConfig Web address). How can I change this?

Again, i think that things went well otherwise.. i couldn't get any of the "postconf -e 'smtpd_sasl_local_domain =' " and similar commands to work, even though postfix did install, but thought that this wouldn't matter much since i'm not really interested in setting up mail.

Stoopid to make such a moronic mistake in the first place... I'd love to know how to change the ISPConfig Web address.

Thanks Much!
Amos
Reply With Quote
Sponsored Links
  #2  
Old 11th January 2006, 11:06
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

Quote:
Originally Posted by amoswright
Hi,

I just completed an install of ISPConfig on fc4 as described in "the perfect set up". I thought that things had gone well, untill I tried to log in on port 80... no go, connection timmed out... then I realized that I'd made a mistake in assigning the IP at the end of the ISPConfig install (ISPConfig Web address). How can I change this?
First, you must login on port 81, that's the port ISPConfig uses.
You can change the URL in /home/admispconfig/ispconfig/lib/config.inc.php. You might also have to change the address in /root/ispconfig/httpd/conf/httpd.conf and restart ISPConfig then:
Code:
/etc/init.d/ispconfig_server restart
Quote:
Originally Posted by amoswright
Again, i think that things went well otherwise.. i couldn't get any of the "postconf -e 'smtpd_sasl_local_domain =' " and similar commands to work, even though postfix did install, but thought that this wouldn't matter much since i'm not really interested in setting up mail.
Why do you think the postconf commands did not work? Did you get any errors?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 11th January 2006, 11:43
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,045
Thanks: 841
Thanked 5,661 Times in 4,468 Posts
Default

Quote:
Originally Posted by amoswright
Again, i think that things went well otherwise.. i couldn't get any of the "postconf -e 'smtpd_sasl_local_domain =' " and similar commands to work, even though postfix did install, but thought that this wouldn't matter much since i'm not really interested in setting up mail.
Did you execute the commands as root user?

These commands did not output anything, if you had not got an error, the comands executed successfully.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 11th January 2006, 21:11
amoswright amoswright is offline
Junior Member
 
Join Date: Jan 2006
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi and thanks for the speedy reply! Thanks Falko and Till!

I'll clarify what I had tried and where I went wrong (I believe):

In setting up my system, I had installed ISPConfig on a PC that is connected to a Linksys router. I had given the PC two static IP's as described in "perfect set up", 192.168.1.199 and 192.168.1.200. During the final install of ISPConfig, I listed 192.168.1.199 as the "address of the ISPConfig web".. Now, I have a static IP from our service provider, 66.63.88.57, and once I realized the complications that would arise with port forwarding on the router etc., thought to put the server outside of the router (by way of connecting the PC and the router to a small switch). Thus, I hoped to assign our outside static IP to the server with ISPConfig, and have the router on DHCP... Does this set up work, and if so how would I change that IP setting in ISPConfig? I looked in the files that were suggested, and saw how to change the URL such as "bathskatepark.org", but not the underlying IP number, did I just miss it?

On other question of executing the postconf commands, I did get an error, "command not found". I was logged in as root. Oddly, now the command works... Is it too late to complete this section of the "perfet install" directions, after ISPConfig is set up?

Thanks agian,
Amos
Reply With Quote
  #5  
Old 11th January 2006, 21:15
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,045
Thanks: 841
Thanked 5,661 Times in 4,468 Posts
Default

Quote:
Originally Posted by amoswright
In setting up my system, I had installed ISPConfig on a PC that is connected to a Linksys router. I had given the PC two static IP's as described in "perfect set up", 192.168.1.199 and 192.168.1.200. During the final install of ISPConfig, I listed 192.168.1.199 as the "address of the ISPConfig web".. Now, I have a static IP from our service provider, 66.63.88.57, and once I realized the complications that would arise with port forwarding on the router etc., thought to put the server outside of the router (by way of connecting the PC and the router to a small switch). Thus, I hoped to assign our outside static IP to the server with ISPConfig, and have the router on DHCP... Does this set up work, and if so how would I change that IP setting in ISPConfig? I looked in the files that were suggested, and saw how to change the URL such as "bathskatepark.org", but not the underlying IP number, did I just miss it?
For this kind of setup you need 2 statix IP's from your provider. One for the server and one for the router.


Quote:
On other question of executing the postconf commands, I did get an error, "command not found". I was logged in as root. Oddly, now the command works... Is it too late to complete this section of the "perfet install" directions, after ISPConfig is set up?
You can rerun the postfix setup part.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 11th January 2006, 21:38
amoswright amoswright is offline
Junior Member
 
Join Date: Jan 2006
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
For this kind of setup you need 2 statix IP's from your provider. One for the server and one for the router.
Hmmm... so, back to setting it up behind the router then... was I correct in providing the local static IP (ie 192.168.1.199 or 192.168.1.200) as the ISPConfig Web IP?

I guess I'm not sure of the settings for the final part of ISPConfig, and how to change them now, after the fact...

If I assign the router the the outside static IP, then would these settings work:
Please enter your MySQL server: localhost
Please enter your MySQL user: root
Please enter your MySQL password: (psswd)
Please enter a name for the ISPConfig database: ispconfigdb
Please enter the IP address of the ISPConfig web: 192.168.0.199
Please enter the host name: www
Please enter the domain: bathskatepark.org
Please select the protocol (http or https (SSL encryption)) to use to access the ISPConfig system: http

And then... I need to do something to the router to forward the http://www.bathskatepark.org:81 request to the internal IP?

...Trying to get a server set up so kids at our teen center can do web design on our newly donated computers... Am I getting close?

Once again, thank you!!!!
Amos
Reply With Quote
  #7  
Old 12th January 2006, 02:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

Quote:
Originally Posted by amoswright
If I assign the router the the outside static IP, then would these settings work:
As Till said, you would need a second static IP address for this.

So I guess you're setting up your server behind the router in a local network. My comments are for this scenario.
Quote:
Originally Posted by amoswright
Please enter your MySQL server: localhost
Please enter your MySQL user: root
Please enter your MySQL password: (psswd)
Please enter a name for the ISPConfig database: ispconfigdb
Please enter the IP address of the ISPConfig web: 192.168.0.199
Please enter the host name: www
Please enter the domain: bathskatepark.org
Please select the protocol (http or https (SSL encryption)) to use to access the ISPConfig system: http
This is all ok.

Quote:
Originally Posted by amoswright
And then... I need to do something to the router to forward the http://www.bathskatepark.org:81 request to the internal IP?
You have to forward port 81 from your router to your ISPConfig server.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 06:40.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.