Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 10th January 2006, 04:20
Bailx Bailx is offline
Junior Member
 
Join Date: Dec 2005
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default SuSe 9.3 64-bit apt-get question...

I'm following the perfect suse 9.3 howto, except i've been modifying things a little bit since i'm running the 64-bit version.

when installing apt i went with the top two listed here (haven't tried jmorris, but should it matter?)

Code:
ftp://ftp.gwdg.de/pub/linux/suse/apt/SuSE/9.3-x86_64/RPMS.suser-scorot/apt-0.5.15cnc7-0.suse093.sc.x86_64.rpm
ftp://ftp.gwdg.de/pub/linux/suse/apt/SuSE/9.3-x86_64/RPMS.suser-scorot/apt-libs-0.5.15cnc7-0.suse093.sc.x86_64.rpm
ftp://ftp.gwdg.de/pub/linux/suse/apt/SuSE/9.3-x86_64/RPMS.suser-jmorris/apt-0.5.15cnc7-suse093.jm.2.x86_64.rpm
ftp://ftp.gwdg.de/pub/linux/suse/apt/SuSE/9.3-x86_64/RPMS.suser-jmorris/apt-libs-0.5.15cnc7-suse093.jm.2.x86_64.rpm
for my sources.list, i've been using this
http://ftp.gwdg.de/pub/linux/suse/ap...urces.list.FTP

everything has been going fine, except when I got to mysql & mysql-devel. It's telling me failed: cpio: Bad magic. It seems that this would mean corrupted packages...

no doubt i could get this installed in some other way, but I was trying to follow the howto as best as I could, so that perhaps other people could benefit...

any help that someone might lend would be appreciated.
Reply With Quote
Sponsored Links
  #2  
Old 10th January 2006, 12:16
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

In that case I'd try to install these packages with yast.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 27th January 2006, 06:39
gimhan90 gimhan90 is offline
Senior Member
 
Join Date: Jan 2006
Posts: 139
Thanks: 2
Thanked 0 Times in 0 Posts
Default Quota configuration error/ suse 9.3

Quote:
Originally Posted by Bailx
I'm following the perfect suse 9.3 howto, except i've been modifying things a little bit since i'm running the 64-bit version.

when installing apt i went with the top two listed here (haven't tried jmorris, but should it matter?)

Code:
ftp://ftp.gwdg.de/pub/linux/suse/apt/SuSE/9.3-x86_64/RPMS.suser-scorot/apt-0.5.15cnc7-0.suse093.sc.x86_64.rpm
ftp://ftp.gwdg.de/pub/linux/suse/apt/SuSE/9.3-x86_64/RPMS.suser-scorot/apt-libs-0.5.15cnc7-0.suse093.sc.x86_64.rpm
ftp://ftp.gwdg.de/pub/linux/suse/apt/SuSE/9.3-x86_64/RPMS.suser-jmorris/apt-0.5.15cnc7-suse093.jm.2.x86_64.rpm
ftp://ftp.gwdg.de/pub/linux/suse/apt/SuSE/9.3-x86_64/RPMS.suser-jmorris/apt-libs-0.5.15cnc7-suse093.jm.2.x86_64.rpm
for my sources.list, i've been using this
http://ftp.gwdg.de/pub/linux/suse/ap...urces.list.FTP

everything has been going fine, except when I got to mysql & mysql-devel. It's telling me failed: cpio: Bad magic. It seems that this would mean corrupted packages...

no doubt i could get this installed in some other way, but I was trying to follow the howto as best as I could, so that perhaps other people could benefit...

any help that someone might lend would be appreciated.



Hi,

i too use 64 bit version and followed the how to steps as neccesary changes for 64 bit. but when i tried to install apt-get , i got following error. pls give me a hint .

please chkeck my steps.

su93254144:/etc # rpm -ivh ftp://ftp.gwdg.de/pub/linux/suse/apt....sc.x86_64.rpm
su93254144:/etc # rpm -ivh ftp://ftp.gwdg.de/pub/linux/suse/apt....sc.x86_64.rpm
Preparing...

install apt on suse 9.3/64 bit

su93254144:/etc/apt # vi sources.list
# A very basic sources.list file.
# Remove "base" in case you are behind a slow connection.
# Fastest repository comes first, with netselect it is possible to determine
# the fastest repository easily.
# Visit the server to determine which apt components are provided.
rpm ftp://mirrors.mathematik.uni-bielefe...inux/suse/apt/ SuSE/9.3-x86_64 update security rpmkeys
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/9.3-x86_64 update security rpmkeys


# The list with all available components can be found at:
# http://linix01.gwdg.de/apt4rpm
# Some components provide experimental software, select wisely!
# http://ftp.gwdg.de/pub/linux/suse/ap...urces.list.FTP

# Consult the link above if you want to include uri's for src rp

su93254144:/etc/apt # apt-get update
apt-get: error while loading shared libraries: librpm-4.1.so: cannot open shared object file: No such file or directory


Now i also can't use yast - i , instaed of apt-get , because when i use yast - i packagename , system asked some missing system libries. Pls try to resolve the atleast yast .
Reply With Quote
  #4  
Old 27th January 2006, 06:55
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

But does
Code:
yast
instead of
Code:
yast -i <package name>
work?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 27th January 2006, 07:13
gimhan90 gimhan90 is offline
Senior Member
 
Join Date: Jan 2006
Posts: 139
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
But does
Code:
yast
instead of
Code:
yast -i <package name>
work?

yast -i packagename -----> pop up a screen (about Package Dependencies ) and mentioned about some libriries are missing. (librpm-4.1.so,libapt-pkg-libc6.3-5.so.2.. )
Reply With Quote
  #6  
Old 27th January 2006, 07:40
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

No, don't use
Code:
yast -i <package name>
, simply run
Code:
yast
(no other parameters)!
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 27th January 2006, 07:50
gimhan90 gimhan90 is offline
Senior Member
 
Join Date: Jan 2006
Posts: 139
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
No, don't use
Code:
yast -i <package name>
, simply run
Code:
yast
(no other parameters)!

yast

pop up the "Yast Control Centre " .

and when i went to the ,

Software ----> Install and Remove Software .

Result---> same missing library files screen was displayed .
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Howto Suse 10 x86_64 and ISPConfig SeaWolf Tips/Tricks/Mods 10 28th January 2006 21:07
The Perfect Setup - SUSE 9.3 (firewall?!) bogdinator HOWTO-Related Questions 7 12th December 2005 12:31
SuSE 10 No Mysql-devel gwendri Installation/Configuration 4 15th November 2005 12:41
Suse 9.3 - Setting up the basics (File and Print Services) creativehook Suggest HOWTO 1 16th October 2005 20:50
Upgrading from SUSE 9.3 to 10.0 dlplnx Installation/Configuration 1 6th October 2005 10:37


All times are GMT +2. The time now is 07:12.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.