Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 18th January 2008, 01:59
agarcia71 agarcia71 is offline
HowtoForge Supporter
 
Join Date: Nov 2006
Posts: 18
Thanks: 2
Thanked 0 Times in 0 Posts
Send a message via MSN to agarcia71
Default OpenLDAP + Samba Domain Controller On Ubuntu 7.10

hi guys:

this is my 3rd day, I tryng to setup my ldap server with this howto. I follow all the steps like the howto

My problem is this: when I run this command
Code:
admon@ldap$ net getlocalsid
got this error:

Code:
[2008/01/17 18:42:30, 0] lib/smbldap.c:smbldap_connect_system(982)
  failed to bind to server ldap://localhost/ with dn="cn=admin,dc=ddiscovery,dc=local" Error: Can't contact LDAP server
        (unknown)
after a few seconds appears the SID

I don't know what I'm doing wrong:

this is my smb.conf

Code:
[global]

workgroup = DDISCOVERY
server string = Domain Server (Samba, Ubuntu)
dns proxy = no
passdb backend = ldapsam:ldap://localhost/

obey pam restrictions = no
#Begin: Custom LDAP Entries
ldap admin dn = cn=admin,dc=ddiscovery,dc=local
ldap suffix = dc=ddiscovery, dc=local
ldap group suffix = ou=Groups
ldap user suffix = ou=Users
ldap machine suffix = ou=Computers
ldap idmap suffix = ou=Users
; Do ldap passwd sync
ldap passwd sync = Yes
passwd program = /usr/sbin/smbldap-passwd %u
passwd chat = *New*password* %n\n *Retype*new*password* %n\n *all*authentication*tokens*updated*
add user script = /usr/sbin/smbldap-useradd -m "%u"
ldap delete dn = Yes
delete user script = /usr/sbin/smbldap-userdel "%u"
add machine script = /usr/sbin/smbldap-useradd -w "%u"
add group script = /usr/sbin/smbldap-groupadd -p "%g"
delete group script = /usr/sbin/smbldap-groupdel "%g"
add user to group script = /usr/sbin/smbldap-groupmod -m "%u" "%g"
delete user from group script = /usr/sbin/smbldap-groupmod -x "%u" "%g"
set primary group script = /usr/sbin/smbldap-usermod -g "%g" "%u"
domain logons = yes
# End: Custom LDAP Entries

  invalid users = root
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\sUNIX\spassword:* %n\n Retype\snew\sUNIX\spassword:* %n\n passwd:*password\supdated\ssuccessfully* .
logon path =

# Other parameters have default configuration
I'll apreciate any help!!!


PD: sorry abount my english.
Reply With Quote
Sponsored Links
  #2  
Old 18th January 2008, 13:51
o.meyer o.meyer is offline
Senior Member
 
Join Date: Aug 2007
Posts: 167
Thanks: 2
Thanked 24 Times in 23 Posts
Default

Hi agarcia71,

please paste the output of

Code:
cat /etc/smbldap-tools/smbldap_bind.conf
Best regards,

Olli
Reply With Quote
  #3  
Old 19th January 2008, 02:02
agarcia71 agarcia71 is offline
HowtoForge Supporter
 
Join Date: Nov 2006
Posts: 18
Thanks: 2
Thanked 0 Times in 0 Posts
Send a message via MSN to agarcia71
Default

Hi o.meyer

We found that the daemons smb and nmbd starts but they are didn't listen, and when we restart both daemons again we got this error:

Code:
admon@ldap$ sudo /etc/init.d/samba restart
 * Stopping Samba daemons...
start-stop-daemon: warning: failed to kill 3865: No such process            
                                                                                                   [OK]
 * Starting Samba daemons                                                              [OK]
admon@ldap$
Thanks

aGarcia71
Reply With Quote
  #4  
Old 19th January 2008, 02:08
agarcia71 agarcia71 is offline
HowtoForge Supporter
 
Join Date: Nov 2006
Posts: 18
Thanks: 2
Thanked 0 Times in 0 Posts
Send a message via MSN to agarcia71
Default

Hi o.meyer

We think the problem is on smb.conf because after restoring the original configuration for smb.conf the daemons work.

But we still don't found the solution.
Reply With Quote
  #5  
Old 22nd January 2008, 00:05
agarcia71 agarcia71 is offline
HowtoForge Supporter
 
Join Date: Nov 2006
Posts: 18
Thanks: 2
Thanked 0 Times in 0 Posts
Send a message via MSN to agarcia71
Default Help !!!

Plz Help:

This is netstat before doing the smb.conf modification:

Code:
admon@ldap:/etc/samba$ sudo netstat -puta
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name   
tcp        0      0 *:ldap                  *:*                     LISTEN     4888/slapd          
tcp        0      0 *:netbios-ssn           *:*                     LISTEN     5464/smbd           
tcp        0      0 *:microsoft-ds          *:*                     LISTEN     5464/smbd           
tcp6       0      0 *:ldap                  *:*                     LISTEN     4888/slapd          
tcp6       0      0 *:ssh                   *:*                     LISTEN     3826/sshd           
tcp6       0      0 ldap:ssh                ::ffff:10.2.7.1%8:53139 ESTABLISHED4895/sshd: admon [p 
udp        0      0 ldap:netbios-ns         *:*                                5462/nmbd           
udp        0      0 *:netbios-ns            *:*                                5462/nmbd           
udp        0      0 ldap:netbios-dgm        *:*                                5462/nmbd           
udp        0      0 *:netbios-dgm           *:*                                5462/nmbd

doing the step 5 when I restart the samba daemon got this error:

Code:
admon@ldap:/etc/samba$ sudo /etc/init.d/samba restart
 * Stopping Samba daemons...                                                                                                 start-stop-daemon: warning: failed to kill 5279: No such process             [ OK ]                                                                                                                     
 * Starting Samba daemons                                                               [ OK ]
Then I run next command:
Code:
admon@ldap:/etc/samba$ sudo netstat -puta
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name   
tcp        0      0 *:ldap                  *:*                     LISTEN     4888/slapd          
tcp        0      0 localhost:36848         localhost:ldap          TIME_WAIT  -                   
tcp6       0      0 *:ldap                  *:*                     LISTEN     4888/slapd          
tcp6       0      0 *:ssh                   *:*                     LISTEN     3826/sshd           
tcp6       0      0 ldap:ssh                ::ffff:10.2.7.1%8:53139 ESTABLISHED4895/sshd: admon [p 
udp        0      0 ldap:netbios-ns         *:*                                5320/nmbd           
udp        0      0 *:netbios-ns            *:*                                5320/nmbd           
udp        0      0 ldap:netbios-dgm        *:*                                5320/nmbd           
udp        0      0 *:netbios-dgm           *:*                                5320/nmbd           
admon@ldap:/etc/samba$
I Can't see the smb daemon running

This is again my smb.conf
Code:
[global]

workgroup = DDISCOVERY
server string = Domain Server (Samba, Ubuntu)
dns proxy = no
passdb backend = ldapsam:ldap://localhost/

obey pam restrictions = no
#Begin: Custom LDAP Entries
ldap admin dn = cn=admin,dc=ddiscovery,dc=local
ldap suffix = dc=ddiscovery, dc=local
ldap group suffix = ou=Groups
ldap user suffix = ou=Users
ldap machine suffix = ou=Computers
ldap idmap suffix = ou=Users
; Do ldap passwd sync
ldap passwd sync = Yes
passwd program = /usr/sbin/smbldap-passwd %u
passwd chat = *New*password* %n\n *Retype*new*password* %n\n *all*authentication*tokens*updated*
add user script = /usr/sbin/smbldap-useradd -m "%u"
ldap delete dn = Yes
delete user script = /usr/sbin/smbldap-userdel "%u"
add machine script = /usr/sbin/smbldap-useradd -w "%u"
add group script = /usr/sbin/smbldap-groupadd -p "%g"
delete group script = /usr/sbin/smbldap-groupdel "%g"
add user to group script = /usr/sbin/smbldap-groupmod -m "%u" "%g"
delete user from group script = /usr/sbin/smbldap-groupmod -x "%u" "%g"
set primary group script = /usr/sbin/smbldap-usermod -g "%g" "%u"
domain logons = yes
# End: Custom LDAP Entries

  invalid users = root
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\sUNIX\spassword:* %n\n Retype\snew\sUNIX\spassword:* %n\n passwd:*password\supdated\ssuccessfully* .
logon path =
# Other parameters have default configuration
I still don't know what is the problem, please helpme

Best regards,

aGarcia71
Reply With Quote
  #6  
Old 22nd January 2008, 14:40
o.meyer o.meyer is offline
Senior Member
 
Join Date: Aug 2007
Posts: 167
Thanks: 2
Thanked 24 Times in 23 Posts
Default

Hi agarcia71,

please try this global section:

Code:
[global]
        workgroup = DDISCOVERY
        netbiosname = PDC-SRV-DDISCOVERY
        preferred master = yes
        os level = 65
        wins support = yes
        enable privileges = yes
        timeserver = yes
	socket options = SO_KEEPALIVE IPTOS_LOWDELAY SO_SNDBUF=8192 SO_RCVBUF=8192
        log level = 3
        null passwords = yes
        # unix charset = ISO8859-1
        name resolve order = bcast host
        domain logons = yes
        domain master = yes
        printing = cups
        printcap name = cups
        logon path = \\%N\profiles\%u
        logon script = logon.bat
	logon drive = H:
        map acl inherit = yes
        nt acl support = yes
        passdb backend = ldapsam:ldap://127.0.0.1/
        obey pam restrictions = no

        ldap admin dn = cn=admin,dc=ddiscovery,dc=local
        ldap suffix = dc=ddiscovery,dc=local
        ldap group suffix = ou=Groups
        ldap user suffix = ou=Users
        ldap machine suffix = ou=Computers
        ldap idmap suffix = ou=Users
        ldap passwd sync = yes
        ldap delete dn = yes

        passwd program = /usr/sbin/smbldap-passwd -u %u
        passwd chat = "Changing password for*\nNew password*" %n\n "*Retype new password*" %n\n

        add user script = /usr/sbin/smbldap-useradd -m "%u"
        add user to group script = /usr/sbin/smbldap-groupmod -m "%u" "%g"
        set primary group script = /usr/sbin/smbldap-usermod -g "%g" "%u"
        add group script = /usr/sbin/ambldap-groupadd -p "%g"
        add machine script = /usr/sbin/smbldap-useradd -w "%u"

        delete user script = /usr/sbin/smbldap-userdel "%u"
        delete user from group script = /usr/sbin/smbldap-groupmod -x "%u" "%g"
        delete group script = /usr/sbin/smbldap-groupdel "%g"
Best regards,

Olli
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Roaming Profile Error with Samba Domain Controller Setup noahlau HOWTO-Related Questions 6 8th March 2008 18:33
Ubuntu 7.10 LDAP Samba question netwerkdude HOWTO-Related Questions 0 6th January 2008 22:35
samba domain controller - ubuntu eoij1 HOWTO-Related Questions 3 6th October 2006 14:35
Configure Linux client to join a Samba domain controller denny_lin Installation/Configuration 1 9th June 2006 12:31
SAMBA domain controller / CUPS gradedcheese HOWTO-Related Questions 14 8th March 2006 09:21


All times are GMT +2. The time now is 10:19.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.