Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th January 2008, 13:17
smilem smilem is offline
Member
 
Join Date: Jan 2008
Posts: 52
Thanks: 1
Thanked 0 Times in 0 Posts
Exclamation can't login to ispconfig admin invalid certificate?

I managed to sucessfuly install ISPconfig on CentOS 5.1, using this tutorial
http://www.howtoforge.com/centos-5.1...-ftp-ispconfig installations was OK no errors etc.

But when I try to get to admin (I use firefox) I get this error:

https://192.168.1.11:81/

my host is like tutorial: server1

Could not establish encrypted connection because certificate presented by 192.168.1.11 has an invalid signature

My setting for ISPconfig:

Please enter your MySQL server: localhost or I shoud have entered server1?
Please enter your MySQL user: root
Please enter your MySQL password: <MySQLpassword>
Please enter a name for the ISPConfig database: db_ispconfig
Please enter the IP address of the ISPConfig web: 192.168.1.11
Please enter the host name: server1 or I shoud have entered www?
Please enter the domain: somemydomain.com
Please select the protocol (http or https (SSL encryption)) to use to access the ISPConfig system: 1


If I enter http://192.168.1.11:81/

I get:

Hint: https://server1.somemydomain.com:81/

But if click the link I get page unavailable error:

You tried to access the address https://server1.somemydomain.com:81/, which is currently unavailable. Please make sure that the Web address (URL) is correctly spelled and punctuated, then try reloading the page


Here is what I entered during ISPconfig install script:
Code:
wget http://internap.dl.sourceforge.net/sourceforge/ispconfig/ISPConfig-2.2.19.tar.gz
tar xvfz ISPConfig-2.2.19.tar.gz
cd install_ispconfig
./setup


Step0

RSA

Step2

1.Country Name: LT
2. State or Province Name: .
3. Locality Name: .
4. Organization Name: .
5. Organizational Unit Name: .
6. Common Name (eg, CA name): .
7. Email Address (eg, name@FQDN): .
8. Certificate Validity: 365

Step3

3

Step5

1.Country Name: LT
2. State or Province Name: .
3. Locality Name: .
4. Organization Name: .
5. Organizational Unit Name: .
6. Common Name (eg, CA name): .
7. Email Address (eg, name@FQDN): .
8. Certificate Validity: 365

Step6

3

Step7

n

Step8

n

------------------

Enter postmaster address: postmaster@somemydomain.com

host name: server1
domain:    somemydomain.com

HTTPS choose for yes 1
What is wrong? Why secure connection will not work? and I can't access ISPconfig admin panel?

Last edited by smilem; 13th January 2008 at 14:26.
Reply With Quote
Sponsored Links
  #2  
Old 13th January 2008, 15:40
smilem smilem is offline
Member
 
Join Date: Jan 2008
Posts: 52
Thanks: 1
Thanked 0 Times in 0 Posts
Default

I've fixed the login problem by:

I ran commands to make new certificate:
replace "yourpassword" with your own password.
Code:
openssl genrsa -des3 -passout pass:yourpassword -out /root/ispconfig/httpd/conf/ssl.key/server.key2 1024
openssl req -new -passin pass:yourpassword -passout pass:yourpassword -key /root/ispconfig/httpd/conf/ssl.key/server.key2 -out /root/ispconfig/httpd/conf/ssl.csr/server.csr -days 365
openssl req -x509 -passin pass:yourpassword -passout pass:yourpassword -key /root/ispconfig/httpd/conf/ssl.key/server.key2 -in /root/ispconfig/httpd/conf/ssl.csr/server.csr -out /root/ispconfig/httpd/conf/ssl.crt/server.crt -days 365
openssl rsa -passin pass:yourpassword -in /root/ispconfig/httpd/conf/ssl.key/server.key2 -out /root/ispconfig/httpd/conf/ssl.key/server.key
chmod 400 /root/ispconfig/httpd/conf/ssl.key/server.key
Then restarted server using:

/etc/init.d/ispconfig_server restart

Now I can login, but have another

problem1:

Firefox shows a pop-up window that sounds like:

You have attemted to establish connection with "192.168.1.11".
However, the security certificate presented belongs to "mydomain.com". It is possible, though unlikely, that someone may be trying to intercept your communication with this web site.

Is it possible to make it work without this pop up ?

problem2

If I do not log in to console I get something like

set_rtc_mmss: can't update from 1 to 59
set_rtc_mmss: can't update from 2 to 59
set_rtc_mmss: can't update from 3 to 59
and so on

How to fix this?

problem3
When I shut down or restart system

Starting killall: Shutting down posfix [FAILED]

problem4
When system boots I get these 2 errors:

error1

Starting proftpd: Warning: Handling possibly truncated configuration data at line 67
'/etc/proftpd.conf'

Line 67 is:
Code:
ServerIdent on "FTP Server ready."
error2

Starting monitoring for VG VolGroup00: /dev/hdc: open failed: Read only file system
2 logical volume(s) in volume group "VolGroup00" monitored

Last edited by smilem; 13th January 2008 at 19:18.
Reply With Quote
  #3  
Old 14th January 2008, 11:10
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,011
Thanks: 826
Thanked 5,378 Times in 4,225 Posts
Default

Quote:
Is it possible to make it work without this pop up ?
Yes, buy officially signer dertificate.

Quote:
problem2
Is this VM? Then its normal, you can not update the realtime clock from within a VM.

Quote:
problem4
Addd a new empty line after this line.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 14th January 2008, 23:12
smilem smilem is offline
Member
 
Join Date: Jan 2008
Posts: 52
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
Yes, buy officially signer dertificate.



Is this VM? Then its normal, you can not update the realtime clock from within a VM.



Addd a new empty line after this line.
problem2 - yes this is virtual machine
what about problem 3?

problem4 - I edded empty line and got the same problem, however I fixed the problem by correcting error in
script /etc/init.d/proftpd

I had entered: [ $NETWORKING = "no" ] && exit 0
Instead of: [ ${NETWORKING} = "no" ] && exit 0

And I had: echo "Usage: $prog start|stop|restart|reload|condrestart|status"
Istead of: echo "Usage: $prog {start|stop|restart|reload|condrestart|status}"

So problems 4 and 2 fixed What about problem 3 - should postfix shutdown fail?

Last edited by smilem; 15th January 2008 at 00:01.
Reply With Quote
  #5  
Old 15th January 2008, 08:14
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,011
Thanks: 826
Thanked 5,378 Times in 4,225 Posts
Default

Quote:
what about problem 3?
Do you get any error messages in the mail log file?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 15th January 2008, 15:33
smilem smilem is offline
Member
 
Join Date: Jan 2008
Posts: 52
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
Do you get any error messages in the mail log file?
Please in future posts can you specify the path to the file you ask for?

Here is /var/log/maillog
Code:
Jan 15 00:26:26 server1 freshclam[2859]: -------------------------------------- 
Jan 15 00:29:44 server1 dovecot: Killed with signal 15
Jan 15 14:24:17 server1 dovecot: Dovecot v1.0.rc15 starting up
Jan 15 14:24:18 server1 sendmail[2240]: alias database /etc/aliases rebuilt by root
Jan 15 14:24:18 server1 sendmail[2240]: /etc/aliases: 76 aliases, longest 10 bytes, 765 bytes total
Jan 15 14:24:21 server1 postfix/postfix-script: starting the Postfix mail system
Jan 15 14:24:21 server1 postfix/master[2293]: daemon started -- version 2.3.3, configuration /etc/postfix
Jan 15 14:24:56 server1 postfix/postfix-script: stopping the Postfix mail system
Jan 15 14:24:56 server1 postfix/master[2293]: terminating on signal 15
Jan 15 14:24:56 server1 sendmail[2710]: alias database /etc/aliases rebuilt by root
Jan 15 14:24:56 server1 sendmail[2710]: /etc/aliases: 76 aliases, longest 10 bytes, 765 bytes total
Jan 15 14:24:58 server1 postfix/postfix-script: starting the Postfix mail system
Jan 15 14:24:58 server1 postfix/master[2756]: daemon started -- version 2.3.3, configuration /etc/postfix
Jan 15 14:25:04 server1 freshclam[2840]: freshclam daemon 0.92 (OS: linux-gnu, ARCH: i386, CPU: i686) 
Jan 15 14:25:04 server1 freshclam[2840]: ClamAV update process started at Tue Jan 15 14:25:04 2008 
Jan 15 14:25:04 server1 freshclam[2840]: main.cvd is up to date (version: 45, sigs: 169676, f-level: 21, builder: sven) 
Jan 15 14:25:04 server1 freshclam[2840]: daily.inc is up to date (version: 5483, sigs: 21693, f-level: 21, builder: acab) 
Jan 15 14:25:04 server1 freshclam[2840]: --------------------------------------
Reply With Quote
  #7  
Old 15th January 2008, 15:35
smilem smilem is offline
Member
 
Join Date: Jan 2008
Posts: 52
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
Do you get any error messages in the mail log file?
Hope this is the file you ask, could you please specify the path to the file you ask for?

/var/log/maillog
Code:
Jan 15 00:26:26 server1 freshclam[2859]: -------------------------------------- 
Jan 15 00:29:44 server1 dovecot: Killed with signal 15
Jan 15 14:24:17 server1 dovecot: Dovecot v1.0.rc15 starting up
Jan 15 14:24:18 server1 sendmail[2240]: alias database /etc/aliases rebuilt by root
Jan 15 14:24:18 server1 sendmail[2240]: /etc/aliases: 76 aliases, longest 10 bytes, 765 bytes total
Jan 15 14:24:21 server1 postfix/postfix-script: starting the Postfix mail system
Jan 15 14:24:21 server1 postfix/master[2293]: daemon started -- version 2.3.3, configuration /etc/postfix
Jan 15 14:24:56 server1 postfix/postfix-script: stopping the Postfix mail system
Jan 15 14:24:56 server1 postfix/master[2293]: terminating on signal 15
Jan 15 14:24:56 server1 sendmail[2710]: alias database /etc/aliases rebuilt by root
Jan 15 14:24:56 server1 sendmail[2710]: /etc/aliases: 76 aliases, longest 10 bytes, 765 bytes total
Jan 15 14:24:58 server1 postfix/postfix-script: starting the Postfix mail system
Jan 15 14:24:58 server1 postfix/master[2756]: daemon started -- version 2.3.3, configuration /etc/postfix
Jan 15 14:25:04 server1 freshclam[2840]: freshclam daemon 0.92 (OS: linux-gnu, ARCH: i386, CPU: i686) 
Jan 15 14:25:04 server1 freshclam[2840]: ClamAV update process started at Tue Jan 15 14:25:04 2008 
Jan 15 14:25:04 server1 freshclam[2840]: main.cvd is up to date (version: 45, sigs: 169676, f-level: 21, builder: sven) 
Jan 15 14:25:04 server1 freshclam[2840]: daily.inc is up to date (version: 5483, sigs: 21693, f-level: 21, builder: acab) 
Jan 15 14:25:04 server1 freshclam[2840]: --------------------------------------
Reply With Quote
  #8  
Old 16th January 2008, 11:11
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by smilem
problem3
When I shut down or restart system

Starting killall: Shutting down posfix [FAILED]
That's a common problem on RedHat-based distros. Does Postfix come up again with a different PID? Then everything's fine.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 16th January 2008, 21:02
smilem smilem is offline
Member
 
Join Date: Jan 2008
Posts: 52
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
That's a common problem on RedHat-based distros. Does Postfix come up again with a different PID? Then everything's fine.
How do I check that it comes with a different PID? What is PID?
Reply With Quote
  #10  
Old 17th January 2008, 09:25
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,011
Thanks: 826
Thanked 5,378 Times in 4,225 Posts
Default

PID means process ID. You will get a list of all processes including their process ID's with the command:

ps -aux
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
initial admin login incorrect mgburr General 16 1st September 2008 00:14
ISPConfig 2.3.2-dev released till General 9 4th June 2007 10:46
ispconfig subdomain link to login bezier Installation/Configuration 1 28th May 2007 14:13
Details on problem /mailuser login and more (long) linutzy Installation/Configuration 11 15th February 2006 18:45
Total Frustration-HELP palkat Installation/Configuration 17 3rd September 2005 17:28


All times are GMT +2. The time now is 12:06.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.