Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 10th January 2008, 08:21
joephus joephus is offline
Junior Member
 
Join Date: Jan 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default su hangs after ISPConfig install

After installing ISPConfig, whenever I su to another user the shell just hangs, I can ctrl-break out of it and return to my original shell, but otherwise it just hangs with no prompt. Normally I could figure this out by going through my logs, but here is the kicker, I've always set root to nologin. This means that even on a console session you have to su to root and set the shell to get root access. This behavior is the same regardless of what shell (bash, ksh, tcsh, etc.) I use or what user I try to su to, but I'm not sure if this unique to nolgin users or not since I only have one that I know the password for. I know the ISPConfig setup creates the admispconfig user, but you never get prompted to set the password for this user and the passwords you are prompted to set don't work for that user. So i'm not sure if it is exclusive to nologin or not.

Relevant SysInfo:
CentOS 4.6
MYSQL 5.0.45
Apache 2.2.6
PHP 2.2.0

ISPConfig was fully functional.

TIA for any help...
Reply With Quote
Sponsored Links
  #2  
Old 10th January 2008, 14:01
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

ISPConfig does not manage any su settings and I never seen that before. Maybe your /etc/passwd file is corrupted. The admispconfig user can not be used to login.

Do you have a rescue system on that server or can you boot from a linux CD to chech the passwd file?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 10th January 2008, 20:09
joephus joephus is offline
Junior Member
 
Join Date: Jan 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Since it was a fairly new server, I just went with a fresh install. It had the guys over at CentOS stumped too. Thanks though!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
New ISPConfig Install nubtool Installation/Configuration 15 18th May 2008 17:46
ISPConfig install continues to fail jervolpe Installation/Configuration 3 6th July 2007 13:17
Backup ispconfig, change ip and new install metaldrummer Installation/Configuration 1 8th June 2007 12:19
ISPConfig install error: The PHP binary coming with ISPConfig does not work... mlanglois Installation/Configuration 9 13th July 2006 15:56
Install ISPConfig on an already configured server? freedog96150 Installation/Configuration 2 7th July 2006 12:09


All times are GMT +2. The time now is 02:17.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.