Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 4th January 2008, 08:45
bas bas is offline
Junior Member
 
Join Date: Jan 2008
Location: Amsterdam
Posts: 12
Thanks: 1
Thanked 0 Times in 0 Posts
Default Problem with email delivery new install - ubuntu 7.10

Hello

I have followed the setup for the perfect setup. And all went quite smooth. Have been adding domains and email addresses. And was about to switch over my server. Then I tried to test email delivery. And as much as all seems to go without problems in the log. The mail doesnt get delivered (at least not in the right place.

Just FYI - right now i have an old linux server running with a cyrus setup - that I want to migrate to the ISPconfig install.
The websites are already all working - and creating email addresses seemed to work as well.

I'm running ISPconfig version: 2.2.18
I did turn on Maildir in the settings of ISPconfig - but i only did after creating the accounts.

I can't see where it's going wrong. Some of the mails i tried are delivered in /var/mail/xxx
But can't find all of them there - and there are no delivery errors.

Hope someone can help - since i am not sure where to look now.

Thanks
Bas
here are the lines from the mail.info log:

Jan 4 01:23:03 bb postfix/smtp[13676]: 3E0791754097: to=<web7_mike@mail.q#####.com>, orig_to=<>, relay=mail.q#####.com[]:25, delay=0.56, delays=0.04/0.03/0.12/0.36, dsn=2.0.0, status=sent (250 Ok: queued as 097F78EB0C2)

Jan 4 01:23:03 bb postfix/smtp[13676]: 3E0791754097: to=<web7_mike@mail.q#####.com>, orig_to=<>, relay=mail.q#####.com[]:25, delay=0.56, delays=0.04/0.03/0.12/0.36, dsn=2.0.0, status=sent (250 Ok: queued as 097F78EB0C2)


this is my main.cf file:
smtpd_banner = $myhostname ESMTP $mail_name
biff = no
# appending .domain is the MUA's job.
append_dot_mydomain = no
# TLS parameters
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache


myhostname = mail.q#####.com
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = mail.q#####.com, localhost.q#####.com, localhost
relayhost =
mynetworks = 127.0.0.0/8
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination
# , check_policy_service inet:127.0.0.1:60000
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

virtual_maps = hash:/etc/postfix/virtusertable

mydestination = /etc/postfix/local-host-names
Reply With Quote
Sponsored Links
  #2  
Old 4th January 2008, 11:05
bas bas is offline
Junior Member
 
Join Date: Jan 2008
Location: Amsterdam
Posts: 12
Thanks: 1
Thanked 0 Times in 0 Posts
Default Extra info

Just as extra info

I test the mail delivery by using a telnet client to connect to port 25 and give a mail by hand

helo <dns name>
MAIL FROM: <naam@domain.com>
RCPT TO: <account@hosteddomain.com>
DATA
skjflksjd
.

The mail is accepted and queued
can't find it after that anymore
(i would presume it should be processed locally and delivered)

Thanks
Bas
Reply With Quote
  #3  
Old 4th January 2008, 11:18
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,792
Thanks: 821
Thanked 5,337 Times in 4,187 Posts
Default

Please uncomment the line

mydestination = mail.q#####.com, localhost.q#####.com, localhost

in main.cf and restart postfix. then make sure that /etc/mailname contains the correct hostname (mail.q#####.com) and that this hostname is returned when you execute the commands:

hostname
hostname -f

Then make sure that you have a line for mail.q#####.com in /etc/hosts that points to the IP of the server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 4th January 2008, 12:13
bas bas is offline
Junior Member
 
Join Date: Jan 2008
Location: Amsterdam
Posts: 12
Thanks: 1
Thanked 0 Times in 0 Posts
Default thanks - no succes yet

thanks for your quick response.

I have unquoted the line in main.cf (the mydestination)

checked the hosts file. Both localhost and the ipnr are linked to mail.q#####.com, localhost.q#####.com, localhost

and hostname returns mail.q#####.com,
hostname -f returns localhost


Still the log now complains that the host or domain is not found. Name service error for name=mail.q#####.com type=MX: host not found)

I should add that at this moment the machine is not connected to the internet - as that domain on the internet would still point to my old server. But i think that in this case the hosts file should be sufficient

thanks very much for the help already
Bas

Quote:
Originally Posted by till
Please uncomment the line
mydestination = mail.q#####.com, localhost.q#####.com, localhost

in main.cf and restart postfix. then make sure that /etc/mailname contains the correct hostname (mail.q#####.com) and that this hostname is returned when you execute the commands:

hostname
hostname -f

Then make sure that you have a line for mail.q#####.com in /etc/hosts that points to the IP of the server.
Reply With Quote
  #5  
Old 4th January 2008, 12:25
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,792
Thanks: 821
Thanked 5,337 Times in 4,187 Posts
Default

Hostname -f must return the correct hostname and not localhost. To fix this, edit or create the file /etc/hostname and put the hostname mail.q#####.com there. then run:

hostname -F /etc/hostname

Afterwards, change anything in the mail account inside ispconfig, e.g. the quota and save the cahnges, so that the config files get rewritten.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
bas (4th January 2008)
  #6  
Old 4th January 2008, 14:17
bas bas is offline
Junior Member
 
Join Date: Jan 2008
Location: Amsterdam
Posts: 12
Thanks: 1
Thanked 0 Times in 0 Posts
Default

thanks very much
that seemed to have resolved it

just a small question - right now i have in the hosts file the 127.0.0.1 - and the ip of my internal network linked to the ISPconfig host. When i put it online - i guess i should also put the external ipnumber of the site there.

Thanks again
Bas
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPconfig install problem - ubuntu 7.04 - perfect setup The Godfather Installation/Configuration 2 4th September 2007 09:48
postfix email problem Andee63 Installation/Configuration 10 27th March 2007 17:09
Email Questions & Problem koltz General 6 25th February 2007 00:07
First time install problem zxspec Installation/Configuration 2 19th January 2007 01:38
install problem on FC5 PortMan Installation/Configuration 2 27th June 2006 12:07


All times are GMT +2. The time now is 20:42.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.